cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1366
Views
0
Helpful
3
Replies
Highlighted
Beginner

vrf lite default route

I have two vrf lite instances and I want each vrf lite instance to have its own default route to the provider internet.Provider is providing two VLANs and each VLAN has access to Internet.When I remove the global default route I am not able to get out to Internet any advice will be appreciated.


ip vrf Corp

rd 64616:10

routetarget export 64616:10

routetarget import 64616:10

!

ip vrf Test

rd 64615:10

routetarget export 64615:10

routetarget import 64615:10

!

interface Loopback10

ip vrf forwarding Corp

no ip address

!

interface GigabitEthernet0/0

description To  Production Network (150MB circuit)

ip vrf forwarding Corp

ip address 63.234.13.129 255.255.255.128

duplex auto

speed auto

!

interface GigabitEthernet0/1

description To  DMZ Network (150MB circuit)

ip vrf forwarding Corp

ip address 65.115.72.225 255.255.255.224

duplex auto

speed auto

!

interface GigabitEthernet0/2

description To  Test Network 50Mbps

ip vrf forwarding Test

ip address 65.115.72.193 255.255.255.224

duplex auto

speed auto

!

interface GigabitEthernet0/0/0

description To Provider

no ip address

negotiation auto

!

interface GigabitEthernet0/0/0.50

description Production IP Block Provider VLAN 50 150Mbps

encapsulation dot1Q 50

ip vrf forwarding Corp

ip address 63.235.163.6 255.255.255.252

!

interface GigabitEthernet0/0/0.51

description Test IP Block Provider VLAN 51 50Mbps

encapsulation dot1Q 51

ip vrf forwarding Test

ip address 63.235.163.2 255.255.255.252

!

ip route 0.0.0.0 0.0.0.0 63.235.163.5

ip route vrf Test 0.0.0.0 0.0.0.0 63.235.163.1

ip route vrf Corp 0.0.0.0 0.0.0.0 63.235.163.5

3 REPLIES 3
Highlighted
Rising star

vrf lite default route

When you remove the global default route you lose connectivity within the VRFs? How are you testing it?

Daniel Dib
CCIE #37149

Please rate helpful posts.

Daniel Dib
CCIE #37149
CCDE #20160011

Please rate helpful posts.
Highlighted
Beginner

vrf lite default route

When i remove global default i am not able to go to Internet from each vrf. I am putting laptop with public assigned block from

provider for each of the vrf.I don't want any connectivity between the vrfs.I just want each vrf to have default route to Internet.

Highlighted
Rising star

vrf lite default route

Hi Anuj,

I am looking at your configuration, but I don't see any reason to loose internet connection when you remove default route from global routing table.

Could you please upload entire router config and also detail process of how you test the connectivity. I mean, configuration change, output of show ip route, port where you connect your laptop, ip addresses which you assign to laptop, etc...

Best Regards

Please rate all helpful posts and close solved questions

Best Regards Please rate all helpful posts and close solved questions
CreatePlease to create content
Content for Community-Ad

Cisco COVID-19 Survey