cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3641
Views
4
Helpful
6
Replies

Problem with portal guest Cisco ISE

andres.salesa1
Beginner
Beginner

Hi,

We just installed Cisco ISE 2.2 patch2.


Version 2.2.0.470

Installed Patches 1,2

Product Identifier (PID) ISE-VM-K9

Version Identifier (VID) V01

ADE-OS Version 3.0.2.218

We have the basic/wired license (no posture and no profiling)


Access to the guest portal is done with a username and password and we create them through the sponsor portal.

When an external guest client tries to access the guest portal. The portal asks the guest user to install the latest version of Java.

Is it normal behavior? Do I need to have java? It is not feasible for all external users to have the JAVA version to access an invited portal.

This happens in Windows 7 and Windows 10 environments with the latest versions of IE, Mozilla and Chrome.

Can somebody help me?


thank you

1 Accepted Solution

Accepted Solutions

Go to your portal open settings there and find :

Screenshot-2017-10-13 Identity Services Engine.png

View solution in original post

6 Replies 6

Arne Bier
VIP
VIP

Hi Andres

Do you have some screenshots of this happening?

Your deployment sounds almost identical to mine.  There is no requirement for Java on the client side - it's just HTML that gets presented to the end device.  I have connected MACOS , Win7 through 10, Android Phones (no Java), Apple Phones (no Java).

Are you sure this is triggered by ISE, or by the client's OS ?

The ISE Admin GUI requires Adobe Flash for a few functions and you will be prompted for that.  But even that doesn't require Java on the client side.  There may be some Java Script that runs in the browser but to my knowledge that does not require you to install the JRE from www.java.com

If anything, rest assured that since Apple iOS does NOT run Java, they connect just fine to an ISE Guest Portal 

Hi Arne,

I have attached some screenshots.

Even installing the latest version of java 8. Continue requesting Java installation with all browsers (Mozilla, Chrome and IE)

The problem comes through the guest portal. Users who leave this message have no problem to navigate or perform their tasks.

I tested it with Android phones and Iphone. And we can access the portal and navigate without problems. Do not request anything additional.

Java should not be mandatory. Being new to the tool and newly installed. I do not know, if it is something normal, a bug, etc.

Regards

Did you check your guest portal and see if its requiring compliance or BYOD? If it is uncheck that.

Hi,

Excuse my ignorance. I have the base license.

The option to require compliance can not be found by any menu option. I am not clear that these options go with my license.

Could you tell me where I can locate this option?

Regards

Go to your portal open settings there and find :

Screenshot-2017-10-13 Identity Services Engine.png

Hi have ISE 3.1.0.518 and i have this issue too and this solution do not work for me.

Someone can help me please

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: