cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

9818
Views
20
Helpful
52
Replies
Highlighted
Community Manager

Ask the Expert: CiscoWorks Prime LAN Management Solution - Implementation, Configuration, and Troubleshooting

CiscoWorks Prime LAN Management Solution: Implementation, Configuration, and TroubleshootingWith Vinod Arya

Welcome to the Cisco Support Community Ask the Expert conversation. This is an opportunity to learn and ask questions about the design, configuration, and troubleshooting of CiscoWorks Prime LAN Management Solution with Cisco expert Vinod Arya. He can cover questions about Cisco Prime LMS, including initial portal login and use of the Getting Started workflow to configure the server. He will also demonstrate how to explore and customize the dashboards in My Menu, manage portlets, and change the portal layout.

This is a continuation of the live webcast.

Vinod Arya is a High Touch Technical Support (HTTS) engineer in Cisco’s Focused Technical Support (FTS) organization working on Network Management System (NMS) products and technologies. His current focus is on planning and implementing Network Management Infrastructure(s). His areas of expertise also include NMS products and technologies such as the CiscoWorks LAN Management Solution (LMS), Simple Network Management Protocol (SNMP), IP, Service-Level Agreements (SLAs), Cisco Prime Provisioning, Cisco Network Registrar, and many others. He has more than 7 years of experience in IT. Prior to joining Cisco’s HTTS NMS team, Arya worked for Convergys India Pvt Ltd managing and optimizing the Optus Broadband Network. From there he joined HCL Technologies, working with its local switching team before moving on to the Network Management Team. He was also part of its Technical Assistance Center (TAC). Arya holds a Bachelor’s degree in Information Technology from Kumanun University in Nainital, India, and a MBA in Information Technology from Sikkim Manipal University in Bangalore, India. He holds several Cisco Certifications, including CCNA® and VCP 5.0..

Webcast related links:

52 REPLIES 52
Highlighted
Beginner

Ask the Expert: CiscoWorks Prime LAN Management Solution - Impl

Hello Vinod

Thanks for a very good presentation. We have been already using LMs4.2 on our production for some time but I stiil have some things I would like to check with you.

1  - Every time a device IP address or hostname changes on  LMS just assumes it is down. Is there anyway to prevent this from happening - I mean a way to inform LMS about the update that has occured?

2 - When upgrading software (IOS) LMS flags the upgrade as failed but the IOS is loaded correctly  - after a reload everything is fine.  Is there anyway to avoid this? - have tried several things suggested in the Support Community  -  hanging the timeouts of telnet etc but nothings seems to work. Have looked in the logs as suggested by LMS but no luck until now.

Switches 2960S PS-L

IOS 15.0.2.2

3 - When an error is acknowledged (ex. switch down during maintenance) is it possible to take away from the faults view list?

Best regards

Isaac

Highlighted
Cisco Employee

Ask the Expert: CiscoWorks Prime LAN Management Solution - Impl

Hello Isaac,

Thank you for your compliment. Following are the answers for your questions :

1. I'm not very clear about you statement "Every time a device IP address or hostname changes". If this means :

     a. The managed IP of the device is changed OR

     b. The IP configured on the device interface is changed to some other IP Address.

if,

(a.), than ubfortunately there is no such provision, as if the IP address by which device is managed in LMS, it is changed and if not reachable it may consider it down and generate alert for device. We need to update device in DCR to prevent this.

(b.) Interfaces managed by fault management are changed and not reachable, LMS untill the next device redicovery schedule. If there is a planned change of those managed IPs, you can unmanage the IP's from Fault Management to avoid alerts.

2. When we run a SWIM job, there are a lot of job options which can be selected, even if a single option is not successful, entire job status may go to failed, but the upgrade process may be successful. As you said when you reboot the device, the device works fine. So, in Job option you have selected Reboot Device option, you need to have

snmp-server system-shutdown command configured on device, else it may fail. LMS uses snmp to reboot the server.

3. You have to manually clear the alerts. Ack may not remove it. When you clear a alert, it will be removed from the window. You can however can still view those ack or cleared messages in history report when needed, upto 31 days.

-Thanks

Vinod

-Thanks Vinod **Rating Encourages contributors, and its really free. **
Highlighted
Beginner

Ask the Expert: CiscoWorks Prime LAN Management Solution - Impl

Hello Vinod

1 - My case is what you describe in a). In PI it is ok for an AP to change ip address. PI detects that the device is the same just with a different IP address and is stated as up. I was wondering if it wasn't the possible to do the same on LMS (but with our switched network).

Some other times what we do is that we upgrade or change the hardware ex. changing a 2960 for a 2960S but we keep the same ip address and hostname. In that case LMS states the device as faulty and is not able to detect that there is one new device with the same management ip address, The only way I have found is to delete the original device and to run a new discover.

2 - I don't reboot as part of the task cause during the day I have too many users online. The only thing that the task has to accomplish is to upgrade the IOS but still fails. I have tested the snmp-server system-shutdown but did'nt help.

3 - Thanks for your answers.

Best wishes

Isaac

Highlighted
Cisco Employee

Ask the Expert: CiscoWorks Prime LAN Management Solution - Impl

Hello Isaac,

Hope you are doing good!

Cisco PI is an evolved WCS/NCS and hence it is the part of Cisco Unified Wireless Network (CUWN) where all LAP gets registered with it and communicate regularly with a tunnel. These LAPs cannot act independently and hence NCS/CPI have real time information about them. Whereas in Cisco Prime LMS after device is added each module

communicates to it via different modules for different management aspects.

If we change the entire hardware, previous LMS used to show it in conflicted devices, by figuring out different sysObjectID of the new platform, but now, this feature doesnt seems proper and hence re-add is a solution. No need to run discovery, but deleting and re-adding manually may fix issue. Also, I havent tried, but if you correct the

sysObjectID of the new hardware manually it should work. For it you can select device from :

Inventory --> add/import manage device --> select device --> edit identity --> change device type

I guess hence once LMS entire features are merged with CPI, it will be best of both worlds.

2. I gave an example of failure like when people opt for reboot and this command is not configured and also the entire task in overall may be successful except just an option. Though for the exact reason we would need the debug logs.

-Thanks

Vinod

-Thanks Vinod **Rating Encourages contributors, and its really free. **
Highlighted
Beginner

Re: Ask the Expert: CiscoWorks Prime LAN Management Solution -

Hello Vinod

Thank for you the time you are using to help us

In attachment you will find the logs requested.

Thanks for your support.

Isaac

Highlighted
Cisco Employee

Re: Ask the Expert: CiscoWorks Prime LAN Management Solution -

Hello Isaac,

Thanks for the update.

Ask the Expert series are intended for specific features, configuraiton and implementation questions for product/technology, whereas we encourage to use discussions for real time troubleshooting.

For this speicific isue, I checked the log you shared, i have following questions :

1. Is this a standalone device or a stacked device? Please share show version from device.

2. Are you using a .tar image to upgrade or .bin?

3. I need following log file :

/var/adm/CSCOpx/files/rme/jobs/swim/3761/HX927432_SW21_telnet.log

Next Action on this issue can be planned after the above answers.

-Thanks

Vinod

-Thanks Vinod **Rating Encourages contributors, and its really free. **
Highlighted
Beginner

Re: Ask the Expert: CiscoWorks Prime LAN Management Solution -

Hello Vinod

Please advise if I should begin a new thread CSC and many thanks for your help.

1 - This is a standalone 2960S. Sh version in attachement.

2 - We are using a tar file.

3 - That log file is the one I sendt one the other thread (also attached here).

Once again thanks for your help

Isaac

Highlighted
Cisco Employee

Ask the Expert: CiscoWorks Prime LAN Management Solution - Impl

Hello Isaac,

Thanks for the update. Please open this device in Device Center in LMS and use the tool snmpwalk and poll it for sysObjectID and share the output.

Also, i need show run | incl snmp-server output from device.

-Thanks

Vinod

-Thanks Vinod **Rating Encourages contributors, and its really free. **
Highlighted
Cisco Employee

Ask the Expert: CiscoWorks Prime LAN Management Solution - Impl

Hello Isaac,

Hope you are doing good and you saw my post.

Being the last day of CSC Ask the Expert today, I want to share what I suspect may be causing problem and want to tell you to try and check.

Sometimes these Stackable devices like 29xx are managed by LMS in default Stack state and hence some operations are used in a way, expecting it to be a stack, where the device may be a singe standalone device.

To manage these device as a standalone device and not as a stack, you should configure device for following command :

no snmp-server sysobjectid type stack-oid

Try to Delete device and re-add to DCR and run the new SWIM job and see if it succeeds.

Please share your output.

-Thanks

-Thanks Vinod **Rating Encourages contributors, and its really free. **
Highlighted
Cisco Employee

Ask the Expert: CiscoWorks Prime LAN Management Solution - Impl

Hello Isaac,

As today is the last day of this Ask the Expert series, I am just curious if you tried the steps suggested.

Please share next update, or start a new CSC discussion thread further for this troubleshooting.

-Thanks

Vinod

-Thanks Vinod **Rating Encourages contributors, and its really free. **
Highlighted
Beginner

Re: Ask the Expert: CiscoWorks Prime LAN Management Solution -

Hello Vinod

I am sorry I didn't reply before but I was not in the office and had no access to LMS. I am now back and have tried the steps you suggested but it's still not possible to upgrade the devs with success.

I have also configured to devices with no snmp-server sysobjectid type stack-oid saved configuration restarted the device and deleted and re added to LMS. Tried also to run Update Inventory but for some reason the device type is not being detected by LMS.

This is the error I get when I am on the Recomending fase:


Software Image Management Notifications
SWIM1107:  This operation requires CONTAINMENT Data in Inventory.
Probable Cause :Device Information Required for the Operation is Not Available in the Inventory.
Recommended Action : Perform Update inventory operation and check whether the required data is shown in Detailed device report.
If so Retry the operation.Else data is Not available from the device.

In attachement you wil find the two files you asked on one of your last threads.

Please advise if I have to continue this discussion somewhere else.

Thanks for bearing with me

Isaac

Highlighted
Beginner

Ask the Expert: CiscoWorks Prime LAN Management Solution - Impl

Our LMS seems to be working for Inventory and Configuration for some of the ME3800x devices, but the icon DCR still shows as question mark. Is it some isssue with the device support or LMS? We have updated RME device packages already.

Highlighted
Cisco Employee

Ask the Expert: CiscoWorks Prime LAN Management Solution - Impl

Hello Joe,

It seems you need to upgrade your mdf device package for ciscoworks. LMS needs new metadata information when new devices which are not day 1 supported are added. Because LMS now supports some device Automatically, for similar supported platform, but it still may not have any associated icon to its sysObjectID.

You can update latest mdf device packages from here:

http://software.cisco.com/download/release.html?mdfid=284259296&flowid=37207&softwareid=283716219&release=Mdf.%201.80&relind=AVAILABLE&rellifecycle=&reltype=latest

Please check and let me know.

-Thanks

-Thanks Vinod **Rating Encourages contributors, and its really free. **
Highlighted
Beginner

Re:Ask the Expert: CiscoWorks Prime LAN Management Solution - I

Hello vinod,

Thanks for reply. I upgraded the mdf which fixed the issue and i see it now with an icon :-).
A must mention is your wonderful web event and slides.

Thx
Joe


Sent from Cisco Technical Support Android App

CreatePlease to create content
Content for Community-Ad