cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2881
Views
0
Helpful
29
Replies
Highlighted
Beginner

Cannot Connect to ANIserver

Hi.

I'm after a reboot on LMS 2.6 server, the CM home page started showing the following message: "Cannot connect to ANI Server since it is down". I followed the procedures as in the thread "Ciscoworks ANI server cannot connect, Joe Clark please help", but, in the end, after I restarted yhe Damon Manager, all seervices came up, except for the ANI database engine. After I started this serrvice manually, it came up, but the ANI.log file reappeared and the message on the CM home became "Please wait... ANIServer is still initializing."

The result for the pdreg command is below:

C:\>pdreg -l ANIDbEngine
        Process      = ANIDbEngine
        Path         = C:\PROGRA~1\CSCOpx\objects\db\win32\dbsrv9.exe
        Flags        =
        Startup      = Started automatically at boot.
        Dependencies = Not applicable

The result for the pdshow command is attached.

Hope Joe Clark or anyone can help me to.

Thanks in advance.

29 REPLIES 29
Highlighted
Hall of Fame Cisco Employee

You cannot start the ANIDbEngine service manually.  Reboot the server, and if the database does not come back up, then post the output of the pdshow command.

Highlighted

Hi, thank you for the reply.

I rebooted the server and the database came up, but the CM Home page still shows the same message: "Please wait... ANIServer is still initializing". I waited for an hour and no change. The ani.log file is there, but I cannot read it. The pdshow exit is attached.

Highlighted

It is getting worse. When I try to launch RME home, a message says "License Server/Daemon Manager is down. Please check license.log for more information."

I think something is preventing the services to come up.

Highlighted
Hall of Fame Cisco Employee

There are no process problems reflected in the pdshow.  All of the required daemons are up.  Post the ani.log and the NMSROOT/MDC/tomcat/logs/stdout.log and stderr.log.

Highlighted

Have you tried restarting the daemon manager? this happened to me before and after restarting the daemon everything seems to be fine.

Highlighted

Yes. I've restarted Daemon Manager anda e

nven rebooted the server. No changes.

Highlighted

I'm running out of disk space, maybe that is the cause of the problems. Please find attached the stdout and the log for the databases.

Highlighted

The disk space problem is solved, but now, besides the ANI server problem, RME Engine does not start. The Windows Event Viewer shows the pollowing message: "Cannot open transaction log file -- No such file or directory". Is there any way to recover these services?

The log files for the  RME are attached.

Thanks.

Highlighted
Hall of Fame Cisco Employee

Your transaction logs are corrupt.  See this document on how you can recover them:

https://supportforums.cisco.com/docs/DOC-8796

The information will be found under "Recovering from a Server Crash."

Highlighted

Thank you. Now RME engine comes up, but the JRM service still does not. CM Home says "Please wait.... ANIServer is still initializing " and RME home says "JRM Service could be down. Check whether JRM services are running".

The pdshow is attached.

Highlighted
Hall of Fame Cisco Employee

Post the jrm.log.  Was the hostname on this server changed recently?

Highlighted

Yes, the server was renamed accordingly to the procedure in http://www.cisco.com/en/US/docs/net_mgmt/ciscoworks_common_services_software/3.0.5/user/guide/diagnos.html#wp1078582. But it worked fine for some time before this problem.

The jrm.log is attached.

Highlighted
Hall of Fame Cisco Employee

Post the outputs of the hostname command and the "pdreg -l CTMJrmServer".

Highlighted

Here it is:

C:\>pdreg -l CTMJrmServer

        Process      = CTMJrmServer

        Path         = C:\PROGRA~1\CSCOpx\bin\cwjava.exe

        Flags        = -cw C:\PROGRA~1\CSCOpx -cw:jre lib/jre -cp:p MDC/tomcat/w

ebapps/rme/WEB-INF/classes,MDC/tomcat/webapps/rme/WEB-INF/lib/ctm.jar,MDC/tomcat

/webapps/rme/WEB-INF/lib/log4j.jar com.cisco.nm.rmeng.jrmwrapper.server.CTMJobMa

nagerServer cwsctx03rjorp

        Startup      = Started automatically at boot.

        Dependencies = RMEDbMonitor jrm TomcatMonitor RMECSTMServer

Content for Community-Ad