cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
20300
Views
0
Helpful
16
Replies

Cisco AnyConnect Client & W11 Client Error Connecting VPN

Hello everyone,

 

After upgrading my Windows 10 laptop to Windows 11, VPN client CiscoAnyConnect stops working.

The error I get is "Connection attempt failed"

I have tried uninstalling and re-installing the application, deleting old registry files and even Cisco folder on %appdata% local path on local Windows User.

Is there any known bug with this? Should I update Cisco AnyConnect Client?

 

I've also tried to set-up a VPN connection through the Windows VPN Profile, setting up L2TP/IPSec as the type of VPN and also using the secret pre-shared key for the profile I'm assigned to. I get the error that the remote computer dropped the connection. I don't get any entries on the logs for L2TP. If I change the VPN profile to IKEv2, I get a log entry stating that the profile only supports IKEv1 and does not support multiple sessions. (This is an old profile I had with different configuration).

 

Any  hand you can provide I'd be more that thankful!

w

1 Accepted Solution

Accepted Solutions

Hello,

 

in the Network Adapters page in Windows 11 there should be a L2TP-IPSec adapter, if you go to Properties --> Security, you can allow several network authentication protocols, you might want to toggle and test different ones...

View solution in original post

16 Replies 16

marce1000
VIP Mentor VIP Mentor
VIP Mentor

 

 - Unfortunately and or for the time being Anyconnect is not yet supported on Windows 11 :

            https://www.cisco.com/c/en/us/support/docs/smb/routers/cisco-rv-series-small-business-routers/smb5457-cisco-anyconnect-secure-mobility-client-supported-operating.html

 M.

Thanks for the answer, I was able to test in another W11 client PC and same error message.

 

Are there any reasons why I cannot set up the VPN connection through Windows directly?

 

Do Cisco Remote Access VPNs only work with Cisco AnyConnect clients, if yes, why would that be?

 

          - It can't be  that difficult to read replies , or can it ?

 M.

Funny cause the one not getting what I'm saying is you....

 

You keep talking about AnyConnect, I'm now talking about THE NATIVE WINDOWS VPN CLIENT.

 

Maybe there are some differences with protocols or something, but that IS NOT in your reply.

 

Please keep you ego aside next time

 

Hello,

 

the native Windows VPN client should, in theory, work. What is your VPN server, is that a Cisco device as well ? If so can you post the running configuration ?

 

That said, Windows 11 is still fairly unexplored, but you might want to try the suggestions in the video linked below. 

 

https://www.youtube.com/watch?v=PTjiwpwTr0A

For more information, follow this guide: https://www.techy.how/tutorials/win11-vpn-not-working A short tutorial on how to fix the VPN not working issue on Windows 11. 🛠️ Equipment I use: (Mic, PC Components, etc.) https://www.techy.how/equipment Wallpaper from this video: ...

Hi George thanks for answering. @Georg Pauwen 

Indeed, my VPN Server is a Cisco ASA device.

It's seems like I will have to create a basic VPN with local users in order to connect via Windows client for now.

Here is the configuration I have on the device, maybe you can find something in there that I don't see hehe:

 

https://paste-bin.xyz/21183

 

Thank you in advance!

Hello,

 

thanks or the config, I'll have a look...

Hello,

 

the first thing I noticed is that you are running release 9.1.x on your ASA, which as far as I recall was released around 2012. So that is rather outdated, the newest release is 9.14.x, I don't know if that resolves your issue, and in how far you are in a position to upgrade.

 

Another thing you could try: I have been messing around with a non-functioning Nvidia RTX 3060 graphics card in Windows 11 during the last couple of days (which is obviously totally unrelated to your issue), but the one thing I got out of it was that I got to know Windows 11's Device Manager pretty well. If you go to Device Manager --> Network Adapters, there are a bunch of WAN Miniport adapters. Try and disable the ones you don't need (you probably only need the L2TP adapter). You might have to reboot the Windows 11 client. Then try and connect the VPN client again...

@Georg Pauwen 

Hey, still no luck disabling the WAN miniports, I still get the error message that the remote computer terminated the connection.

Can you confirm which users by looking at the log I sent are able to log in to the L2TP VPN? 

Don't mind the pre-shared key, I can take a look at it.

 

Thanks

 

PS: Cannot update the ASA honestly

Hello,

 

in the Network Adapters page in Windows 11 there should be a L2TP-IPSec adapter, if you go to Properties --> Security, you can allow several network authentication protocols, you might want to toggle and test different ones...

That actually did the trick, I enabled the lower part of the settings, allowed MS-CHAPv2, and put the pre shared key on advanced tab, worked like a charm and through L2TP/IPSEC, not bad.

 

Thanks! @Georg Pauwen 

Hey @Georg Pauwen 

Sorry to bother back again,

I have a question:

When I connect to the VPN through the native Windows 11 VPN Client, remote desktop connections are stuck at "initiating", do you know why this could be happening?

On the other hand, the Cisco AnyConnect client updated and now it works with W11, when I connect using it, I can do remote desktop just fine, why would that be? 

Hello,

 

does the RDP connection go through the VPN ? If not, in the native Windows 11 client, enable split tunneling (as described in the short video below)...

 

https://www.youtube.com/watch?v=S5XCOS-il3c

Professor Robert McMillen shows you how to setup split tunneling for VPN traffic in Windows 11.

@Georg Pauwen Hey!

That didn't work. 

One thing I've noticed is that the VPN on native client W11 only works when PAP (Unencrypted Password) is enabled.

Would that have anything to do with it?

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers