cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
14562
Views
5
Helpful
11
Replies

Cisco Prime HA secondary

Jose Lucas
Beginner
Beginner

Hello,

is there any way to manually  change HA status on Secondary Prime 2 after initial setup?

CLI commands does not have any option to add high availability configuration after being removed.

Thanks.

1 Accepted Solution

Accepted Solutions

Hi Jose ,

unfortunately There is no cli to reactivate it  .   HA was NOT  deactivated properrly as in the .xml file we can still see the Entries.

everything from  
should be removed after running the "ncs
ha remove"

what is the output of " ncs ha status " ? on both primary and secondary

To remove HA : " ncs ha remove "  without qoutes

Try to run the  "ncs ha remove " command on bot the server and then try to configure the HA on primary and see how it works.

ASAIK  .After removing the HA configuration from CLI . To re-enable the  HA setup , we need to run the  setup again and

there we need to mentioned that it is a secondary server and from the then configure the Primary to point to it.

Thanks-
Afroz
[Do rate the useful post]
****Ratings Encourages Contributors ****

Thanks- Afroz [Do rate the useful post] ****Ratings Encourages Contributors ****

View solution in original post

11 Replies 11

AFROJ AHMAD
Cisco Employee
Cisco Employee

Hi Jose,

How about GUI .

Go to Administration >system settings > High Availability > HA Configuration

haSettings.xml >> file have the HA config

/opt/CSCOlumos/conf/rfm/classes/com/cisco/common/ha/config/

Thanks-
Afroz
[Do rate the useful post]
****Ratings Encourages Contributors ****

Thanks- Afroz [Do rate the useful post] ****Ratings Encourages Contributors ****

Hi Afroz,

I thinks HA configuration from GUI can only be done from Primary Server.

Trying to operate with second option "hasetting.xml", wich parameter do you mean do I need to modify?

Here we have current config:

ade # cat haSettings.xml

ade #

The problem is that the secondary server was installed in HA but was deactivated later (ncs HA remove).

There is no command in the NCS to reactivate it?

Many thanks.

Hi Jose ,

unfortunately There is no cli to reactivate it  .   HA was NOT  deactivated properrly as in the .xml file we can still see the Entries.

everything from  
should be removed after running the "ncs
ha remove"

what is the output of " ncs ha status " ? on both primary and secondary

To remove HA : " ncs ha remove "  without qoutes

Try to run the  "ncs ha remove " command on bot the server and then try to configure the HA on primary and see how it works.

ASAIK  .After removing the HA configuration from CLI . To re-enable the  HA setup , we need to run the  setup again and

there we need to mentioned that it is a secondary server and from the then configure the Primary to point to it.

Thanks-
Afroz
[Do rate the useful post]
****Ratings Encourages Contributors ****

Thanks- Afroz [Do rate the useful post] ****Ratings Encourages Contributors ****

You were right: I have applied "ncs ha remove" and configure again from GUI on Primary Server and now,

CPI-01/admin# ncs ha status

[State] Primary Active [Failover Type] automatic

CPI-02/admin# ncs ha status

[Server] CPI-01(192.168.1.5) [State] Secondary Syncing [Failover Type] automatic

Services on primary server appears to be ok

CPI-01/admin# ncs sta

start   status 

CPI-01/admin# ncs status

Health Monitor Server is running.

Ftp Server is running

Database server is running

Tftp Server is running

Matlab Server is running

NMS Server is running.

Plug and Play Gateway is running.

SAM Daemon is running ...

DA Daemon is running ...

Syslog Daemon is running ...

...but is not the same on Secondary Server

CPI-02/admin# ncs status

Health Monitor Server is running.

Ftp Server is Stopped

Database server is running

Tftp Server is Stopped

Matlab Server is Stopped

NMS Server is stopped.

CNS Gateway with port 11011 is down

CNS Gateway SSL with port 11012 is down

CNS Gateway with port 11013 is down

CNS Gateway SSL with port 11014 is down

Plug and Play Gateway Broker with port 61617 is down

Plug and Play Gateway config, image and resource are down on https

Plug and Play Gateway config, image and resource are down on http

Plug and Play Gateway is stopped.

SAM Daemon is not running ...

DA Daemon is not running ...

Syslog Daemon is not running ...

Finally, how to do start "setup" again on a CIP thas has been already configured?

Many Thanks!

ASAIk , we need to run the setup again for secondary and mentoned this as SECONDARY during the SET ONLY.

Thanks-
Afroz
[Do rate the useful post]
****Ratings Encourages Contributors ****

Thanks- Afroz [Do rate the useful post] ****Ratings Encourages Contributors ****

how can i change HA from automatic to manual using CLI, currently machine is running on secondary server

mtenorio
Beginner
Beginner

@Jose Lucas you can from the linux shell

type "shell"
go to the following directory:
/opt/CSCOlumos/bin

There is a script named: hamode.sh
-bash-4.1# ./hamode.sh primary
HA mode is : secondary
Setting HA mode to 'primary'
* * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * *

Changing HA mode will result in *LOSS* of any data currently on the system
Enter 'yes' to proceed ....

* * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * *
yes
Setting HA mode to 'primary'

I tried this and its working 

ade # ./hamode.sh primary
HA mode is : secondary
No input arguments are allowed to this script.
ade #

 

I an not able to execute the command on the secondary.

 

I can move to the file structure.. 

I get a permission denied if I run the script on the secondary...

 

essc01-epnm/admin# shell
Enter shell access password :
Starting bash shell ...
ade #
ade # /opt/CSCOlumos/bin
sh: /opt/CSCOlumos/bin: Is a directory
ade #
ade # ./hamode.sh primary
sh: ./hamode.sh: Permission denied
ade #

 

mtenorio
Beginner
Beginner
@Jose Lucas you can from the linux shell

type "shell"
go to the following directory:
/opt/CSCOlumos/bin

There is a script named: hamode.sh
-bash-4.1# ./hamode.sh primary
HA mode is : secondary
Setting HA mode to 'primary'
* * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * *

Changing HA mode will result in *LOSS* of any data currently on the system
Enter 'yes' to proceed ....

* * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * *
yes
Setting HA mode to 'primary'
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers