cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
16667
Views
5
Helpful
21
Replies
MarioLieb
Beginner

Cisco Prime ver 1.3 issue

Hi @all

today i´d tried to login at my Cisco Prime interface. After i´d tried to browse to the device center i get an error. See picture.

The last config i did was to configure Radius setting. But i´d tested it and threre it works fine ... Any idea

There was an error while parsing and rendering the content. (Tried to register widget with id==dGroupOS but that id is already registered)

THX Mario

Another error is when i´d tried to click on Administration->SystemSettings->Datadeduplication i get this error

There was an error while parsing and rendering the content. (Tried to register widget with id==tableSP_xwtTableGlobalToolbar_refreshButton but that id is already registered)

21 REPLIES 21
MarioLieb
Beginner

Hi guys

new Information ... with Firefox it works ... with Chrome and IE not ....

I have the same problem. It seems that Chorme is updated to Version 29.0.1547.57 m, and along with it these problems came.

We tested on a PC that ran version 28-something and this problem was not present.

FF works.


I also get various other error-msg:

There was an error while parsing and rendering the content. (Tried to register widget with id==officeExtendApDialog but that id is already registered)

There was an error while parsing and rendering the content. (Object #has no method 'getAttribute')

Google has broke some of the features with latest version of chrome (v29) and hence CPI is having some issues. You can still run older Chrome version or use other browsers.

It is still being worked upon for fix.

-Thanks Vinod **Rating Encourages contributors, and its really free. **
simonvanm
Beginner

Same problem here. It seems like the only solution at this time is downgrading chrome.

You can find some older versions here: http://www.oldapps.com/google_chrome.php

This is wholly a problem introduced by Google.  Chrome 29 changed something in their dom traversal code used by QuerySelectorAll and/or in their actual DOM structure properties.   This broke the Dojo JavaScript Toolkit critical API: dojo.query.  The query code started to return TEXT nodes instead of just DOM Elements.  This is incorrect behavior and as such has caused the dom/template parser of Dojo to break while instantiating various types of widgets; primarily things such as the dijit Select control.  This has a ripple effect of breaking/failing page loads with random errors.  The most common error seen is some type of 'getAttribute' error.   

You can refer to this Dojo bug on the subject:

https://bugs.dojotoolkit.org/ticket/17400

Cisco is currently working to patch the products affected by this .  In the meantime the only options are to downgrade Chrome and Chrome Frame back to 28, or to use FireFox.

I have applied the patch per the instructions, and it said "patch applied successfully",but when I do a "show version", it has not added the line about the update.

Any thoughts?

andypenning
Enthusiast

There is a patch for this. Below is info on the 1.3 patch:

Description:Apply this patch over existing Prime Infrastructure 1.3.0.20 to fix the issue introduced in Google Chrome 29 build, which broke Dojo Toolkits query interface.
Release:1.3.0
Release Date:04/Sep/2013
File Name:PI_1_3_0_20-Update.1.12.CSCui77571-2.tar.gz
Size:0.13 MB (134938 bytes)
MD5 Checksum:d56011daa798def923e34c9ec40196bd

Hello

it works !!!

There is also a Patch for 1.4 available this Patch works also ...

Hello,

didn't work for me. I just installed the patch on CISCO Prime 1.3

Still the same error: IE / Chrome Frame 29 shows it. Firefox is working.

Fails in IE and Chrome.  Home page works on both (dashboard will render),

but with IE, Operate >device work center will either fail with a "error parsing and rendering content.  (Object # has no method "get attribute"),

or in Chrome - it just won't render the main frame.

Firefox still works, but reports an 'unsupported browser' error on Prime's splash / login screen.

Yes, I cleared the browser cache. But this did not help for IE.

Did you clear your browser cache after patching the server?   If you don't clear your browser cache, it is likely the browser is still loading the broken version from its local cache.

Sincerely,

-- Jared Jurkiewicz

/facepalm

Yes, that seems to have resolved that issue for Chrome.  I have not tested IE yet.