cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1165
Views
5
Helpful
6
Replies

Connect a switch Cisco Catalyst 3650 to a stack with ethernet cable

bnour02
Beginner
Beginner

Hi Cisco community,
I need your help to set up a new switch, and you can suggest another way to do it easier with same performance.

We have 3 switch Cisco Catalyst 3650 as our stack, we have just purchased another switch Cisco Catalyst 3650 (SW4) that we plan to add in the network because we are having more wired PCs in few weeks.

DHCP server is managed by the stack switch.

 

If possible, we do not want to add it to the stack, but we want to add it to the network as a "hub" that will send IP addresses to clients connected to it.
So we wonder if we can connect port 14 of SW4 to port 13 of stack active switch (SW1) with ethernet cable?
These 2 ports have to be set up as trunk with all vlans allowed?

For now, port 13 of (SW1) is configured as a VLAN30 (wired PCs vlan) access port, do I have to change it to trunk port?

I am rookie in network setting, sorry for asking these kind of questions.
Thanks for your help!
Do I set up port 14 of SW4 and port 13 of SW1 as below?

interface GigabitEthernet1/0/14
description Uplink to Stack SW
switchport mode trunk
switchport nonegotiate
spanning-tree bpduguard enable
switchport trunk allowed vlan 30

Access ports of SW4 as below:

interface GigabitEthernet1/0/17
description Users
switchport access vlan 30
switchport mode access
switchport nonegotiate
switchport voice vlan 20
auto qos trust
no cdp enable
spanning-tree portfast
spanning-tree bpduguard enable
service-policy input AutoQos-4.0-Trust-Cos-Input-Policy
service-policy output AutoQos-4.0-Output-Policy

 

Do I have to set up the DHCP on SW4 as well please?


ST-SW.pngST-SW 2.png



1 Accepted Solution

Accepted Solutions

Joseph W. Doherty
Hall of Fame Master Hall of Fame Master
Hall of Fame Master

"I need your help to set up a new switch, and you can suggest another way to do it easier with same performance."

Easier than stacking it within your existing stack?

If so, a) physically stacked, with other switches, will usually provide best performance (also, generally, better redundancy) and b) generally managing one (logical) device, rather than two, is easier.

If you cannot physically stack the switch with your others, often the "optimal" setup, is a two link Etherchannel, with links for non-stacked switch connected to different stacked switches.

As to your concern about DHCP, and performance, having a separate physical switch will provide very, very (very) little performance improvement, although it could make your DHCP management much more complex.  Further, DHCP on a stack provides redundancy which is much harder to provide across different DHCP servers.

View solution in original post

6 Replies 6

balaji.bandi
VIP Community Legend VIP Community Legend
VIP Community Legend
So we wonder if we can connect port 14 of SW4 to port 13 of stack active switch (SW1) with ethernet cable?
These 2 ports have to be set up as trunk with all vlans allowed?

yes this can be achieved, not required all the VLAN to allow in the Trunk, make sure you have not changed any Native VLAN then you need to allow both the vlan Voice and Data in the trunk.  This should be done both the side (Sw1 and Sw4)

 

interface GigabitEthernet1/0/14
switchport trunk allowed vlan 20,30

 

Other notes :

 

Make sure on the new Switch 4 you created the VLAN, and Spanning tree set higher than stack, so it will not become root for your VLAN.

If you looking redundancy, suggest to make port-channel with Switch 1 and Switch2 ( consider SW1 as master, SW2 as Standby)

if any of the switch failes, SW4 still work.

 

If you like to mamange switch remotely, you can add Manangment VLAN (if not you need to console all time to manange switch)

 

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

Thanks for your quick reply!
The native vlan has been changed, so I can set up both ports like below?

SW4:
interface GigabitEthernet1/0/14
description Uplink to Stack SW
switchport mode trunk
switchport nonegotiate
spanning-tree bpduguard enable
switchport trunk allowed vlan 30
switchport trunk native vlan 30

SW1:
interface GigabitEthernet1/0/13
description link to SW4
switchport mode trunk
switchport nonegotiate
spanning-tree bpduguard enable
switchport trunk allowed vlan 30
switchport trunk native vlan 30

 

How can I set Spanning tree higher than stack please?

 

 

Here are the current status of the 2 ports:

 

SW4:
interface GigabitEthernet1/0/13
description vlan 30
switchport access vlan 30
switchport trunk native vlan 30
switchport mode trunk
switchport nonegotiate
storm-control broadcast level 20.00
storm-control multicast level 20.00
storm-control action trap
spanning-tree vlan 10-70 port-priority 16
spanning-tree guard root

SW1:
interface GigabitEthernet1/0/13
description link to SW4
switchport access vlan 30
switchport trunk native vlan 30
switchport trunk allowed vlan 30
switchport mode trunk
switchport nonegotiate
switchport voice vlan 20
auto qos trust
no cdp enable
spanning-tree portfast
spanning-tree bpduguard enable
service-policy input AutoQos-4.0-Trust-Cos-Input-Policy
service-policy output AutoQos-4.0-Output-Policy

balaji.bandi
VIP Community Legend VIP Community Legend
VIP Community Legend

if you need voice LAN, then you need to add as below in the trunk :

 

SW4 and SW1 example :


interface GigabitEthernet1/0/14
description Uplink to Stack SW
switchport mode trunk
switchport nonegotiate
spanning-tree bpduguard enable
switchport trunk allowed vlan 20,30
switchport trunk native vlan 30

 

 

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

Joseph W. Doherty
Hall of Fame Master Hall of Fame Master
Hall of Fame Master

"I need your help to set up a new switch, and you can suggest another way to do it easier with same performance."

Easier than stacking it within your existing stack?

If so, a) physically stacked, with other switches, will usually provide best performance (also, generally, better redundancy) and b) generally managing one (logical) device, rather than two, is easier.

If you cannot physically stack the switch with your others, often the "optimal" setup, is a two link Etherchannel, with links for non-stacked switch connected to different stacked switches.

As to your concern about DHCP, and performance, having a separate physical switch will provide very, very (very) little performance improvement, although it could make your DHCP management much more complex.  Further, DHCP on a stack provides redundancy which is much harder to provide across different DHCP servers.

Hi Joseph, thanks for the link Etherchannel suggestion, can you tell me how to configure it please?
I will use the normal ports?
And actually the switch is not the DHCP server, the DHCP server is in a VM.


Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: