- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
07-31-2022 01:44 AM
Hi everyone
As per post title, I am trying to implement internet connection and set up a web server.
The diagram I have created works fine in terms of hosts being able to communicate with each other. I have set up the "Perth Router" as the DHCP server configured the trunk links and all.
Now I would like to connect the network to the internet and set up the web server. I am a bit lost as to how to achieve this. I have watched some videos on YT but I simply can't get my head around it.
I have attached my PT file - Password for console and privilege exec mode are cisco and class respectively for all router and switches.
Any suggestion would be much appreciated
Please bear with me as I have only starter with networking about a month ago
Cheers
Luca
Solved! Go to Solution.
- Labels:
-
Network Management
Accepted Solutions
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
08-02-2022 01:01 AM
Hello,
if you need a variable length subnet between the router and the cloud, you could use any /30 address you want, e.g.:
interface GigabitEthernet0/1
--> description WAN to Internet
--> ip address 100.100.100.1 255.255.255.252
--> ip nat outside
duplex auto
speed auto
The static route:
--> ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/1
works, but if you have a fixed IP address, you can also use:
--> ip route 0.0.0.0 0.0.0.0 100.100.100.2
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
07-31-2022 03:31 AM
Hi
what could be all device password set as cisco is not correct password.
regards
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
07-31-2022 03:44 AM
Hi
I am not an expert, but I don't think the passwords have anything to do with the issue I am having. I need to set up a internet connection and configure the web server.
Regards
Luca
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
07-31-2022 01:50 PM
If someone could have a look at my design and give some tips that would be greatly appreciated.
Cheers
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
08-01-2022 12:12 AM
Hello,
what (if any) instructions are you following ? The router that connects to the Internet needs to have NAT configured. I don't know if this is supposed to be the Perth or the Sidney router ?
Let's say the Perth router is the ISP/Internet facing router; you would need to add the lines marked in bold:
PerthRouter#sh run
Building configuration...
Current configuration : 1540 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname PerthRouter
!
enable secret 5 $1$mERr$9cTjUIEqNGurQiFU.ZeCi1
!
ip dhcp excluded-address 192.168.10.1
ip dhcp excluded-address 192.168.10.1 192.168.10.10
ip dhcp excluded-address 192.168.20.1 192.168.20.10
ip dhcp excluded-address 192.168.30.1 192.168.30.10
!
ip dhcp pool MYPOOL
network 192.168.10.0 255.255.255.0
default-router 192.168.10.1
dns-server 192.168.10.3
ip dhcp pool MYPOOL2
network 192.168.20.0 255.255.255.0
default-router 192.168.20.1
dns-server 192.168.20.3
ip dhcp pool MYPOOL3
network 192.168.30.0 255.255.255.0
default-router 192.168.30.1
dns-server 192.168.30.3
!
ip cef
no ipv6 cef
!
license udi pid CISCO1941/K9 sn FTX1524CE00-
!
spanning-tree mode pvst
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/0.10
encapsulation dot1Q 10
ip address 192.168.10.1 255.255.255.0
--> ip nat inside
!
interface GigabitEthernet0/0.20
encapsulation dot1Q 20
ip address 192.168.20.1 255.255.255.0
--> ip nat inside
!
interface GigabitEthernet0/0.30
encapsulation dot1Q 30
ip address 192.168.30.1 255.255.255.0
--> ip nat inside
!
interface GigabitEthernet0/1
--> description WAN to Internet
--> ip address dhcp
--> ip nat outside
duplex auto
speed auto
!
interface Vlan1
no ip address
shutdown
!
--> ip nat inside source list 1 interface GigabitEthernet0/1 overload
!
--> ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/1
!
--> access-list 1 permit 192.168.10.0 0.0.0.255
--> access-list 1 permit 192.168.20.0 0.0.0.255
--> access-list 1 permit 192.168.30.0 0.0.0.255
!
ip classless
!
ip flow-export version 9
!
banner motd ^C Authorised access only! ^C
!
line con 0
password cisco
login
!
line aux 0
!
line vty 0 4
password cisco
login
!
end
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
08-01-2022 02:15 AM - edited 08-01-2022 02:19 AM
Hi Georg
Thanks so much for getting back to me.
To be honest I was trying to follow a couple of tutorials I found on YT but got very confused.
To answer your question, yes it's the Perth Router that needs to connect to the internet.
I will try and implement the configuration as per your suggestion.
One other thing that I am confused with is the actual connection between the router and the ISP. Doesn't this require a static route from the router to the cloud? Or maybe I am really mixing thing up?
Also I am required to use a variable length subnet between the router and the ISP.
Please bear with me as I am really new to networking.
Many thanks in advance
Luca
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
08-02-2022 01:01 AM
Hello,
if you need a variable length subnet between the router and the cloud, you could use any /30 address you want, e.g.:
interface GigabitEthernet0/1
--> description WAN to Internet
--> ip address 100.100.100.1 255.255.255.252
--> ip nat outside
duplex auto
speed auto
The static route:
--> ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/1
works, but if you have a fixed IP address, you can also use:
--> ip route 0.0.0.0 0.0.0.0 100.100.100.2
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
08-02-2022 01:36 AM
Hi Georg
Brilliant! Thanks so very much for the info.
As for the static route
@Georg Pauwen wrote:The static route:
--> ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/1
works, but if you have a fixed IP address, you can also use:
--> ip route 0.0.0.0 0.0.0.0 100.100.100.2
The above command is actually - ip route 0.0.0.0 0.0.0.0 100.100.100.2 as you typed it including both addresses? or you meant ip route followed by one of the 2 addresses? Depending on which one I want to use?
Thanks for being so patient! Much appreciated
Cheers
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
08-02-2022 03:47 AM
Hi Georg
So very sorry if I am bothering you. But one thing is still not clear 100%
When you say
--> ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/1
works, but if you have a fixed IP address, you can also use:
--> ip route 0.0.0.0 0.0.0.0 100.100.100.2
Do I need to enter the command exactly like that ip route 0.0.0.0 0.0.0.0 100.100.100.2?
Or I need to use the ip route command followed by one of the 2 addresses? This is the part that is not clear.
Thanks so much for your patient
Cheers
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
08-01-2022 04:03 AM
Hi Again
I have made the required changes as per you suggestion.
Just to clarify is the following the static route "ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/1"?
Many thanks in advance
