cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1361
Views
47
Helpful
17
Replies
meet_mkhan
Beginner

Default route to be distributed in ospf

Hi Experts,              

I am in process of configuring ospf between dubai router and oman router.The problem

is the both routers have default to route to internet  0.0.0.0 0.0.0.0 214.42.x.x               

Can i configure ospf on both routers if yes then how can i configure        

any kind of information is appreciated.

Regards,

Munawer Khan

3 ACCEPTED SOLUTIONS

Accepted Solutions

Hello,

It seems, that the serial interfaces are directly connected to the internet and the Dubai router can reach the Oman router and the other way aroud? If yes, see below

1. You have to create a tunnel interface on router dubei

     interface Tunnel 10
      description DUBAI_OMAN
      ip address 10.0.0.1 255.255.255.252
      cdp enable
      tunnel source 

      tunnel source Serial 0/0/0

      tunnel destination 212.72.8.x
     exit

2. You have to create a tunnel interface on router dubei

     interface Tunnel 10
      description DUBAI_OMAN
      ip address 10.0.0.2 255.255.255.252
      cdp enable
      tunnel source 

      tunnel source Serial 0/0/0

      tunnel destination 213.32.x.x
     exit

3. You have to change the router ospf 10 at the Dubai router and include the tunnel network istead of the serial network

     router ospf 10
      router-id 10.254.0.1
      network 10.254.0.1 0.0.0.0 area 0
      !
      no networ 213.32.x.x 0.0.0.0 area 0
      !
      network 10.0.0.0 0.0.0.3 area 0       network 213.42.104.x 0.0.0.15 area 1

      redistribute static subnets route-map INTERNET-DUBAI

      default-information originate always
     exit

4. You have to change the router ospf 10 at the Oman router and include the tunnel network istead of the serial network

     router ospf 10
      router-id 10.254.0.2
      network 10.254.0.2 0.0.0.0 area 0
      !
      no network 212.72.8.x 0.0.0.3 area 0       !
      network 10.0.0.0 0.0.0.3 area 0       !
      no network 192.168.11.0 0.0.0.255 area 1
      !
      network 192.168.11.0 0.0.0.255 area 2

      redistribute static subnets route-map INTERNET-OMAN

      default-information originate always
     exit

5. You should now have an unencrypted connection between both routers.

View solution in original post

Hello,

no cdp isn't mandatory. It's sometimes only a nice feature to see the neigbours of your device, like "show cdp neighbours" .

Kind regards

Kai

View solution in original post

Hello,

where something in your mind like

sh processes ?

  <1-4294967295>  Process Number

  cpu             Show CPU use per process

  history         display ordered Process history

  memory          Show memory use per process

  timercheck      Show processes configured for timercheck

  |               Output modifiers

 

sh memory ?

  allocating-process  Show allocating process name

  dead                Memory owned by dead processes

  debug               Memory debugging commands

  failures            Memory failures

  fast                Fast memory stats

  fragment            Summary of memory fragment information

  free                Free memory stats

  io                  IO memory stats

  multibus            Multibus memory stats

  overflow            memory overflow corrections

  pci                 PCI memory stats

  processor           Processor memory stats

  statistics          Mempool Statistics

  summary             Summary of memory usage per alloc PC

  transient           Transient memory stats

  |                   Output modifiers

 

sh interfaces fa0/0

FastEthernet0/0 is up, line protocol is up

  Hardware is Gt96k FE, address is 0015.6260.3f7e (bia 0015.6260.3f7e)

  Description:

  Internet address is

  MTU 1500 bytes, BW 100000 Kbit/sec, DLY 100 usec,

     reliability 255/255, txload 43/255, rxload 42/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Full-duplex, 100Mb/s, 100BaseTX/FX

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input 00:00:00, output 00:00:00, output hang never

  Last clearing of "show interface" counters never

  Input queue: 1/75/29026385/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 8000 bits/sec, 12 packets/sec

  5 minute output rate 3000 bits/sec, 3 packets/sec

     1159982340 packets input, 4008215947 bytes

     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

     1787 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     0 watchdog

     0 input packets with dribble condition detected

     532702931 packets output, 3247467049 bytes, 0 underruns

     0 output errors, 0 collisions, 40 interface resets

     30 unknown protocol drops

     0 babbles, 0 late collision, 0 deferred

     0 lost carrier, 0 no carrier

     0 output buffer failures, 0 output buffers swapped out

Kind regards

Kai

View solution in original post

17 REPLIES 17
Kai Onken
Beginner

Hello,

I have two question:

  • Do you want to create a vpn tunnel over the internet

               See attached file INTERNET.TXT

    • Do you have a direct connection between the routers, e.g. darkfiber,...

                   See attached file DARKFIBER.TXT

      I think those samples should help, if I got your question right.

      In this sample is no focus set to scalability, like subinterfaces, VLAN, VRF, etc.

      In both samples the LAN client will have Interet access, if this should not happen, than remove the lines "redistribute static subnets route-map INTERNET-DUBAI" and "redistribute static subnets route-map INTERNET-OMAN"

      Hi Kai Onken,

      Thanks for your reply.Let me explain you my network setup

      R1 is in Oman  

      ROUTER(R1) :SERIAL1(214.42.X.X/28)

      ETHERNET(192.168.14.1/24)

      defualt route via serial1 connected to lease line.

        R2 is in Dubai  ROUTER(R2) :SERIAL1(213.44.X.X/28)

        ETHERNET(192.168.10.1/24)

      default route via serial1 connect to lease line.

        Now i want to configure ospf point to point connectivity between Oman and Dubai

        so please assist me if it is possible to configure ospf between R! and R2?

      OSPF is an Interior Gateway Protocol (IGP) and it will not pass through a public network.

      You need to use some sort of tunneling mechanism (like a VPN or GRE tunnel).

      Hello Munnawer,

      Marvin is right. In this case, you've to use the INTERNET configuration and change the GigabitEthernet 0/1 to your serial connection. Than should your setup work. The point to point connection will be the Tunnel Interface. But notice that the two routers habe to "see" each other throught the internet to create a tunnel.

      If you want to do a VPN Tunnel you neet the hole INTERNET configuration. This connection will be encrypted

      If you only want a Tunnel, you could remove section starting with CRYPTO. This will be an unencrypted connection.

      You've to know, if you encrypt the connection, the bandwith could decrease, based on the routers you will use.

      Kind regards

      Kai

      Hi Dears,

                   Thanks for your replies.Kindly check the config below

      CONFIGUARTION AT DUBAI ROUTER:     

      interface GigabitEthernet 0/0

      description LAN - Dubai

      ip address 213.42.104.x 255.255.255.0

      no shutdown

      exit

      interface Serial 0/0/0

      description Transfer to Oman via lease line

      ip address 213.32.x.x 255.255.255.252

      no shutdown

      exit

      interface loopback 10

      description Router ID | OSPF 10

      ip address 10.254.0.1 255.255.255.255

      no shutdown

      exit

      ip routing

      route-map INTERNET-DUBAI

      match tag 10

      exit

      ip route 0.0.0.0 0.0.0.0 interface Serial 0/0/0 tag 10 name "omanhost"

      router ospf 10

      router-id 10.254.0.1

      network 10.254.0.1 0.0.0.0 area 0

      network 213.32.x.x 0.0.0.0 area 0

      network 213.42.104.x 0.0.0.15 area 1

      redistribute static subnets route-map INTERNET-DUBAI

      default-information originate always

      exit

      CONFIGURATION AT OMAN ROUTER:

      interface GigabitEthernet 0/0

      description LAN - Oman

      ip address 192.168.11.12 255.255.255.0

      no shutdown

      exit

      interface Serial 0/0/0

      description Transfer to Dubai via lease line

      ip address 212.72.8.x 255.255.255.252

      no shutdown

      exit

      interface loopback 10

      description Router ID | OSPF 10

      ip address 10.254.0.2 255.255.255.255

      no shutdown

      exit

      ip routing

      route-map INTERNET-OMAN

      match tag 10

      exit

      ip route 0.0.0.0 0.0.0.0 interface Serial 0/0/0 tag 10 name "dubaihost"

      router ospf 10

      router-id 10.254.0.2

      network 10.254.0.2 0.0.0.0 area 0

      network 212.72.8.x 0.0.0.3 area 0

      network 192.168.11.0 0.0.0.255 area 1

      redistribute static subnets route-map INTERNET-OMAN

      default-information originate always

      exit

      Still i cant see ospf in Routing Table there is only default route via serial 0/0/0



      Hello,

      It seems, that the serial interfaces are directly connected to the internet and the Dubai router can reach the Oman router and the other way aroud? If yes, see below

      1. You have to create a tunnel interface on router dubei

           interface Tunnel 10
            description DUBAI_OMAN
            ip address 10.0.0.1 255.255.255.252
            cdp enable
            tunnel source 

            tunnel source Serial 0/0/0

            tunnel destination 212.72.8.x
           exit

      2. You have to create a tunnel interface on router dubei

           interface Tunnel 10
            description DUBAI_OMAN
            ip address 10.0.0.2 255.255.255.252
            cdp enable
            tunnel source 

            tunnel source Serial 0/0/0

            tunnel destination 213.32.x.x
           exit

      3. You have to change the router ospf 10 at the Dubai router and include the tunnel network istead of the serial network

           router ospf 10
            router-id 10.254.0.1
            network 10.254.0.1 0.0.0.0 area 0
            !
            no networ 213.32.x.x 0.0.0.0 area 0
            !
            network 10.0.0.0 0.0.0.3 area 0       network 213.42.104.x 0.0.0.15 area 1

            redistribute static subnets route-map INTERNET-DUBAI

            default-information originate always
           exit

      4. You have to change the router ospf 10 at the Oman router and include the tunnel network istead of the serial network

           router ospf 10
            router-id 10.254.0.2
            network 10.254.0.2 0.0.0.0 area 0
            !
            no network 212.72.8.x 0.0.0.3 area 0       !
            network 10.0.0.0 0.0.0.3 area 0       !
            no network 192.168.11.0 0.0.0.255 area 1
            !
            network 192.168.11.0 0.0.0.255 area 2

            redistribute static subnets route-map INTERNET-OMAN

            default-information originate always
           exit

      5. You should now have an unencrypted connection between both routers.

      Hi,

          I am Getting error while enabling cdp on tunnel interface

      DUBAIHOST(config-if)#cdp enable

      % CDP is not supported on this interface, or for this encapsulation.

      So is it mandatory to enable cdp.?

      Hello,

      no cdp isn't mandatory. It's sometimes only a nice feature to see the neigbours of your device, like "show cdp neighbours" .

      Kind regards

      Kai

      Hi Kai Onken,

      I Thank you very much for all the assistance now every thing is working fine.

      i can see the ospf routes in Routing table along with default route.this time i wll choose your answer

      is perfect correct.

      Dear Kai Onken i need one more favour from your side

      do you any good network monitoring commands in cisco or any software to monitor all things like

      router bandwidth how much used, free and which application uses how much bandwidth

      router,firewall,switches cpu load,each user how much bandwidth utilizing and what kind of services

      users are using i mean all things I want to monitor.

              Thanks agian for your support .

      Regards,

      Munnawer Khan.

      Hello,

      We're using Nagios at our office. If you don't need any kind of support, you could choose the opensource version

      http://www.nagios.org/ additional you can check http://exchange.nagios.org/ for plugins. This should help you.

      At the configuration advise you to use the encryption on the Internet connection form the sample at the top.

      Kind regards

      Kai

      Hi,

          I am installing this software and i will check how it works in my network.

           Do you know any cisco commands on routers,switches and cisco asa to do same thing i mean monitoring

            users particularly bandwidth utilization.

      Regards,

      Munnawer

      Hi,
          My friend this nagios software is only for CentOS and Ubuntu servers i wnat
          software on windows platform like windows 2000,2003xp etc.
          Do you know any cisco commands on routers,switches and cisco asa
          to do same thing i mean monitoring
            users particularly bandwidth utilization.
      Regards,
      Munnawer
             

      Hello,

      you could try e.g.

      Kind redards.

      Kai

      For performance management you can run the open source Cacti on Windows (although most people run it on Linux, as with Nagios mentioned earlier). That will give you high level - e.g. bandwidth used by an interface.

      If you want to drill down to see user level utilization you will need to use Netflow on the routers exporting to a collector on a server. What's Up Gold can be a Netflow server. You can also use a free tool like ntop but I don't think it is available on Windows.