cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2388
Views
0
Helpful
1
Replies

I need work with two sub-nets

FBARRERAR
Level 1
Level 1

Hi, i have two sub-nets that are class A with clase C mask /24, if i have a router, what I could do if i want that these two sub-nets work and can see both?

Thanks

Fabian

1 Reply 1

paddyxdoyle
Level 6
Level 6

Hi,

You have a few options here.

A) If you have two Ethernet/Fast Ethernet interfaces you could configure 1 interface with an address from one subnet, and the other interface with an address from the other, and connect each of your networks to the router. This could be done using the same switch and having seperate VLANs one for each subnet or you could have seperate physical switches...

e.g.

router

------

interface fastethernet 0/0

ip address 1.1.1.1 255.255.255.0

interface fastethernet 0/1

ip address 2.2.2.1 255.255.255.0

B) If you have a flat network with no VLANs you could use a single interface on your router with a primary address in one subnet and a secondary address in the other subnet.

e.g.

interface fastethernet 0/0

ip address 1.1.1.1 255.255.255.0

ip address 2.2.2.1 255.255.255.0 secondary

C) If you are using VLANs and only have a single router interface available, plus your router and switch supports trunking you could trunk the VLANs to your router from your switch

e.g.

switch

------

Int fastEthernet 0/1

switchport access vlan 999

switchport mode trunk

switchport trunk encapsulation dot1q

switchport trunk alloweved vlans 2,3

switchport trunk native vlan 2

router

------

interface fastethernet 0/0

no ip address

interface fastethernet 0/0.2

description vlan2

encapsulation dot1q 2 native

ip address 1.1.1.1 255.255.255.0

interface fastethernet 0/0.3

description vlan3

encapsulation dot1q 3

ip address 2.2.2.1 255.255.255.0

On all these examples the default gateway for your clients would be set to the routers interface address matching the subnet they are in.

Option B is normally used if you are migrating between address schemes, so i would say depending on your router/topology you would be looking at A or C

HTH

PD