cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
702
Views
10
Helpful
6
Replies
O_H
Beginner
Beginner

IP SLA (TCP) Gives No Connection... But can telnet to the dest

I use IP SLA TCP operation as below:

 

ip sla 9
tcp-connect 172.30.240.38 80 source-ip 10.192.45.254
threshold 2000
timeout 3000
frequency 5
ip sla schedule 9 life forever start-time now

 

But it always gives the (No connection) return code result in the (show ip sla summary).

From the same router, i can telnet port 80 using same source IP and it is open normally. The destination is a web server.

Any ideas? 

@IPSLA  @sla

1 ACCEPTED SOLUTION

Accepted Solutions

Glad all working, so we mark as resolved here.

BB

***** Rate All Helpful Responses *****

How to Ask The Community for Help

View solution in original post

6 REPLIES 6
balaji.bandi
VIP Master

tcp-connect 172.30.240.38 80 source-ip 10.192.45.254

 

i would check when the Router leanving with telnet go with same IP address ?

what is this IP address ?

BB

***** Rate All Helpful Responses *****

How to Ask The Community for Help

I source the telnet from the same IP used in SLA and port 80 as described. It works with telnet but not with SLA. It is an SVI IP on the switch.

Test 2 options and let us know how it goes :

 

test1  without source IP :

 

ip sla 9
tcp-connect 172.30.240.38 80

 

test 2

 

ip sla 9
tcp-connect 172.30.240.38 80 control disable

 

also post show ip sla summary

BB

***** Rate All Helpful Responses *****

How to Ask The Community for Help

I created SLA11 for test1 & SLA12 for test2 as per your advice. Test2 gives this socket error as below.

 

 

 

SWITCH#show ip sla sum
IPSLAs Latest Operation Summary
Codes: * active, ^ inactive, ~ pending

ID           Type        Destination       Stats       Return      Last
                                           (ms)        Code        Run
-----------------------------------------------------------------------
*9           tcp-connect 172.30.240.38     -           No connecti 21 seconds ag
                                                       on          o



*11          tcp-connect 172.30.240.38     -           No connecti 56 seconds ag
                                                       on          o



*12          tcp-connect 172.30.240.38     RTT=0       Socket conn 48 seconds ag
                                                       ect error   o

 

 

It worked now using the source-ip & control disable. Thank u!

Glad all working, so we mark as resolved here.

BB

***** Rate All Helpful Responses *****

How to Ask The Community for Help

View solution in original post