01-21-2021 07:42 AM
Hello, I am trying to solve this network. It is a bit challenging. I am trying to configure static routing, dhcp, and ip helper address. My dhcp is not sending any address to my pc. My static routing is not working. I am not sure what I doing wrong please help. I include a screenshot of the network diagram and a screenshot of my config script.
Solved! Go to Solution.
01-21-2021 05:04 PM
make sure your paste command correct device, you pasting commands of Router2 on Router 1 - read the post correctly
01-21-2021 08:25 AM - edited 01-21-2021 08:26 AM
A Router connected to network with hosts should use the last available IP in the subnet
High level it should work - check before adding, there may be some typos - add IP helper config to work on the interface towards DHCP
Router 0
g0/0:195.165.85.1 255.255.255.252
g0/1:195.165.85.62 255.255.255.224
ip route 0.0.0.0 0.0.0.0 192.165.85.2
Router 1
g0/0:195.165.85.2 255.255.255.252
g0/1:195.165.85.6 255.255.255.252
g0/2:195.165.85.94 255.255.255.224
ip route 195.165.85.32 255.255.255.224 192.165.85.1
ip route 195.165.85.96 255.255.255.224 192.165.85.5
Router 2
g0/0:195.165.85.5 255.255.255.252
g0/1:195.165.85.126 255.255.255.224
ip route 0.0.0.0 0.0.0.0 192.165.85.6
ip dhcp pool net32
network 195.165.85.32 255.255.255.224
default-router 195.165.85.62
ip dhcp pool net64
network 195.165.85.64 255.255.255.224
default-router 195.165.85.94
ip dhcp pool net96
network 195.165.85.96 255.255.255.224
default-router 195.165.85.126
ip dhcp excluded-address 195.165.85.62
ip dhcp excluded-address 195.165.85.94
ip dhcp excluded-address 195.165.85.126
01-21-2021 09:02 AM
Thank you for replying. PC0 is getting an ip address from the dhcp. But i notice that PC1 and PC2 is not getting any ip address. I used the ip helper on router 1 and router 2 but it is still not getting the ip address. This is the command i used
ip helper-address 195.165.85.62.
01-21-2021 09:10 AM
PC0 getting IP address - in the same range ?
ip dhcp pool net32
network 195.165.85.32 255.255.255.224
default-router 195.165.85.62
Can you post Router0 / Router 1 / router 2 config - just to clarify some information before i can advise.
01-21-2021 09:41 AM
Yes, PC0 is getting an address 195.165.85.33.
This is the configuration for router 0,1and 2
Router 0
g0/0:195.165.85.1 255.255.255.252
g0/1:195.165.85.62 255.255.255.224
ip route 0.0.0.0 0.0.0.0 192.165.85.2
Router 1
g0/0:195.165.85.2 255.255.255.252
g0/1:195.165.85.6 255.255.255.252
g0/2:195.165.85.94 255.255.255.224
ip route 195.165.85.32 255.255.255.224 192.165.85.1
ip route 195.165.85.96 255.255.255.224 192.165.85.5
Router 2
g0/0:195.165.85.5 255.255.255.252
g0/1:195.165.85.126 255.255.255.224
ip route 0.0.0.0 0.0.0.0 192.165.85.6
ip dhcp pool net32
network 195.165.85.32 255.255.255.224
default-router 195.165.85.62
ip dhcp pool net64
network 195.165.85.64 255.255.255.224
default-router 195.165.85.94
ip dhcp pool net96
network 195.165.85.96 255.255.255.224
default-router 195.165.85.126
ip dhcp excluded-address 195.165.85.62
ip dhcp excluded-address 195.165.85.94
ip dhcp excluded-address 195.165.85.126
Router 1
int gig 0/2 ip helper-address 195.165.85.62
Router 2
int gig 0/1 ip helper-address 195.165.85.62
01-21-2021 10:09 AM
I have not seen a helper address that has not provided Router 0 helper config- try below.
remove old helper-address and try below on below routers and let us know. (typing from mobile may be some typo)
Router 1
int gig 0/2 ip helper-address 195.165.85.94
Router 2
int gig 0/1 ip helper-address 192.165.85.6
01-21-2021 10:36 AM - edited 01-21-2021 10:40 AM
I remove the helper addresses and reconfigure it with the ones that you provided but it didn't work. Also, in your last reply i notice that you made a typo for Router 2 you be put .6 but i believe it suppose to be .126
I also notice that router0 cant ping router 2. I am wondering if their is an issues somewhere along their.
01-21-2021 11:03 AM
sure as i mentioned the mobile has some correction
get in to device - show run and post full config. on all routers
01-21-2021 11:29 AM
Ok. Thank you. Here the configurations of router 0, 1, and 2.
Router0
ip dhcp excluded-address 195.165.85.62
ip dhcp excluded-address 195.165.85.94
ip dhcp excluded-address 195.165.85.126
!
ip dhcp pool net32
network 195.165.85.32 255.255.255.224
default-router 195.165.85.62
ip dhcp pool net64
network 195.165.85.64 255.255.255.224
default-router 195.165.85.94
ip dhcp pool net96
network 195.165.85.96 255.255.255.224
default-router 195.165.85.126
interface GigabitEthernet0/0
ip address 195.165.85.1 255.255.255.252
duplex auto
speed auto
!
interface GigabitEthernet0/1
ip address 195.165.85.62 255.255.255.224
duplex auto
speed auto
!
interface GigabitEthernet0/2
no ip address
duplex auto
speed auto
shutdown
!
interface Vlan1
no ip address
shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.165.85.2
!
ip flow-export version 9
Router 1
interface GigabitEthernet0/0
ip address 195.165.85.2 255.255.255.252
duplex auto
speed auto
!
interface GigabitEthernet0/1
ip address 195.165.85.6 255.255.255.252
duplex auto
speed auto
!
interface GigabitEthernet0/2
ip address 195.165.85.94 255.255.255.224
ip helper-address 195.165.85.94
duplex auto
speed auto
!
interface Vlan1
no ip address
shutdown
!
ip classless
ip route 195.165.85.32 255.255.255.224 192.165.85.1
ip route 195.165.85.96 255.255.255.224 192.165.85.5
!
ip flow-export version 9
Router2
interface GigabitEthernet0/0
ip address 195.165.85.5 255.255.255.252
duplex auto
speed auto
!
interface GigabitEthernet0/1
ip address 195.165.85.126 255.255.255.224
ip helper-address 192.165.85.6
duplex auto
speed auto
!
interface GigabitEthernet0/2
no ip address
duplex auto
speed auto
shutdown
!
interface Vlan1
no ip address
shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.165.85.6
!
ip flow-export version 9
!
!
!
no cdp run
!
!
01-21-2021 12:48 PM
I was in impression router 1 acting as DHCP - But as per the config Router 0 acting as DHCP Server, so we need to change as below bold - test and advise
Router0
ip dhcp excluded-address 195.165.85.62
ip dhcp excluded-address 195.165.85.94
ip dhcp excluded-address 195.165.85.126
!
ip dhcp pool net32
network 195.165.85.32 255.255.255.224
default-router 195.165.85.62
ip dhcp pool net64
network 195.165.85.64 255.255.255.224
default-router 195.165.85.94
ip dhcp pool net96
network 195.165.85.96 255.255.255.224
default-router 195.165.85.126
interface GigabitEthernet0/0
ip address 195.165.85.1 255.255.255.252
duplex auto
speed auto
!
interface GigabitEthernet0/1
ip address 195.165.85.62 255.255.255.224
duplex auto
speed auto
!
interface GigabitEthernet0/2
no ip address
duplex auto
speed auto
shutdown
!
interface Vlan1
no ip address
shutdown
!
ip classless
no ip route 0.0.0.0 0.0.0.0 192.165.85.2
ip route 195.165.85.64 255.255.255.224 192.165.85.2
ip route 195.165.85.96 255.255.255.224 192.165.85.2
!
ip flow-export version 9
Router 1
interface GigabitEthernet0/0
ip address 195.165.85.2 255.255.255.252
duplex auto
speed auto
!
interface GigabitEthernet0/1
ip address 195.165.85.6 255.255.255.252
duplex auto
speed auto
!
interface GigabitEthernet0/2
ip address 195.165.85.94 255.255.255.224
ip helper-address 195.165.85.1
duplex auto
speed auto
!
interface Vlan1
no ip address
shutdown
!
ip classless
ip route 195.165.85.32 255.255.255.224 192.165.85.1
ip route 195.165.85.64 255.255.255.224 192.165.85.94
ip route 195.165.85.96 255.255.255.224 192.165.85.5
!
ip flow-export version 9
Router2
interface GigabitEthernet0/0
ip address 195.165.85.5 255.255.255.252
duplex auto
speed auto
!
interface GigabitEthernet0/1
ip address 195.165.85.126 255.255.255.224
ip helper-address 192.165.85.1
duplex auto
speed auto
!
interface GigabitEthernet0/2
no ip address
duplex auto
speed auto
shutdown
!
interface Vlan1
no ip address
shutdown
!
ip classless
no ip route 0.0.0.0 0.0.0.0 192.165.85.6
ip route 195.165.85.32 255.255.255.224 192.165.85.6
ip route 195.165.85.64 255.255.255.224 192.165.85.6
ip route 195.165.85.96 255.255.255.224 192.165.85.126
!
ip flow-export version 9
!
!
!
no cdp run
!
!
01-21-2021 04:22 PM
When I try input to input the ip route into router 1. I keep getting invalid hop.
Router(config)#no ip route 0.0.0.0 0.0.0.0 192.165.85.6
%No matching route to delete
Router(config)#ip route 195.165.85.32 255.255.255.224 195.165.85.6
%Invalid next hop address (it's this router)
Router(config)#ip route 195.165.85.64 255.255.255.224 195.165.85.6
%Invalid next hop address (it's this router)
Router(config)#ip route 195.165.85.96 255.255.255.224 195.165.85.126
01-21-2021 05:04 PM
make sure your paste command correct device, you pasting commands of Router2 on Router 1 - read the post correctly
01-21-2021 07:20 PM
Ok thank you very much for the help. It is working now.
01-21-2021 08:27 AM
return path from DHCP server to IP help interface.
check this point.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide