11-16-2023 07:18 PM
Hi
I have configured the SVI on the multi-layer switch; I don't want to use the router as a DHCP server. I want to utilize a multilayer switch for DHCP pool..
VLAN 1
VLAN 2
VLAN 3
Interface IP-Address OK? Method Status Protocol
FastEthernet0/1 10.10.10.2 YES manual up up
FastEthernet0/2 unassigned YES unset up up
FastEthernet0/3 unassigned YES unset down down
FastEthernet0/4 unassigned YES unset down down
FastEthernet0/5 unassigned YES unset down down
FastEthernet0/6 unassigned YES unset down down
FastEthernet0/7 unassigned YES unset down down
FastEthernet0/8 unassigned YES unset down down
FastEthernet0/9 unassigned YES unset down down
FastEthernet0/10 unassigned YES unset down down
FastEthernet0/11 unassigned YES unset down down
FastEthernet0/12 unassigned YES unset down down
FastEthernet0/13 unassigned YES unset down down
FastEthernet0/14 unassigned YES unset down down
FastEthernet0/15 unassigned YES unset down down
FastEthernet0/16 unassigned YES unset down down
FastEthernet0/17 unassigned YES unset down down
FastEthernet0/18 unassigned YES unset down down
FastEthernet0/19 unassigned YES unset down down
FastEthernet0/20 unassigned YES unset down down
FastEthernet0/21 unassigned YES unset down down
FastEthernet0/22 unassigned YES unset down down
FastEthernet0/23 unassigned YES unset down down
FastEthernet0/24 unassigned YES unset down down
GigabitEthernet0/1 unassigned YES unset down down
GigabitEthernet0/2 unassigned YES unset down down
Vlan1 10.10.1.1 YES manual up up
Vlan2 10.10.2.1 YES manual up up
Vlan3 10.10.3.1 YES manual up up
Switch#
Switch#
Switch#
Switch#show run
Switch#show running-config
Building configuration...
Current configuration : 1547 bytes
!
version 12.2(37)SE1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
!
ip dhcp pool vlan1
network 10.10.1.0 255.255.255.0
default-router 10.10.1.1
dns-server 8.8.8.8
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/1
no switchport
ip address 10.10.10.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/2
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
ip address 10.10.1.1 255.255.255.0
!
interface Vlan2
mac-address 0003.e437.9501
ip address 10.10.2.1 255.255.255.0
!
interface Vlan3
mac-address 0003.e437.9502
ip address 10.10.3.1 255.255.255.0
!
ip classless
!
ip flow-export version 9
!
!
!
Solved! Go to Solution.
11-17-2023 06:50 AM - edited 11-17-2023 09:12 AM
You don't need ip helper address since there's no L3 equipement between hosts and the DHCP server hosted on L3Switch.
Why we need ip helper address? Because broadcast is drop by Router. If there is a Router on the way towards your DHCP server, you need to configure ip helper address on the first adress to act as DHCP relay!
11-16-2023 08:10 PM
@ankitohc hi please share the packet tracer file.
11-16-2023 09:54 PM - edited 11-17-2023 12:29 AM
Not sure if PT L3 switch can do DHCP server role but Make sure you L3 switch has ip routing command on; check with show ip routing;
double check your link to L2 sw is trunk one; and add DHCP pools for others; vlan 2 and 3 are in database,
you can attach PT file here but it must be in a zip format
Regards, ML
**Please Rate All Helpful Responses **
11-17-2023 02:31 AM - edited 11-17-2023 02:32 AM
Hello @ankitohc
MultiLayer switch seem to be well configured.
As concerned L2 switch you shoul have this:
sh run
Building configuration...
Current configuration : 1186 bytes
!
version 15.0
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
interface FastEthernet0/1
switchport trunk allowed vlan 1-3
switchport mode trunk
!
interface FastEthernet0/2
description --PC2-vlan1
switchport mode access
switchport access vlan 1
spanning-tree portfast
!
interface FastEthernet0/3
description --PC0-vlan2
switchport mode access
switchport access vlan 2
spanning-tree portfast
!
interface FastEthernet0/4
description --PC1-vlan3
switchport mode access
switchport access vlan 3
spanning-tree portfast
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
-------------------------------
Switch#sh int trunk
Port Mode Encapsulation Status Native vlan
Fa0/1 on 802.1q trunking 1
Port Vlans allowed on trunk
Fa0/1 1-3
Port Vlans allowed and active in management domain
Fa0/1 1,2,3
Port Vlans in spanning tree forwarding state and not pruned
Fa0/1 1,2
-------------------------------
-------------------------------
Switch#sh int status
Port Name Status Vlan Duplex Speed Type
Fa0/1 connected trunk auto auto 10/100BaseTX
Fa0/2 connected 1 auto auto 10/100BaseTX
Fa0/3 connected 2 auto auto 10/100BaseTX
Fa0/4 connected 3 auto auto 10/100BaseTX
[...]
-------------------------------
PC0-vlan 1 should have an IP address:
11-17-2023 06:03 AM - edited 11-17-2023 06:04 AM
Hosts are getting the IP address but still have some questions.
Please see attached file
I have some questions. I did not enable the IP helper command. How is it getting the IP address from a different VLAN?
L2 Switch -
hostname Switch
!
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
interface FastEthernet0/1
!
interface FastEthernet0/2
switchport mode access
!
interface FastEthernet0/3
switchport access vlan 2
!
interface FastEthernet0/4
switchport access vlan 3
L3 Switch
hostname Switch
!
!
!
!
ip dhcp pool vlan1
network 10.10.1.0 255.255.255.0
default-router 10.10.1.1
dns-server 8.8.8.8
ip dhcp pool vlan2
network 10.10.2.0 255.255.255.0
default-router 10.10.2.1
dns-server 8.8.8.8
ip dhcp pool vlan3
network 10.10.3.0 255.255.255.0
default-router 10.10.3.1
dns-server 8.8.8.8
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/1
no switchport
ip address 10.10.10.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/2
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
ip address 10.10.1.1 255.255.255.0
!
interface Vlan2
mac-address 0003.e437.9501
ip address 10.10.2.1 255.255.255.0
!
interface Vlan3
mac-address 0003.e437.9502
ip address 10.10.3.1 255.255.255.0
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
11-17-2023 06:50 AM - edited 11-17-2023 09:12 AM
You don't need ip helper address since there's no L3 equipement between hosts and the DHCP server hosted on L3Switch.
Why we need ip helper address? Because broadcast is drop by Router. If there is a Router on the way towards your DHCP server, you need to configure ip helper address on the first adress to act as DHCP relay!
11-17-2023 07:12 AM
If you are right when I have configured the DHCP on the router then I have put the 10.10.10.1 address as DHCP Relay and it worked I usually first implement my topology on virtual labs then on physical labs. I have noticed that everything is good so far; however, I also connected to the ESXI host on VLAN 3; it gives me an IP address of 10.10.3.11; however, when I open this IP address on the browser it points me to the Cisco login page, not VMware host..Not sure why I will attach the pictures
Can you please help me why it's happening..
11-17-2023 07:54 AM - edited 11-17-2023 07:58 AM
I have changed the port and switched to vlan 1 now it shows the Esxi login page ..just thinking why it’s not working on other vlan
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide