cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1467
Views
5
Helpful
4
Replies

PPPoE over VLAN configuration

Gregorygrzegorz
Level 1
Level 1

Hey there,

 

I have Cisco ISR 900 device. I'm trying to pass traffic from my vlan 10 via dialer 1(ppoe client).

When i tested ping from dialer 1 it works but i can not combine dialer and vlan.

Can anyone see what i'm doing wrong?

 

Config in spoiler:

Spoiler


Building configuration...

Current configuration : 2637 bytes
!
! Last configuration change at
!
version 15.8
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
!
!
!
!
!
!
!
!
ip dhcp excluded-address 10.0.0.0 10.0.0.50
!
ip dhcp pool LAN
import all
network 10.0.0.0 255.255.255.0
default-router 10.0.0.254
dns-server 172.64.36.1 172.64.36.2
lease 0 1
!
!
!
ip name-server 172.64.36.1
ip name-server 172.64.36.2
ip cef
no ipv6 cef
multilink bundle-name authenticated
!
vpdn enable
!
vpdn-group 1
!
!
!
license udi pid C921-4P sn xxxxxxxx
!
!
username xxxxxx privilege 15 secret 5 $xxxxxxxxxxxx
!
redundancy
!
!
!
!
!
!
interface GigabitEthernet0
description Lan connection
switchport access vlan 10
no ip address
!
interface GigabitEthernet4
description PrimaryWANDesc_internet connection
no ip address
duplex auto
speed auto
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface GigabitEthernet5
no ip address
shutdown
duplex auto
speed auto
!
interface Vlan1
no ip address
!
interface Vlan10
description Vlan 10
ip address 10.0.0.254 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
interface Dialer0
no ip address
!
interface Dialer1
mtu 1480
ip address negotiated
ip mtu 1480
ip nat outside
ip virtual-reassembly in
encapsulation ppp
ip tcp adjust-mss 1412
dialer pool 1
dialer-group 1
ppp mtu adaptive
ppp authentication chap callin
ppp chap hostname xxxx
ppp chap password 0 xxxx
!
ip forward-protocol nd
ip http server
ip http authentication local
no ip http secure-server
!
!
ip route 0.0.0.0 0.0.0.0 Dialer1
!
dialer-list 1 protocol ip permit
!
!
access-list 1 permit any
!
control-plane
!
!
line con 0
line vty 0 4
login
transport input none
!
scheduler allocate 20000 1000
!
end

 

Thanks in advance for help

 

 

1 Accepted Solution

Accepted Solutions

Hello,

you can also try the below (changes marked in bold

Building configuration...

Current configuration : 2637 bytes
!
! Last configuration change at
!
version 15.8
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
no aaa new-model
!
ip dhcp excluded-address 10.0.0.0 10.0.0.50
!
ip dhcp pool LAN
import all
network 10.0.0.0 255.255.255.0
default-router 10.0.0.254
dns-server 172.64.36.1 172.64.36.2
lease 0 1
!
ip name-server 172.64.36.1
ip name-server 172.64.36.2
ip cef
no ipv6 cef
multilink bundle-name authenticated
!
vpdn enable
!
vpdn-group 1
!
license udi pid C921-4P sn xxxxxxxx
!
username xxxxxx privilege 15 secret 5 $xxxxxxxxxxxx
!
redundancy
!
interface GigabitEthernet0
description Lan connection
switchport access vlan 10
no ip address
!
interface GigabitEthernet4
description PrimaryWANDesc_internet connection
no ip address
duplex auto
speed auto
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface GigabitEthernet5
no ip address
shutdown
duplex auto
speed auto
!
interface Vlan1
no ip address
!
interface Vlan10
description Vlan 10
ip address 10.0.0.254 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
interface Dialer0
no ip address
!
interface Dialer1
mtu 1480
ip address negotiated
ip mtu 1480
ip nat outside
ip virtual-reassembly in
encapsulation ppp
ip tcp adjust-mss 1412
dialer pool 1
dialer-group 1
ppp mtu adaptive
ppp authentication chap callin
ppp chap hostname xxxx
ppp chap password 0 xxxx
!
ip forward-protocol nd
ip http server
ip http authentication local
no ip http secure-server
!
--> ip nat inside source list 1 interface Dialer1 overload
!
ip route 0.0.0.0 0.0.0.0 Dialer1
!
dialer-list 1 protocol ip permit
!
--> access-list 1 permit 10.0.0.0 0.0.0.255
!
control-plane
!
line con 0
line vty 0 4
login
transport input none
!
scheduler allocate 20000 1000
!
end

View solution in original post

4 Replies 4

sorry I dont see attach config 
as @balaji.bandi  mention you need NAT overload, 
if not success 
share 
show ip route 

balaji.bandi
Hall of Fame
Hall of Fame

add below line and test it.

access-list 100 permit 10.0.0.0 0.0.0.255 any
ip nat inside source list 100 interface Dialer1 overload

 

Note : dns-server 172.64.36.1 172.64.36.2  ( if this is valid DNS ok, if not change to 8.8.8.8 google DNS if browsing not working)

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

Hello,

you can also try the below (changes marked in bold

Building configuration...

Current configuration : 2637 bytes
!
! Last configuration change at
!
version 15.8
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
no aaa new-model
!
ip dhcp excluded-address 10.0.0.0 10.0.0.50
!
ip dhcp pool LAN
import all
network 10.0.0.0 255.255.255.0
default-router 10.0.0.254
dns-server 172.64.36.1 172.64.36.2
lease 0 1
!
ip name-server 172.64.36.1
ip name-server 172.64.36.2
ip cef
no ipv6 cef
multilink bundle-name authenticated
!
vpdn enable
!
vpdn-group 1
!
license udi pid C921-4P sn xxxxxxxx
!
username xxxxxx privilege 15 secret 5 $xxxxxxxxxxxx
!
redundancy
!
interface GigabitEthernet0
description Lan connection
switchport access vlan 10
no ip address
!
interface GigabitEthernet4
description PrimaryWANDesc_internet connection
no ip address
duplex auto
speed auto
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface GigabitEthernet5
no ip address
shutdown
duplex auto
speed auto
!
interface Vlan1
no ip address
!
interface Vlan10
description Vlan 10
ip address 10.0.0.254 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
interface Dialer0
no ip address
!
interface Dialer1
mtu 1480
ip address negotiated
ip mtu 1480
ip nat outside
ip virtual-reassembly in
encapsulation ppp
ip tcp adjust-mss 1412
dialer pool 1
dialer-group 1
ppp mtu adaptive
ppp authentication chap callin
ppp chap hostname xxxx
ppp chap password 0 xxxx
!
ip forward-protocol nd
ip http server
ip http authentication local
no ip http secure-server
!
--> ip nat inside source list 1 interface Dialer1 overload
!
ip route 0.0.0.0 0.0.0.0 Dialer1
!
dialer-list 1 protocol ip permit
!
--> access-list 1 permit 10.0.0.0 0.0.0.255
!
control-plane
!
line con 0
line vty 0 4
login
transport input none
!
scheduler allocate 20000 1000
!
end

It works thank you very much