cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3409
Views
0
Helpful
2
Replies
Beginner

Problem to obtain startup-config under privilege level

hi guys

I'm using IOS 15.2 and under this version i cannot obtain the startup-config under certain privilege level ( in this case it is 7 )

i have no problem to get it from the earlier version, also from 15.1

Router#sh privil

Current privilege level is 7

Router#sh startup-config

Using 4414 out of 262136 bytes

%Error opening nvram:/startup-config (Permission denied)

Config:

privilege exec level 7 show startup-config

privilege exec level 15 show configuration

privilege exec level 1 show

When i added cmd "privilege exec level 7 show startup-config", IOS automatically generated new line "privilege exec level 15 show configuration"

seems there must be some "improvement" under 15.2 versions

Any ideas ?

thanks

Pet

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Participant

Problem to obtain startup-config under privilege level

Hello,

I have been facing the same issue and have opened a case. Please find the answer I get from the TAC :

==============================================

This is intended by design as a security measure. Starting in newer releases of IOS, the privilege level for file system access has to be configured separately. There are two options to overcome this:

1) Run the command from the enable prompt.

2) Set the file system privilege level via the config command "file privilege X", with X the privilege level number

==============================================

Hope that helps.

Best regards.

Karim

View solution in original post

2 REPLIES 2
Highlighted
Participant

Problem to obtain startup-config under privilege level

Hello,

I have been facing the same issue and have opened a case. Please find the answer I get from the TAC :

==============================================

This is intended by design as a security measure. Starting in newer releases of IOS, the privilege level for file system access has to be configured separately. There are two options to overcome this:

1) Run the command from the enable prompt.

2) Set the file system privilege level via the config command "file privilege X", with X the privilege level number

==============================================

Hope that helps.

Best regards.

Karim

View solution in original post

Highlighted

thanks krahmani323 Thanks for

thanks krahmani323

Thanks for your comments, the problem was solved in this way.

regards

Router(config)#file privilege ?
  <0-15>  Privilege level3

 

/**-*-*-*-*-*-*-*-**--*-*-*

CreatePlease to create content
Content for Community-Ad