08-04-2016 10:33 PM
HI, I am trying to mark traffic on our switch for traffic going to the ISP router. I have loaded the below config but the ISP isnt seeing the packets being marked. (We have VOIP handsets to ) Any advice would be great.
class-map match-any BA
match access-group name BA
class-map match-any RT
match access-group name RT
class-map match-any VO
match access-group name VO
class-map match-any VI
class-map match-all AutoQoS-VoIP-RTP-Trust
match ip dscp ef
policy-map MAP-QoS
class VO
set dscp ef
class VI
set dscp af43
class RT
set dscp af41
class BA
set dscp af21
policy-map AutoQoS-Police-CiscoPhone
class AutoQoS-VoIP-RTP-Trust
set dscp ef
police 320000 8000 exceed-action policed-dscp-transmit
class AutoQoS-VoIP-Control-Trust
set dscp cs3
police 32000 8000 exceed-action policed-dscp-transmit
ip access-list extended BA
permit ip any host 10.15.1.51
permit ip any host 10.15.1.52
permit tcp any any eq 161
permit tcp any eq 161 any
permit udp any any eq snmp
permit udp any eq snmp any
ip access-list extended RT # RT traffic is what i really want to ISP to prioritize
permit tcp any any eq 1494
permit tcp any eq 1494 any
permit tcp any any eq 2598
permit tcp any eq 2598 any
permit tcp any any eq 1521
permit tcp any eq 1521 any
permit tcp any any eq telnet
permit tcp any eq telnet any
ip access-list extended VO
permit udp any any range 3462 3525
permit udp any any range 9998 10317
permit udp any range 3462 3525 any
permit udp any range 9998 10317 any
Port connected to ISP -
service-policy input MAP-QoS
mls qos trust dscp
David
08-05-2016 05:01 AM
So on the port connected to the ISP, shouldn't it be "service-policy output MAP-QOS"?
08-07-2016 03:35 PM
Hi, output doesnt work on the 3560, i get
Warning: Assigning a policy map to the output side of an interface not supported
08-08-2016 03:29 AM
Seems you can only mark the traffic on ingress and not egress on these switches. Then perhaps apply the service-policy to the other ports so that when they are forwarded to the ISP they will be marked. Is that an option?
08-08-2016 06:45 PM
Hi, are you saying that i should put service-policy input MAP-QoS on all the access ports as well as uplink ports back to the core switch that connects to the ISP?
I can try it
08-09-2016 03:54 AM
If you can only mark in one direction and this is where you need to do it it may be your only recourse. However, I see what appears to be some Auto QoS configured and am not sure what sort of ingress policies you currently have on the access ports. You may have to take that into consideration and combine the policies so you get everything marked the way you want. Hope that makes sense.
Feel free to send a sanitized config if you want.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide