cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
596
Views
0
Helpful
2
Replies
Highlighted
Beginner

RME report generator issue

Hai guys,

We have an issue with RME report generator.

Currently we are using LMS 3.2 installed on VMware esxi5 and RME version 4.3.2.

Every things are working fine except RME reports and RME job browser.

We we try to geneate report we get an error.

Below is error details:

"Problem with File /WEB-INF/screens/reports/InventoryReportsUI.jsp!!!/WEB-INF/screens/reports/InventoryReportsUI.jsp(519,98) Attribute value com.cisco.nm.rmeng.util.EnvironmentAPI.getEnv().getDataDir()+"/rme/jobs/inventory/reports" is quoted with " which must be escaped when used within the value "

we need your kind support to solve this issue.

Your support is highly appreciated.

With Regards,

M.K

2 REPLIES 2
Highlighted
Beginner

Guys,

Any solution to this issue is highly appreciated or i would e better to opne case with TAC.

Need your kind consideration on this disussion.

Thanks in advance.

BR,

M.K

Highlighted

Hi,

Please check and follow the below steps and see if that fixes the issue :

1.     Open the registry and navigate to
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tomcat\Parameters.

2.     Check if entries for below 2 JVM options already exists or not.
-Dorg.apache.jasper.compiler.Parser.STRICT_QUOTE_ESCAPING=false
-Dorg.apache.jasper.compiler.Generator.STRICT_GET_PROPERTY=false

3.     If there are no entries for above, add it as below,

3.1   Right Click on "JVM Option Count" and modify the Value Data. Increase
the value to 2(Say for example: If already value data is 19, then increase
it to 21 to hold 2 New Strings)

3.2   Check how many JVM options are there(i.e starting from 0) and then
note down the last JVM Option Number. 

3.3   Say for example: If there are 20 JVM Option Number starting from 0,
then Right Click on Tomcat -> Parameter, add the String Value as "JVM Option
Number 21". Then provide the Value data with
"-Dorg.apache.jasper.compiler.Parser.STRICT_QUOTE_ESCAPING=false"

3.4   Repeat step3.3 and add another String value "JVM Option Number 22" and
provide the value data with
"-Dorg.apache.jasper.compiler.Generator.STRICT_GET_PROPERTY=false" .

4.     Restart the daemons and check for the issue.

-Thanks

Vinod

-Thanks Vinod **Rating Encourages contributors, and its really free. **
Content for Community-Ad