Showing results for 
Search instead for 
Did you mean: 

Smart Install VLAN creation.

Hi All,

I have been having a play with Smart Install, and it's working fairly well and I am looking to implement in our production environment. The only thing that I find annoying is that when I have all the vlan config in my smart install configuration file; ie:

vlan 324



vlan 125




After the switch load the config and reboots all the VLAN configuration is gone, and I have VLAN's with names like Vlan324 if there were access ports configured to that VLAN. I'm guessing because config gets copied into startup config, however only when it is put into running config is vlan.dat updated on the switch and upon reboot startup_config must get ignored or superseeded by the config of vlan.dat. Since my VLAN's aren't in there new ones get created as needed, and of course a bunch of vlan's are left operating on the trunk, but disabled as they are not defined in the switch.

Does anyone know of an easy way to fix this, perhaps a command that will force creation of vlan.dat based on the startup config? The only guess I have so far is to try and have a line in the Smart Install config to copy startup-config running-config during smart install and hope that this will create the VLAN's and the needed vlan.dat file. But I'm yet to test this, possibly on Monday.

Any ideas would be appreciated. Though using VTP isn't currently something I am entertaining.



42 Replies 42

Leo Laohoo
VIP Community Legend VIP Community Legend
VIP Community Legend

Post your configuration template.  I've got Zero-Touch Smart Install running (with multiple VLANs) and I haven't seen this kind of behaviour before.

Sanatised config attached:

Whatever I did wrong, I blame LMS.

When you do this, you have an existing VLAN.DAT file?  Try removing it, connect the smartinstall port and reboot the switch.

You may also want to try putting VTP mode into Transparent.

I have never encountered a problem like this since I've been suing ZT SmartInstall since 2011. 

Tried a write erase follow by deleating vlan.dat and vlan.dat.renamed from flash. Rebooted and made no difference:

47   VLAN0047                         active    Gi1/0/21, Gi1/0/22

143  VLAN0143                         active    Gi1/0/1, Gi1/0/2, Gi1/0/3

                                                Gi1/0/4, Gi1/0/5, Gi1/0/6

                                                Gi1/0/7, Gi1/0/8, Gi1/0/9

                                                Gi1/0/10, Gi1/0/11, Gi1/0/12

                                                Gi1/0/13, Gi1/0/14, Gi1/0/15

                                                Gi1/0/16, Gi1/0/17, Gi1/0/18

175  VLAN0175                         active    Gi1/0/1, Gi1/0/2, Gi1/0/3

VTP is in transparent mode as per the config.

It's weird. Maybe an IOS bug or something. Will try some things and let you know. Might be time to reach out to our SE, he loves Smart Install and Auto Smart Ports. If anyone else has seen this please let me know.

Might be time to reach out to our SE, he loves Smart Install and Auto Smart Ports.

I know who your SE is.  That's Peter Thomas.  I met him during Cisco Live 2013 in Melbourne.

Tell him I say "Hi". 

PS:  Sent you a PM.

Hello to you both

I have checked and I am havinfg the same issue. I am almost sure that the switches were getting all the vlans.. but they aren't.

Any news on this issue?



Interesting, so what an IOS bug maybe? That will teach me for loading 15.0-2SE1 onto the director just to try out the ultra modern code.

Or is it something else...?

Hi Kevin

Not sure if it is a bug.

I am running with this image:

Switch Ports Model              SW Version            SW Image                

------ ----- -----              ----------            ----------              

*    1 10    WS-C3560CG-8TC-S   15.0(2)SE             C3560c405ex-UNIVERSALK9-M

Maybe should try one other?

Have tried to copy running config to startup on the default config?



Jsut an update. Director upgraded to 15.0(2)SE2 - same issue.

Just a small question:

Which clients are you using?



Hi Isaac,

Sorry for the late response, I just woke up. 

My director is a 3750G-24PS and my clients are 3560CG, 3560E, 2960/2960G/2960S, 3750/G/E/X and ME-3800X.

Hello Kevin

Could you please check if you have the same errors:

Mar 30 03:29:10: VTP mode mismatches between startup-config: transparent, vlan database: server.

Mar 30 03:29:11: %SW_VLAN-4-BAD_STARTUP_VLAN_CONFIG_FILE: Failed to configure VLAN from startup-config.  Fallback to use VLAN configuration file from non-volatile memory

Its strange cause I am sure that I deleted the vlan database before starting the SI

"del vlan.dat"



Just thought of an idea, Kevin.

Without using SmartInstall, if you cut-and-paste the entire config you've posted, can you replicate the problem?

Hej Leolaohoo

I have tested what you asked:

Out of the Box switch  - copy seed file to startup config - all good

Switch that has been through Director install and reseted afterwards with this commands:

del /f flash:vlan.dat

del /f flash:config.text

del /f flash:multiple-­fs

del /f flash:private­-config.text

write erase

Mar 30 03:29:10: %SW_VLAN-4-BAD_STARTUP_VLAN_CONFIG_FILE: Failed to configure VLAN from startup-config.  Fallback to use VLAN configuration file from non-volatile memory

No vlans at all (on my seed file I have no access ports configured)

Will keep posting as soon as I find something new.



Hello igen

Some more tips:

- If I disable Si on the client "no vstack" and copy the same config file fromthe tftp to the starttup everything is ok

Everything points that it is something to do with SI - don't know if it is a cleint or server problem - both running 15.0.2.SE2.

One possibility is to copy the vlan.dat from the Director (tested it and works). Any ideas on how that could be accomplished through



Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: