cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
218
Views
0
Helpful
5
Replies
Highlighted

Startup-running config

Hi Experts,

 

When I do certain changes in the CLI and then issued command copy running config startup config 

 

1. I am understood that the running config are saved to startup config(NVRAM) and when issued sh startup, it is showing.

2. Same I have done some changes and given the command copy startup running config.

eg: int gig0/0/1

description backup LAN

ip add 10.240.25.1 255.255.255.0

no shutdown

 

The above config is in running and I did not saved (wr).

 

In startup config I could see the interface gig0/0/1 is in default mode. My assumption is that when I try to copy the startup config to running my interface gig0/0/1 should become default, but it was not happened.

 

Can u guys explain what is the significant difference when we give copy startup to running config.

 

Regards,

Sathish

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: Startup-running config

Thanks Balaji for the answers.

View solution in original post

5 REPLIES 5
Highlighted
VIP Mentor

Re: Startup-running config

startup config will be loaded automatically when the device start.

 

runninng config will be temporarly stored as running, until you issue command wr or copy manually to startup (your understand here is correct)

 

it will not work or take effective copy from startup to running config ( take effective in the live)

 

if you want to take effecttive of startup it has to rebooted or you can manually do the same way you on running config.

 

BB
*** Rate All Helpful Responses ***
Highlighted

Re: Startup-running config

Thanks Balaji for the answers.

View solution in original post

Highlighted
VIP Advisor

Re: Startup-running config

Highlighted

Re: Startup-running config

Thanks for the link
Highlighted
Hall of Fame Master

Re: Startup-running config

While they look very similar the commands copy run start and copy start run operate very differently. copy run start results in a complete replacement of the previous startup config file with a new file reflecting the running config. But copy start run is more of an overlay process. Any line found in the startup config will replace the corresponding line of the running config. But any line in the running config for which there is not a corresponding line in startup will continue to be in the config. For example we might have and interface in running config that has this

interface FastEthernet 1

ip address 10.10.10.1 255.255.255.0

ip access-group 101 in

and startup config might have this

interface FastEthernet 1

ip address 20.20.20.2 255.255.255.0

If we copy start run the result will be 

Interface FastEthernet 1 

ip address 20.20.20.2 255.255.255.0

ip access-group 101 in

 

The reason for the difference in behavior is based on differences between running config and startup config. While startup config is essentially a text file in nvram the running config is a data structure in ram. copy run start interrogates the data structure, takes its content, builds a new text file and that new file replaces the existing startup config. copy start run takes the existing startup config file and feeds it into the syntax processor which updates the existing data structure (does not create a new data structure).

 

HTH

 

Rick

 

HTH

Rick
CreatePlease to create content
Content for Community-Ad