cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1126
Views
0
Helpful
24
Replies
Highlighted
Beginner

Unable to view list of added devices in LMS

Dear All ,

     Iam working on Cisco LMS 3.2.1.Everything was working fine before but since last 2-3 days we are unable to view the list of added devices under device management tab.We are able to see the added groups only.Because of this issue we are unable to get the logs from the added devices.

Can anybody help in resolving this issue.....???

Regards ,

Divya A M

24 REPLIES 24
Highlighted
Cisco Employee

Hi Divya,

Share the output of pdshow command.

In the meantime if possible reboot the server and check the status of the issue.

Thanks-

Afroz

[Do rate the useful post]

Thanks- Afroz [Do rate the useful post] ****Ratings Encourages Contributors ****
Highlighted

Hi Afroz ,

         We already tried rebooting the server , but it didnot help. Now the drive where we have installed LMS (E:\LMS) is 100%.We found that dcrclient.log is taking around 45 GB space.Is it wise to delete the log.Please suggest.

Right now all the processes are down.

Regards ,

Divya A M

Message was edited by: Divya AM

Highlighted

Hi Divya,

Yes , you can delete this file .Instead of delete try this :

NMSROOT\CSCOPx\log>logrot_trunc dcrclient.log

Thanks-

Thanks- Afroz [Do rate the useful post] ****Ratings Encourages Contributors ****
Highlighted

Hi Afroz ,

    We are unable to find NMSROOT\CSCOPx folder.Please help.

Regards ,

  Divya

Highlighted

NMSROOT is nothing other than the directory where LMS is installed.

I think in your case it is E:\ drive

E:\program files\CSCOpx

Thanks- Afroz [Do rate the useful post] ****Ratings Encourages Contributors ****
Highlighted

  Yes , thats where we checked.We don't have program files in E drive as well.

Highlighted

share the screen shot of the command   PATH  from the command prompt of the server

Thanks- Afroz [Do rate the useful post] ****Ratings Encourages Contributors ****
Highlighted

Just delete the file , it has no impact on LMS

you can create a new one with the  same name.. with all the required premission

Thanks-

Thanks- Afroz [Do rate the useful post] ****Ratings Encourages Contributors ****
Highlighted

   We deleted the file and rebooted the server.But while trying to connect to LMS  (" http://sp23dms2:1741 ")

we are getting the following error :-

"The server is temporarily unable to service your request due to maintenance  downtime or capacity problems. Please try again later."

We tried restarting the services and observed that " Ciscoworks tomcat servlet engine " service is automaticallt stopping ,  once we try to connect to LMS.

Highlighted

Hi ,

Is this a windows server ?

If it is a windows server then  open the servies window (type >>services.msc in the RUN)

now change the STARTUP type of the daemon manager  to MANUAL and reboot the server.

once server is back change the startup type to AUTOMATIC and then start the daemon manager and check the status of the issue.

Thanks-

Afroz

Thanks- Afroz [Do rate the useful post] ****Ratings Encourages Contributors ****
Highlighted

We followed the steps as recomended.But the situation is still the same.Ciscoworks tomcat servlet engine service is stopping automatically.

Regards ,

  Divya

Highlighted

Hi Divya,

Stop the daemon manager (net stop crmdmgtd)

Reset the Casuser Password :

NMSROOT/CSCOpx/setup/support>resetCasuser.exe

Next step:

Try to Unregister and Register the Apache service  :

To Unregistered:

pdreg -u Apache

To registered :

C:\PROGRA~2\CSCOpx\MDC\Apache\bin>pdreg -r Apache -e "C:\PROGRA~2\CSCOpx\MDC\Apache\bin\Apache.exe" -f "-d C:\PROGRA~2\CSCOpx\MDC\Apache -D SSL" -d TomcatMonitor

Change the C:\progra~2\CSCOpx  with your Cisco works Installed Directory.

Now start the Daemon Manager (net start crmdmgtd)

I hope this will help

Thanks-

Thanks- Afroz [Do rate the useful post] ****Ratings Encourages Contributors ****
Highlighted

We tried the suggested steps and could successfully reset the Casuser Password.But couldnot perform unregistering and registering Apache service.We ended up getting the following errors.

1.)

C:\Documents and Settings\Administrator>pdreg -u Apache

(no output)

2.)

E:\lms\MDC\Apache\bin>pdreg -r Apache -e

pdcmd: option requires an argument -- e

ERROR: no such command, or option error.

Usage:

    pdcmd options...

Where

-b msg

    broadcast message to all daemons

-k daemon

    kill daemon

-K

    stop system

-H

    start system

-l

    list daemon registry

-R daemon

    start daemon

-i daemon

    show daemon status briefly

-I

    show all daemons status briefly

-s daemon

    show daemon status

-S

    show all daemons status

-G

    show daemon statistics

-r daemon -e path -d depends -f arguments [-w ] [-n] [

-q] [-t code]

    register daemon (-w -- timeout for ready file notification)

                    (-n -- no autostart)

                    (-q -- no INFO messages)

                    (-t {0|p|n} -- expected transient exit code

                         where

                            0 = expected exit code is 0

                            p = expected exit code is >=0

                            n = expected exit code is < 0 )

-u daemon [-q]

    unregister daemon (-q -- no INFO messages)

-v

    show version number

3.)

E:\lms\MDC\Apache\bin>Apache.exe" -f "-d

'Apache.exe" -f "-d' is not recognized as an internal or external command,

operable program or batch file.

4.)

E:\lms\MDC>Apache -D SSL" -d TomcatMonitor

(OS 10048)Only one usage of each socket address (protocol/network address/port)

is normally permitted.  : make_sock: could not bind to address 0.0.0.0:443

no listening sockets available, shutting down

Unable to open logs

Regards  ,

Divya

Highlighted

Now we are getting another error while trying to login to console.

HTTP Status 404 -


type Status report

message

description The requested resource () is not available.


Apache Tomcat/5.5.29

And it is observed that the earlier mentioned problem  -  " Ciscoworks tomcat servlet engine service is stopping automatically." is not existing anymore.

Regards ,

Divya

Content for Community-Ad