cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
751
Views
0
Helpful
7
Replies
tutoy83
Beginner

Why is the DHCP VOIP Vlan not working ?

Hello, 

 

My two phones don't get IP addresses from DHCP Vlan 66, could you tell me why ? The GUI of the IP phones print "Configuring IP".

 


Router>Router>en

Router#sh run

Building configuration...

 

Current configuration : 1269 bytes

!

version 15.1

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname Router

!

!

!

!

ip dhcp excluded-address 10.66.0.1

!

ip dhcp pool voix

network 10.66.0.0 255.255.0.0

default-router 10.66.0.1

option 150 ip 10.66.0.1

!

!

!

no ip cef

no ipv6 cef

!

!

!

!

license udi pid CISCO2811/K9 sn FTX1017SHJS-

!

!

!

!

!

!

!

!

!

!

!

spanning-tree mode pvst

!

!

!

!

!

!

interface FastEthernet0/0

no ip address

duplex auto

speed auto

!

interface FastEthernet0/0.66

encapsulation dot1Q 66

ip address 10.66.0.1 255.255.0.0

!

interface FastEthernet0/0.99

encapsulation dot1Q 99

ip address 192.168.99.1 255.255.255.0

!

interface FastEthernet0/1

no ip address

duplex auto

speed auto

shutdown

!

interface Vlan1

no ip address

shutdown

!

ip classless

!

ip flow-export version 9

!

!

!

!

!

!

!

!

telephony-service

max-ephones 5

max-dn 5

ip source-address 10.66.0.0 port 2000

auto assign 4 to 6

auto assign 1 to 5

!

ephone-dn 1

number 101

!

ephone-dn 2

number 102

!

ephone 1

device-security-mode none

mac-address 0030.A398.B802

type 7960

button 1:1

!

ephone 2

device-security-mode none

mac-address 0030.A398.B803

type 7960

button 1:2

!

line con 0

!

line aux 0

!

line vty 0 4

login

!

!

!

end


SWitch 

 

!

hostname Switch

!

!

!

!

!

!

lldp run

!

spanning-tree mode pvst

spanning-tree extend system-id

!

interface FastEthernet0/1

switchport access vlan 66

switchport trunk native vlan 99

switchport mode trunk

switchport voice vlan 66

!

interface FastEthernet0/2

switchport access vlan 66

switchport mode access

switchport voice vlan 66

!

interface FastEthernet0/3

switchport access vlan 66

switchport mode access

switchport voice vlan 66

!

interface FastEthernet0/4

!

interface FastEthernet0/5

!

interface FastEthernet0/6

!

interface FastEthernet0/7

!

interface FastEthernet0/8

!

interface FastEthernet0/9

!

interface FastEthernet0/10

!

interface FastEthernet0/11

!

interface FastEthernet0/12

!

interface FastEthernet0/13

!

interface FastEthernet0/14

!

interface FastEthernet0/15

!

interface FastEthernet0/16

!

interface FastEthernet0/17

!

interface FastEthernet0/18

!

interface FastEthernet0/19

!

interface FastEthernet0/20

!

interface FastEthernet0/21

!

interface FastEthernet0/22

!

interface FastEthernet0/23

!

interface FastEthernet0/24

!

interface GigabitEthernet0/1

!

interface GigabitEthernet0/2

!

interface Vlan1

no ip address

shutdown

!

interface Vlan66

ip address 10.66.0.2 255.255.0.0

!

interface Vlan99

ip address 192.168.99.10 255.255.255.0

!

ip default-gateway 192.168.99.1

!

!

!

!

line con 0

!

line vty 0 4

login

line vty 5 15

login

!

!

!

!

end


 

 

 

Thank you for your help

Mike

2 ACCEPTED SOLUTIONS

Accepted Solutions

Hello,

 

in short, everything was misconfigured: the access ports, the trunk port, the subinterface on the router, the switch SVI, and the ephone mac addresses. I have revised the file, review the configurations...

View solution in original post

Hello,

 

good stuff ! I did not list all errors in detail, but I guess you figured it out anyway !

View solution in original post

7 REPLIES 7
Flavio Miranda
Advisor

Hi

 Is it PacketTracer? can you add the pkt file in here?

Georg Pauwen
VIP Master

Hello,

 

there is one crucial mistake in your configuration, change that and check if it works then:

 

-->  --> ip source-address 10.66.0.0 port 2000

 

needs to be:

 

--> --> ip source-address 10.66.0.1 port 2000

Hello, 

 

Thank you for your replies, I think it's a phone MAC Adress problem or wrong switch port config ?... I would like it to be on the VLAN 66.

Hello,

 

in short, everything was misconfigured: the access ports, the trunk port, the subinterface on the router, the switch SVI, and the ephone mac addresses. I have revised the file, review the configurations...

Thank you ! I checked your config and tried to do it myself and now... it works ! @Georg Pauwen 

Thank you ! I checked your config and tried to do it myself and now... it works ! @Georg Pauwen 

Hello,

 

good stuff ! I did not list all errors in detail, but I guess you figured it out anyway !