cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

34248
Views
41
Helpful
39
Replies
bal09
Beginner

ASDM unable to load the firewall configuration

I am trying to login using asdm and i keep getting the error ASDM unable to load the firewall configuration.

The firewall is running ASA version 9.5(1) and the ASDM version is 7.5(1).

Java version installed is java 8 update 60 I was on windows 7 but now moved to windows 10 so not really sure what could be the issue.

 

I can however access on a mac fine but need this to be working on windows 10 any help appreciated?

39 REPLIES 39

I want to also confirm, Windows 10 and ASDM with FirePower configured on ASA5506-X (with FirePower interface UP) gives the  above error.

If the FirePower interface is disconnected or Down, ASDM continues to run.

A workaround is to use Windows 7 in my case.

HI all,

I have the same problem working on Windows 7 and Java 8.60. I'm running ASA 9.4(1) and ASDM 7.4(3) on a ASA5506-X

Some days ago it worked fine.

ASA5506-X, ASA 9.5(1) and ASDM 7.5(1) here with Windows 10 and Java 8 Update 6, same problem. Identity certificate is in place, and I can access ASDM via another computer with Windows 8.1 & Java 8 Update 45 (both ASDM Launcher & Web Start)

Noticed that when opening Java Console, there is an error line mentioning supported operating system: "Caused by: com.teamdev.jxbrowser.chromium.internal.EnvironmentException: Unsupported operating system. Supported OS: Windows XP (SP2), 7, 8, Vista, 2003 (SP1), 2008, 2012, Mac OS X & Linux. Current OS: Windows 10"

This is consitent with the current release notes, where they not list Windows 10 as supported OS for ASDM, currently.

R.Seth as you seem to be the only one that seems to have this working would you like to share you system setup outputs from the java log and rest to see what the differences are which other users on windows 10 are experiencing

Hi,

 

I tried the setup with sfr running on ASA5500-x device and not on 5506 device.

So i am not sure if there is any change in the behaviour in terms of ASDM operation.

I will try to look into this.

 

Thanks,

R.Seth.

I'm also having the same problem.

-Windows 10

-Java version 8 update 60

-ASA 5506-X with FirePOWER services

-Cisco Adaptive Security Appliance Software Version 9.5(1)
-Device Manager Version 7.5(1)

 

Hi Guys,

Whoever is running into this problem , can use this workaround:-

Rollback Java on Windows 10 to Java 8u51 or prior releases.

Thanks and Regards,

Vibhor Amrodia

Vibhor

 

Downgrading to Java 8u51 seems to have done the trick.

I can access the SFR via asdm now with no issues. I suspect an update will be produced to allow use of the latest java in time?

Hi,

That's great. Yes , this is a known issue and we don't support WIndows 10 with the latest Java for the moment. So , would request you to use this workaround for the moment.

Thanks and Regards,

Vibhor Amrodia

 

Hi,

I also had this issue with W7 64bits an Java 8u60. Downgrading Java to 8u51 also solved the issue.

Some details: I have both Java 8u60 x86 and Java8u51 64 bits installed. 8u60 for up-to-date security when using Firefox (32 bits). Beside, I have adjusted ASDM run.bat to ensure ASDM is using 8u51, see run.bat extract below:

start "" "C:\Program Files\Java\jre1.8.0_51\bin\javaw.exe" -Xms64m -Xmx1G ...etc

Hope this helps,

Thanks

Your solution/workaround worked perfectly. Thanks for sharing it with us jean.rozycki

any plans to update the error one receives? Ie rather than , unable to load configuration.

Java incompatability in the error message?

Rolling back to Java 8u51 fixed the problem for me. Thanks!

I have the same problem - works for me on Windows 7 but not Windows 10.  It's all about whether the FirePOWER tabs need to be loaded (at least for admin access).  Pretty sure Cisco will have to fix this.

If you don't always need admin access to the FirePOWER module, one option might be to configure a user with a priv level below 15.  On Win 10 such a user can log in and work with the ASA in ASDM.

 

The problem is windows 10 and the Java version.

 

 

If you spin up windows 7 and 51u8 java it works .

 

Kind of silly Cisco keeps attaching to this java junk .

Create
Recognize Your Peers
Content for Community-Ad