cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

1335
Views
0
Helpful
4
Replies
Highlighted
Beginner

the rommon mode tftpdnld command error

hi everyone

 

I wanna upgrade my asa os from tftp server. I set this variables in rommon mode:

ROMMON Variable Settings:
ADDRESS=172.17.17.216
SERVER=192.168.199.17
GATEWAY=172.17.17.214
PORT=Data0
VLAN=900
IMAGE=asa916-10-smp-k8.bin
CONFIG=
LINKTIMEOUT=20
PKTTIMEOUT=2
RETRY=20

 

also it can ping the server:

rommon #9> ping server
Sending 20, 100-byte ICMP Echoes to server 192.168.199.17, timeout is 2 seconds:

Aug  5 20:38:17: %SNMP-3-RESPONSE_DELAYED: processing Get of ifHighSpeed.123 (45000 msecs)?!!!!!!!!!!!!!!!!!!!
Success rate is 95 percent (19/20)

 

then I issue the tftpdnld command at the rommon mode:

rommon #10> tftpdlnd
Invalid or incorrect command.  Use 'help' for help.
rommon #10> tftpdnld
Clearing EOBC receive queue ...
cmostime_set = 1
ROMMON Variable Settings:
  ADDRESS=172.17.17.216
  SERVER=192.168.199.17
  GATEWAY=172.17.17.214
  PORT=Data0
  VLAN=900
  IMAGE=asa916-10-smp-k8.bin
  CONFIG=
  LINKTIMEOUT=20
  PKTTIMEOUT=2
  RETRY=20

tftp asa916-10-smp-k8.bin@192.168.199.17 via 172.17.17.214
Starting download. Press ESC to abort.
!!!!!!!!!!!!!!
Aug  5 20:39:17: %SNMP-3-RESPONSE_DELAYED: processing Get of ifHighSpeed.123 (45072 msecs)!!!!!!!!!!!!!!!!!!!!!!!!!!!
Aug  5 20:40:23: %SNMP-3-RESPONSE_DELAYED: processing Get of ifHighSpeed.123 (50892 msecs)!!!!!!!!!!!!!!!!!
Aug  5 20:41:18: %SNMP-3-RESPONSE_DELAYED: processing Get of ifHighSpeed.123 (46228 msecs)!!!!!!!!!!!!!!!!
Received 38191104 bytes

Sending recovery done SCP message to supervisor.
ACK received.
Launching TFTP Image...

Cisco Security Appliance admin loader (3.0) #0: Fri Sep 11 16:15:22 PDT 2015
Platform WS-SVC-ASA-SM1

 

but at the end it stops and shows the below error:

open /dev/sda1:No such file or directory
dosfsck(/dev/sda1) returned 1
mount: mounting /dev/sda1 on /mnt/disk0 failed: No such file or directory
mount: mounting /dev/sda1 on /mnt/disk0 failed: No such file or directory
Processor memory 11245211648, Reserved memory: 0

 

can anyone help with this?

 

thanks in advance

 

best regards,Sina 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Cisco Employee

The logs you've posted indicate that he connectivity is there and the file is downloading correctly and attempting to install - there is some other issue at this point.

 

My recommendation would to open a TAC case as there may be a hardware issue.  The only hits/times I've seen this before we've had to RMA the ASA-SM1.  That may not be necessary in this case, but TAC should be able to verify.

View solution in original post

4 REPLIES 4
Highlighted
Rising star

Hello, If the connectivity is established in terms of icmp, the only other reason could be is if the tftp port is blocked on a layer 3 device or if the image you are trying to copy is not in the default directory on tftp server. Try to copy the file in the home directory for tftp server and try again. Regards, Ajay
Highlighted
VIP Advisor

check this:

 

https://community.cisco.com/t5/firewalls/asa-5520-issue/td-p/2065250

Please remember to rate useful posts, by clicking on the stars below.

Highlighted
VIP Advisor

have you seen this:

 

https://community.cisco.com/t5/firewalls/asa-5520-issue/td-p/2065250

Please remember to rate useful posts, by clicking on the stars below.

Highlighted
Cisco Employee

The logs you've posted indicate that he connectivity is there and the file is downloading correctly and attempting to install - there is some other issue at this point.

 

My recommendation would to open a TAC case as there may be a hardware issue.  The only hits/times I've seen this before we've had to RMA the ASA-SM1.  That may not be necessary in this case, but TAC should be able to verify.

View solution in original post

Content for Community-Ad