Background:
By definition with OSPFv2 the content of the LSA Type 2 describes the network segment listing the DR address, the attached routers, and the used subnet mask. This information is used by each router participating in OSPF to build the exact picture of the described multiaccess segment, which cannot be fully described with just LSAs Type 1.
With OSPFv3 the LSA Type 2 does not carry the used subnet mask and the DR address.
Inside the Network LSA Type 2 generated by a DR, there is no information of the subnet mask and the DR address, only the attached routers are carried.
Configure R1 and R2 using OSPFv3 Address Family, R3 will be configured later
R1:
interface FastEthernet0/0
ip address 12.0.0.1 255.255.255.0
ipv6 enable
ospfv3 1 ipv4 area 0
!
router ospfv3 1
!
address-family ipv4 unicast
router-id 1.1.1.1
R2:
interface FastEthernet0/0
ip address 12.0.0.2 255.255.255.0
ipv6 enable
ospfv3 1 ipv4 area 0
!
router ospfv3 1
!
address-family ipv4 unicast
router-id 2.2.2.2
Verify OSPFv3 adjacency, R2 is the DR because the highest router-id:
R1#show ospfv3 neighbor
OSPFv3 1 address-family ipv4 (router-id 1.1.1.1)
Neighbor ID Pri State Dead Time Interface ID Interface
2.2.2.2 1 FULL/DR 00:00:39 2 FastEthernet0/0
R1#
Verify the Link State Database LSDB of R1:
We can see that R2 advertises a Network LSA Type 2 and an Intra-Area Prefix LSA Type 9 because it is a DR, R1 does not generate an LSA Type 9 as shown by the LSDB below:
R1#show ospfv3 database
OSPFv3 1 address-family ipv4 (router-id 1.1.1.1)
Router Link States (Area 0)
ADV Router Age Seq# Fragment ID Link count Bits
1.1.1.1 18 0x8000000D 0 1 None
2.2.2.2 129 0x80000004 0 1 None
Net Link States (Area 0)
ADV Router Age Seq# Link ID Rtr count
2.2.2.2 129 0x80000001 2 2
Link (Type-8) Link States (Area 0)
ADV Router Age Seq# Link ID Interface
1.1.1.1 19 0x80000008 2 Fa0/0
2.2.2.2 184 0x80000002 2 Fa0/0
Intra Area Prefix Link States (Area 0)
ADV Router Age Seq# Link ID Ref-lstype Ref-LSID
2.2.2.2 129 0x80000001 2048 0x2002 2
R1#
Why R1 does not generate an LSA Type 9 ?
By definition with OSPFv2 the content of the LSA Type 2 describes the network segment listing the DR address, the attached routers, and the used subnet mask. This information is used by
each router participating in OSPF to build the exact picture of the described multiaccess segment, which cannot be fully described with just LSAs Type 1.
With OSPFv3 the LSA Type 2 does not carry the used subnet mask and the DR address.
Let's verify the Network LSA Type 2 generated by the R2, we can see that there is no information of the subnet mask and the DR address, only the attached routers and the Link State ID: 2 are carried as shown by the show ospfv3 database network command:
R1#show ospfv3 database network
OSPFv3 1 address-family ipv4 (router-id 1.1.1.1)
Net Link States (Area 0)
LS age: 156
Options: (E-Bit, R-bit, DC-Bit, AF-Bit)
LS Type: Network Links
Link State ID: 2 (Interface ID of Designated Router)
Advertising Router: 2.2.2.2
LS Seq Number: 80000001
Checksum: 0x16DC
Length: 32
Attached Router: 2.2.2.2
Attached Router: 1.1.1.1
R1#
Per RFC 5340 OSPF for IPv6
4.4.3.3. Network-LSAs
The LS type of a network-LSA is set to the value 0x2002. Network-
LSAs have area flooding scope. A network-LSA is originated for every
broadcast or NBMA link with an elected Designated Router that is
fully adjacent with at least one other router on the link. The
network-LSA is originated by the link's Designated Router and lists
all routers on the link with which it is fully adjacent.
The procedure for originating network-LSAs in IPv6 is the same as the
IPv4 procedure documented in Section 12.4.2 of [OSPFV2], with the
following exceptions:
An IPv6 network-LSA's Link State ID is set to the Interface ID of
the Designated Router on the link.
IPv6 network-LSAs do not contain a Network Mask. All addressing
information formerly contained in the IPv4 network-LSA has now
been consigned to intra-Area-Prefix-LSAs originated by the link's
Designated Router.
Here comes the Intra-area prefix LSA (Type 9) for help.
OSPFv3 defines a new LSA called Intra-area prefix LSAs (Type 9): A router can originate multiple intra-area prefix LSAs for each router or transit network, each with a unique link-state ID. The link state ID for each intra-area prefix LSA describes its association to either the router LSA or the network LSA. The link-state ID also contains prefixes for stub and transit networks.
This LSA type (Intra Area Prefix) provides information for two different scenarios:
1) It will provide information about IPv6 address prefixes associated with a transit network by referencing a Network LSA.
2) It will provide information about IPv6 address prefixes associated with a router by referencing a Router LSA. Type 9 LSAs are only flooded within an area.
Let's verify the Intra-area prefix LSA (Type 9) advertised by the DR R2:
We can see that this LSA Type 9 carries the following information:
-The subnet 12.0.0.0 and the subnet mask (Prefix Length) /24
-Referenced Link State ID: 2 that matches the Link State ID of the LSA Type 2.
-Referenced LSA Type: 2002 describes its association to the Network LSA Type 2 (or 2002).
R1#show ospfv3 database prefix
OSPFv3 1 address-family ipv4 (router-id 1.1.1.1)
Intra Area Prefix Link States (Area 0)
Routing Bit Set on this LSA
LS age: 230
LS Type: Intra-Area-Prefix-LSA
Link State ID: 2048
Advertising Router: 2.2.2.2
LS Seq Number: 80000001
Checksum: 0x4E7D
Length: 40
Referenced LSA Type: 2002
Referenced Link State ID: 2
Referenced Advertising Router: 2.2.2.2
Number of Prefixes: 1
Prefix Address: 12.0.0.0
Prefix Length: 24, Options: None, Metric: 0
R1#
Therefore when running OSPFv3 in multiaccess segment, the DR generates a unique LSA Type 2 describing the attached routers and unique LSA Type 9 describing the subnet and the subnet mask used in this segment.
Because R1 is not a DR, it does not generate an LSA Type 9.
Let's configure the link fastethernet as point-to-point network type:
R1(config)#int fa0/0
R1(config-if)#ospfv3 network point-to-point
R2(config)#int fa0/0
R2(config-if)#ospfv3 network point-to-point
Let's verify the LSDB of R1:
Because there is no DR election, each router (R1 and R2) generates an intra-area prefix LSA Type 9:
Notice the presence of two LSA Type 9 in the LSDB of R1, one originated by itself and another by R2.
R1#show ospfv3 database
OSPFv3 1 address-family ipv4 (router-id 1.1.1.1)
Router Link States (Area 0)
ADV Router Age Seq# Fragment ID Link count Bits
1.1.1.1 23 0x80000004 0 1 None
2.2.2.2 11 0x80000003 0 1 None
Link (Type-8) Link States (Area 0)
ADV Router Age Seq# Link ID Interface
1.1.1.1 342 0x80000002 2 Fa0/0
2.2.2.2 369 0x80000001 2 Fa0/0
Intra Area Prefix Link States (Area 0)
ADV Router Age Seq# Link ID Ref-lstype Ref-LSID
1.1.1.1 23 0x80000001 0 0x2001 0
2.2.2.2 11 0x80000001 0 0x2001 0
R1#
The show ospfv3 database prefix self-originate command displays the content of LSA Type 9 created by R1, It will provide information about IPv6 address prefix 12.0.0.0/24 associated with a router by referencing a Router LSA Type 1 "Referenced LSA Type: 2001"
R1#show ospfv3 database prefix self-originate
OSPFv3 1 address-family ipv4 (router-id 1.1.1.1)
Intra Area Prefix Link States (Area 0)
Routing Bit Set on this LSA
LS age: 114
LS Type: Intra-Area-Prefix-LSA
Link State ID: 0
Advertising Router: 1.1.1.1
LS Seq Number: 80000001
Checksum: 0x8A53
Length: 40
Referenced LSA Type: 2001
Referenced Link State ID: 0
Referenced Advertising Router: 1.1.1.1
Number of Prefixes: 1
Prefix Address: 12.0.0.0
Prefix Length: 24, Options: None, Metric: 1
R1#
Same informations are carried by the LSA Type 9 generated by R2 as shown by the show ospfv3 database prefix adv-router 2.2.2.2 command:
R1#show ospfv3 database prefix adv-router 2.2.2.2
OSPFv3 1 address-family ipv4 (router-id 1.1.1.1)
Intra Area Prefix Link States (Area 0)
LS age: 205
LS Type: Intra-Area-Prefix-LSA
Link State ID: 0
Advertising Router: 2.2.2.2
LS Seq Number: 80000001
Checksum: 0x9E37
Length: 40
Referenced LSA Type: 2001
Referenced Link State ID: 0
Referenced Advertising Router: 2.2.2.2
Number of Prefixes: 1
Prefix Address: 12.0.0.0
Prefix Length: 24, Options: None, Metric: 1
R1#
Let's remove the OSPFv3 network point-to-point type in the fastethernet link:
R1(config)#int fa0/0
R1(config-if)#no ospfv3 network point-to-point
R2(config)#int fa0/0
R2(config-if)#no ospfv3 network point-to-point
Let's add a router R3 connected to R1 via a serial link:
R1:
interface Serial1/0
ip address 13.0.0.1 255.255.255.0
ipv6 enable
ospfv3 1 ipv4 area 0
R3:
interface Serial1/0
ip address 13.0.0.3 255.255.255.0
ipv6 enable
ospfv3 1 ipv4 area 0
!
router ospfv3 1
!
address-family ipv4 unicast
router-id 3.3.3.3
Let's verify the OSPF adjacencies, we can see that there is no DR election in the serial link:
R1#show ospfv3 neighbor
OSPFv3 1 address-family ipv4 (router-id 1.1.1.1)
Neighbor ID Pri State Dead Time Interface ID Interface
3.3.3.3 0 FULL/ - 00:00:39 4 Serial1/0
2.2.2.2 1 FULL/DR 00:00:39 2 FastEthernet0/0
R1#
Let's see the LSDB of R1:
We can see that R1 generates an LSA Type 9.
R1#show ospfv3 database
OSPFv3 1 address-family ipv4 (router-id 1.1.1.1)
Router Link States (Area 0)
ADV Router Age Seq# Fragment ID Link count Bits
1.1.1.1 68 0x80000007 0 2 None
2.2.2.2 285 0x80000005 0 1 None
3.3.3.3 70 0x80000002 0 1 None
Net Link States (Area 0)
ADV Router Age Seq# Link ID Rtr count
2.2.2.2 285 0x80000001 2 2
Link (Type-8) Link States (Area 0)
ADV Router Age Seq# Link ID Interface
1.1.1.1 78 0x80000001 4 Se1/0
3.3.3.3 70 0x80000001 4 Se1/0
1.1.1.1 939 0x80000002 2 Fa0/0
2.2.2.2 966 0x80000001 2 Fa0/0
Intra Area Prefix Link States (Area 0)
ADV Router Age Seq# Link ID Ref-lstype Ref-LSID
1.1.1.1 78 0x80000001 0 0x2001 0
2.2.2.2 285 0x80000001 2048 0x2002 2
3.3.3.3 70 0x80000001 0 0x2001 0
R1#
Let's verify the content of the LSA Type 9 generated by R1:
The LSA Type 9 carries only the informations about the subnet and the subnet mask of the serial link 13.0.0.0/24 and associated with a router by referencing a Router LSA "Referenced LSA Type: 2001" and the "Referenced Link State ID: 0" which references the Link State ID of its Router LSA Type 1:
R1#show ospfv3 database prefix self-originate
OSPFv3 1 address-family ipv4 (router-id 1.1.1.1)
Intra Area Prefix Link States (Area 0)
Routing Bit Set on this LSA
LS age: 589
LS Type: Intra-Area-Prefix-LSA
Link State ID: 0
Advertising Router: 1.1.1.1
LS Seq Number: 80000001
Checksum: 0x108D
Length: 40
Referenced LSA Type: 2001
Referenced Link State ID: 0
Referenced Advertising Router: 1.1.1.1
Number of Prefixes: 1
Prefix Address: 13.0.0.0
Prefix Length: 24, Options: None, Metric: 64
R1#
Let's see the Router LSA Type 1 of R1, there is no information about the subnet 13.0.0.0/24, only the Link connected to another Router, the Link State ID: 0 is used by R1 to associate this LSA Type 1 with its LSA Type 9 "Referenced Link State ID: 0"
R1#show ospfv3 database router self-originate
OSPFv3 1 address-family ipv4 (router-id 1.1.1.1)
Router Link States (Area 0)
LS age: 25
Options: (E-Bit, R-bit, DC-Bit, AF-Bit)
LS Type: Router Links
Link State ID: 0
Advertising Router: 1.1.1.1
LS Seq Number: 8000000E
Checksum: 0xE497
Length: 56
Number of Links: 2
Link connected to: another Router (point-to-point)
Link Metric: 64
Local Interface ID: 4
Neighbor Interface ID: 4
Neighbor Router ID: 3.3.3.3
Link connected to: a Transit Network
Link Metric: 1
Local Interface ID: 2
Neighbor (DR) Interface ID: 2
Neighbor (DR) Router ID: 2.2.2.2
R1#
Let's configure the serial link as broadcast network type:
R1(config)#int s1/0
R1(config-if)#ospfv3 network broadcast
R3(config)#int s1/0
R3(config-if)#ospfv3 network broadcast
Verify the OSPF adjacencies, since we have two multiaccess segment, there are two DRs elected , R2 for the fastethernet link and R3 for the serial link:
R1#show ospfv3 neighbor
OSPFv3 1 address-family ipv4 (router-id 1.1.1.1)
Neighbor ID Pri State Dead Time Interface ID Interface
3.3.3.3 1 FULL/DR 00:00:38 4 Serial1/0
2.2.2.2 1 FULL/DR 00:00:38 2 FastEthernet0/0
R1#
Let's verify the LSDB of R1:
We can see that R1 does not generate any LSA Type 9.
There are only two LSA Type 9 generated by the DRs R2 and R3:
R1#show ospfv3 database
OSPFv3 1 address-family ipv4 (router-id 1.1.1.1)
Router Link States (Area 0)
ADV Router Age Seq# Fragment ID Link count Bits
1.1.1.1 54 0x80000009 0 2 None
2.2.2.2 340 0x80000007 0 1 None
3.3.3.3 55 0x80000004 0 1 None
Net Link States (Area 0)
ADV Router Age Seq# Link ID Rtr count
2.2.2.2 1049 0x80000001 2 2
3.3.3.3 55 0x80000001 4 2
Link (Type-8) Link States (Area 0)
ADV Router Age Seq# Link ID Interface
1.1.1.1 842 0x80000001 4 Se1/0
3.3.3.3 834 0x80000001 4 Se1/0
1.1.1.1 1703 0x80000002 2 Fa0/0
2.2.2.2 1730 0x80000001 2 Fa0/0
Intra Area Prefix Link States (Area 0)
ADV Router Age Seq# Link ID Ref-lstype Ref-LSID
2.2.2.2 1049 0x80000001 2048 0x2002 2
3.3.3.3 55 0x80000001 4096 0x2002 4
R1#
The show ospfv3 database prefix self-originate command confirms that there is not Intra-Area Prefix LSA 9:
R1#show ospfv3 database prefix self-originate
OSPFv3 1 address-family ipv4 (router-id 1.1.1.1)
R1#
The show ospfv3 database prefix displayed the contents of the LSAs Type 9 created by the DRs R2 and R3, each with a unique link-state ID: 2048 and 4096 respectively and they carry the subnet and subnet mask 12.0.0.0/24 & 13.0.0.0/24 respectively.
Referenced LSA Type: 2002 in both LSA Type 9 describes its association with the LSA Type 2.
Referenced Link State ID: 2 and Referenced Link State ID: 4 respectively for each intra-area prefix LSA describes its association to the network LSA.
The Referenced Link State ID: 2 is the Link State ID of LSA Type 2's R2.
The Referenced Link State ID: 4 is the Link State ID of LSA Type 2's R3.
R1#show ospfv3 database prefix
OSPFv3 1 address-family ipv4 (router-id 1.1.1.1)
Intra Area Prefix Link States (Area 0)
Routing Bit Set on this LSA
LS age: 1137
LS Type: Intra-Area-Prefix-LSA
Link State ID: 2048
Advertising Router: 2.2.2.2
LS Seq Number: 80000001
Checksum: 0x4E7D
Length: 40
Referenced LSA Type: 2002
Referenced Link State ID: 2
Referenced Advertising Router: 2.2.2.2
Number of Prefixes: 1
Prefix Address: 12.0.0.0
Prefix Length: 24, Options: None, Metric: 0
Routing Bit Set on this LSA
LS age: 143
LS Type: Intra-Area-Prefix-LSA
Link State ID: 4096
Advertising Router: 3.3.3.3
LS Seq Number: 80000001
Checksum: 0x3187
Length: 40
Referenced LSA Type: 2002
Referenced Link State ID: 4
Referenced Advertising Router: 3.3.3.3
Number of Prefixes: 1
Prefix Address: 13.0.0.0
Prefix Length: 24, Options: None, Metric: 0
R1#
Let's verify the LSAs Type 2 generated by the DRs R2 and R3:
-The LSA Type 2 of R2 has Link State ID: 2 which matches the Referenced Link State ID: 2 of its LSA Type 9.
-The LSA Type 2 of R3 has Link State ID: 4 which matches the Referenced Link State ID: 4 of its LSA Type 9.
R1#show ospfv3 database network
OSPFv3 1 address-family ipv4 (router-id 1.1.1.1)
Net Link States (Area 0)
LS age: 1255
Options: (E-Bit, R-bit, DC-Bit, AF-Bit)
LS Type: Network Links
Link State ID: 2 (Interface ID of Designated Router)
Advertising Router: 2.2.2.2
LS Seq Number: 80000001
Checksum: 0x16DC
Length: 32
Attached Router: 2.2.2.2
Attached Router: 1.1.1.1
LS age: 261
Options: (E-Bit, R-bit, DC-Bit, AF-Bit)
LS Type: Network Links
Link State ID: 4 (Interface ID of Designated Router)
Advertising Router: 3.3.3.3
LS Seq Number: 80000001
Checksum: 0x6E2
Length: 32
Attached Router: 3.3.3.3
Attached Router: 1.1.1.1
R1#
You must be a registered user to add a comment. If you've already registered, sign in. Otherwise, register and sign in.
Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: