cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1096
Views
0
Helpful
0
Comments
Meddane
VIP
VIP

WLC.png

 

Basic configuration of all routers:

 

R1:

interface Loopback0

 ip address 172.16.1.1 255.255.255.0

!

interface Serial1/0

 ip address 10.0.13.5 255.255.255.252

 no shutd

!

interface Serial1/1

 ip address 10.0.12.1 255.255.255.252

 no shutd

 

R2:

interface Loopback0

 ip address 172.16.2.2 255.255.255.0

!

interface Serial1/0

 ip address 10.0.23.9 255.255.255.252

 no shutd

!

interface Serial1/1

 ip address 10.0.12.2 255.255.255.252

 no shutd

 

R3:

interface Loopback0

 ip address 172.16.3.3 255.255.255.0

!

interface Serial1/0

 ip address 10.0.13.6 255.255.255.252

 no shutd

!

interface Serial1/1

 ip address 10.0.23.10 255.255.255.252

 no shutd

!

interface Serial1/2

 ip address 10.0.34.13 255.255.255.252

 no shutd

 

R4:

interface Loopback0

 ip address 172.16.4.4 255.255.255.0

!

interface Serial1/1

 ip address 10.0.34.14 255.255.255.252

 no shutd

 

 R1 will peer with R2 and R3. R2 will peer with R1 and R3. R3 will peer with R1, R2 and R4. R4 will peer only with R3. The routers should all use their physical interface addresses for BGP peering.

 

R1

router bgp 1

 bgp router-id 1.1.1.1

 neighbor 10.0.12.2 remote-as 2

 neighbor 10.0.13.6 remote-as 3

 

R2

router bgp 2

 bgp router-id 2.2.2.2

 neighbor 10.0.12.1 remote-as 1

 neighbor 10.0.23.10 remote-as 3

 

R3

router bgp 3

 bgp router-id 3.3.3.3

 no neighbor 10.0.13.5 remote-as 5

 neighbor 10.0.23.9 remote-as 2

 neighbor 10.0.34.14 remote-as 4

 

R4

router bgp 4

 bgp router-id 4.4.4.4  

 neighbor 10.0.34.13 remote-as 3

 

Check the status of all BGP connections with the do show ip bgp summary command:

 

R1(config-router)#do show ip bgp summary

BGP router identifier 1.1.1.1, local AS number 1

BGP table version is 1, main routing table version 1

 

Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd

10.0.12.2       4            2       5       5        1    0    0 00:02:14        0

10.0.13.6       4            3       2       2        1    0    0 00:00:21        0

 

R2(config-router)#do show ip bgp summary

BGP router identifier 2.2.2.2, local AS number 2

BGP table version is 1, main routing table version 1

 

Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd

10.0.12.1       4            1       5       5        1    0    0 00:02:16        0

10.0.23.10      4            3       5       5        1    0    0 00:02:13        0

 

R3(config-router)#do show ip bgp summary

BGP router identifier 3.3.3.3, local AS number 3

BGP table version is 1, main routing table version 1

 

Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd

10.0.13.5       4            1       3       3        1    0    0 00:01:18        0

10.0.23.9       4            2       6       6        1    0    0 00:03:07        0

10.0.34.14      4            4       2       2        1    0    0 00:00:10        0

R3(config-router)#

 

R4(config-if)#do show ip bgp summary

BGP router identifier 4.4.4.4, local AS number 4

BGP table version is 1, main routing table version 1

 

Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd

10.0.34.13      4            3       2       2        1    0    0 00:00:13        0

R4(config-if)#

 

Advertise the 172.16.x.0/24 LAN subnets on all routers via BGP. These should be injected using the network command on all routers. Verify that all routers' LAN subnets can ping every other routers LAN subnet.

 

R1

router bgp 1

 network 172.16.1.0 mask 255.255.255.0

 

R2

router bgp 2

 network 172.16.2.0 mask 255.255.255.0

 

R3

router bgp 3

 network 172.16.3.0 mask 255.255.255.0

 

R4

router bgp 4

 network 172.16.4.0 mask 255.255.255.0

 

Verify that all routers have the 172.16.x.0/24 subnets in their BGP Tables:

 

R1(config)#do show ip bgp

BGP table version is 5, local router ID is 1.1.1.1

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,

              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,

              x best-external, a additional-path, c RIB-compressed,

Origin codes: i - IGP, e - EGP, ? - incomplete

RPKI validation codes: V valid, I invalid, N Not found

 

     Network          Next Hop            Metric LocPrf Weight Path

 *>  172.16.1.0/24    0.0.0.0                  0         32768 i

 *   172.16.2.0/24    10.0.13.6                              0 3 2 i

 *>                   10.0.12.2                0             0 2 i

 *   172.16.3.0/24    10.0.12.2                              0 2 3 i

 *>                   10.0.13.6                0             0 3 i

 *   172.16.4.0/24    10.0.12.2                              0 2 3 4 i

 *>                   10.0.13.6                              0 3 4 i

 

R2(config)#do show ip bgp

BGP table version is 5, local router ID is 2.2.2.2

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,

              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,

              x best-external, a additional-path, c RIB-compressed,

Origin codes: i - IGP, e - EGP, ? - incomplete

RPKI validation codes: V valid, I invalid, N Not found

 

     Network          Next Hop            Metric LocPrf Weight Path

 *   172.16.1.0/24    10.0.23.10                             0 3 1 i

 *>                   10.0.12.1                0             0 1 i

 *>  172.16.2.0/24    0.0.0.0                  0         32768 i

 *   172.16.3.0/24    10.0.12.1                              0 1 3 i

 *>                   10.0.23.10               0             0 3 i

 *   172.16.4.0/24    10.0.12.1                              0 1 3 4 i

 *>                   10.0.23.10                             0 3 4 i

 

R3(config-router)#do show ip bgp

BGP table version is 5, local router ID is 3.3.3.3

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,

              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,

              x best-external, a additional-path, c RIB-compressed,

Origin codes: i - IGP, e - EGP, ? - incomplete

RPKI validation codes: V valid, I invalid, N Not found

 

     Network          Next Hop            Metric LocPrf Weight Path

 *   172.16.1.0/24    10.0.23.9                              0 2 1 i

 *>                   10.0.13.5                0             0 1 i

 *   172.16.2.0/24    10.0.13.5                              0 1 2 i

 *>                   10.0.23.9                0             0 2 i

 *>  172.16.3.0/24    0.0.0.0                  0         32768 i

 *>  172.16.4.0/24    10.0.34.14               0             0 4 i

 

R4(config-router)#do show ip bgp

BGP table version is 5, local router ID is 4.4.4.4

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,

              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,

              x best-external, a additional-path, c RIB-compressed,

Origin codes: i - IGP, e - EGP, ? - incomplete

RPKI validation codes: V valid, I invalid, N Not found

 

     Network          Next Hop            Metric LocPrf Weight Path

 *>  172.16.1.0/24    10.0.34.13                             0 3 1 i

 *>  172.16.2.0/24    10.0.34.13                             0 3 2 i

 *>  172.16.3.0/24    10.0.34.13               0             0 3 i

 *>  172.16.4.0/24    0.0.0.0                  0         32768 i

 

Finally, verify that each router can ping every other routers' LAN interface from its own:

 

R1#ping 172.16.2.2 source loopback0

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 172.16.2.2, timeout is 2 seconds:

Packet sent with a source address of 172.16.1.1

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 8/97/236 ms

R1#

 

R1#ping 172.16.3.3 source loopback0

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 172.16.3.3, timeout is 2 seconds:

Packet sent with a source address of 172.16.1.1

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 8/84/128 ms

R1#

 

R1#ping 172.16.4.4 source loopback0

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 172.16.4.4, timeout is 2 seconds:

Packet sent with a source address of 172.16.1.1

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 68/103/140 ms

R1#

 

R2#ping 172.16.1.1 source loopback0

*Mar 26 01:37:51.095: %SYS-5-CONFIG_I: Configured from console by console

R2#ping 172.16.1.1 source loopback0

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:

Packet sent with a source address of 172.16.2.2

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 36/102/144 ms

R2#

 

R2#ping 172.16.3.3 source loopback0

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 172.16.3.3, timeout is 2 seconds:

Packet sent with a source address of 172.16.2.2

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 104/121/152 ms

R2#

 

R2#ping 172.16.4.4 source loopback0

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 172.16.4.4, timeout is 2 seconds:

Packet sent with a source address of 172.16.2.2

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 120/140/148 ms

R2#

 

R3#ping 172.16.1.1 source loopback0

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:

Packet sent with a source address of 172.16.3.3

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 28/37/48 ms

R3#

 

R3#ping 172.16.2.2 source loopback0

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 172.16.2.2, timeout is 2 seconds:

Packet sent with a source address of 172.16.3.3

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 28/34/40 ms

R3#

 

R3#ping 172.16.4.4 source loopback0

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 172.16.4.4, timeout is 2 seconds:

Packet sent with a source address of 172.16.3.3

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 96/106/120 ms

R3#

 

R4#ping 172.16.1.1 source loopback0

*Mar 26 01:39:50.211: %SYS-5-CONFIG_I: Configured from console by console

R4#ping 172.16.1.1 source loopback0

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:

Packet sent with a source address of 172.16.4.4

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 116/129/152 ms

R4#

 

R4#ping 172.16.2.2 source loopback0

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 172.16.2.2, timeout is 2 seconds:

Packet sent with a source address of 172.16.4.4

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 88/124/140 ms

R4#

 

R4#ping 172.16.3.3 source loopback0

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 172.16.3.3, timeout is 2 seconds:

Packet sent with a source address of 172.16.4.4

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 80/104/128 ms

R4#

 

Configure R1 with the following Loopback interfaces:

 

Loopback 1: IP Address 192.0.0.1/32

Loopback 0: IP Address 192.0.1.1/32

 

R1

interface loopback 1

ip add 192.0.0.1 255.255.255.255

 

interface loopback 2

ip add 192.0.1.1 255.255.255.255

 

These prefixes should be advertised only to R2.  Next, configure R2 to advertise a single route for these prefixes to R3. Ensure that this aggregate route ONLY appears in the BGP Table of R4 but not in the BGP Table of R1. Follow the restrictions below:

 

You can NOT use an outbound route map on R1

You can NOT use any outbound filters or route maps on R2 or R3

You can NOT use any inbound filters or route maps on R1 or R3

You can NOT modify administrative distance values

 

To do the first part of the requirement, create a prefix-list named FILTER which matches the two prefixes with a deny action and a third sequence to allow other prefixes, then under router bgp we tell to R1 to apply this prefix-list toward the neighbor 10.0.13.6 which is R3:

 

ip prefix-list FILTER seq 1 deny 192.0.0.1/32

ip prefix-list FILTER seq 2 deny 192.0.1.1/32

ip prefix-list FILTER seq 3 permit 0.0.0.0/0 le 32

!

router bgp 1

network 192.0.0.1 mask 255.255.255.255

network 192.0.1.1 mask 255.255.255.255

neighbor 10.0.13.6 prefix-list FILTER out

 

The show ip bgp neighbors 10.0.12.2 advertised-routes command displays which prefixes or routes are being advertised to R2, notice the presence of the two prefixes 192.0.0.1/32 and 192.0.1.1/32:

 

R1(config)#do show ip bgp neighbors 10.0.12.2 advertised-routes

BGP table version is 7, local router ID is 1.1.1.1

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,

              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,

              x best-external, a additional-path, c RIB-compressed,

Origin codes: i - IGP, e - EGP, ? - incomplete

RPKI validation codes: V valid, I invalid, N Not found

 

     Network          Next Hop            Metric LocPrf Weight Path

 *>  172.16.1.0/24    0.0.0.0                  0         32768 i

 *>  172.16.3.0/24    10.0.13.6                0             0 3 i

 *>  172.16.4.0/24    10.0.13.6                              0 3 4 i

 *>  192.0.0.1/32     0.0.0.0                  0         32768 i

 *>  192.0.1.1/32     0.0.0.0                  0         32768 i

 

Total number of prefixes 5

 

The show ip bgp neighbors 10.0.13.6 advertised-routes command displays which prefixes or routes are being advertised to R3, notice now the absence of the two prefixes 192.0.0.1/32 and 192.0.1.1/32 because the filtering configured on R1:

 

R1(config)#do show ip bgp neighbors 10.0.13.6 advertised-routes

BGP table version is 7, local router ID is 1.1.1.1

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,

              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,

              x best-external, a additional-path, c RIB-compressed,

Origin codes: i - IGP, e - EGP, ? - incomplete

RPKI validation codes: V valid, I invalid, N Not found

 

     Network          Next Hop            Metric LocPrf Weight Path

 *>  172.16.1.0/24    0.0.0.0                  0         32768 i

 *>  172.16.2.0/24    10.0.12.2                0             0 2 i

 

Total number of prefixes 2

 

The second part requires that you summarize these prefixes and ensure that they are NOT advertised back to R1 by R3. Given the restrictions. When summarizing with BGP, if you use the aggregate-address command, the router that performs the aggregation removes, by default, any other AS_PATH information (AS_SET). The summarized route is therefore originated from the AS of the router that generated the summary. This means that if the routes that are summarized were received from another AS, as is our case, the aggregate can be re-advertised back to that AS, causing some issues (such as routing loop. For example, assume the following command was issued on R2:

 

On R2 we will use the aggregate-address command in order to advertise a single route for the prefixes 192.0.0.1/32 and 192.0.1.1/32 to R3.

Keep in mind that when summarizing with BGP, if we use the aggregate-address command, the router (R2 in our case) that performs the aggregation, by default it removes any other AS_PATH information (AS_SET). The summarized route is thus originated from the AS of the router that generated the summary (R2) not the router that generates the routes of the specific subnets (R1). This means that if the routes that are summarized were received from another AS, like with our case the aggregate can be re-advertised back to that AS (AS 1), causing some issues suche loop problems.

 

We can verify when summarizing on R2 as follow:

 

R2

router bgp 2

 aggregate-address 192.0.0.0 255.255.254.0 summary-only

 

From the BGP table of R3, R2 suppresses the specific 192.0.0.1/32 and 192.0.1.1/32 prefixes and advertises only a single route to R3. This route appears on R3 as follows:

Notice that the AS_PATH shows that this aggregate route is originated from AS 2, in other word the AS 1 is not listed in the BGP table of R3 for the summary route:

 

R3#show ip bgp 192.0.0.0 255.255.254.0

BGP routing table entry for 192.0.0.0/23, version 50

Paths: (1 available, best #1, table default)

Flag: 0x820

  Not advertised to any peer

  Refresh Epoch 1

  2, (aggregated by 2 2.2.2.2)

    10.0.23.9 from 10.0.23.9 (2.2.2.2)

      Origin IGP, metric 0, localpref 100, valid, external, atomic-aggregate, best

      rx pathid: 0, tx pathid: 0x0

 

Notice that the AS_PATH shows that this aggregate originates in AS 2, even though it is based on prefixes originated in AS 1. Given this, R1 will accept this same prefix from both R2 an R3:

 

R1(config)#do show ip bgp 192.0.0.0 255.255.254.0

BGP routing table entry for 192.0.0.0/23, version 14

Paths: (2 available, best #2, table default)

  Advertised to update-groups:

     6

  Refresh Epoch 2

  3 2, (aggregated by 2 2.2.2.2)

    10.0.13.6 from 10.0.13.6 (3.3.3.3)

      Origin IGP, localpref 100, valid, external, atomic-aggregate

      rx pathid: 0, tx pathid: 0

  Refresh Epoch 1

  2, (aggregated by 2 2.2.2.2)

    10.0.12.2 from 10.0.12.2 (2.2.2.2)

      Origin IGP, metric 0, localpref 100, valid, external, atomic-aggregate, best

      rx pathid: 0, tx pathid: 0x0

 

To avoid this issue, add the keyword as-set to the aggregate-address command. It includes all AS of the specific prefixes from which the aggregate is generated. This prevents the aggregate from being advertised back to this AS 1, in other word the routers receiving this UPDATE will see their own AS_PATH in the update and drop it, according to the BGP loop prevention mechanism rule:

 

R2

router bgp 2     

aggregate-add 192.0.0.0 255.255.254.0 summary-only as-set

 

Following this change, the aggregate now reflects an origin of AS 1 when seen on R3:

 

R3#show ip bgp 192.0.0.0 255.255.254.0

BGP routing table entry for 192.0.0.0/23, version 55

Paths: (1 available, best #1, table default)

  Advertised to update-groups:

     1

  Refresh Epoch 1

  2 1, (aggregated by 2 2.2.2.2)

    10.0.23.9 from 10.0.23.9 (2.2.2.2)

      Origin IGP, metric 0, localpref 100, valid, external, best

      rx pathid: 0, tx pathid: 0x0

 

Because R1 sees its own AS_PATH in the list, it does NOT accept the aggregate:

 

R1(config)#do show ip bgp 192.0.0.0 255.255.254.0

% Network not in table

R1(config)#

 

R1, R2 and R3 can ping the 192.0.0.1/32 and 192.0.1.1/32 prefixes from the loopback interfaces as a sources:

 

R2#ping 192.0.0.1 source lo0

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.0.0.1, timeout is 2 seconds:

Packet sent with a source address of 172.16.2.2

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 28/40/52 ms

R2#ping 192.0.1.1 source lo0

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.0.1.1, timeout is 2 seconds:

Packet sent with a source address of 172.16.2.2

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 28/37/48 ms

 

R3#ping 192.0.0.1 source lo0

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.0.0.1, timeout is 2 seconds:

Packet sent with a source address of 172.16.3.3

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 68/113/128 ms

R3#ping 192.0.1.1 source lo0

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.0.1.1, timeout is 2 seconds:

Packet sent with a source address of 172.16.3.3

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 76/105/148 ms

 

R4#ping 192.0.0.1 source lo0

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.0.0.1, timeout is 2 seconds:

Packet sent with a source address of 172.16.4.4

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 96/132/152 ms

R4#ping 192.0.1.1 source lo0

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.0.1.1, timeout is 2 seconds:

Packet sent with a source address of 172.16.4.4

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 116/129/140 ms

R4#

 

Configure R2 and R4 with a Loopback 20 interface with the IP address 192.168.0.2/32. Next, redistribute this prefix into BGP on R2 and R4 and configure BGP path control so that R1 prefers the prefix originated by R4 over the prefix originated by R1. However, follow the restrictions below:

 

You can NOT modify the AS_PATH length for this prefix on ANY router

You can NOT modify default administrative distance values

You can NOT modify the WEIGHT or LOCAL_PREF attributes on R1

You can only issue ONE single command on R1, i.e. one line of code

You MUST use route maps when redistributing this interface on R2 and R4

 

R2

interface loopback 20

ip address 192.168.0.2 255.255.255.255

 

R4

interface loopback 20

ip address 192.168.0.2 255.255.255.255

 

If you have read the BGP path selection process. Because we cannot use WEIGHT or LOCAL_PREF, those two attributes are ruled out. Because both prefixes are not originated on the local router, we can skip this step of the path selection process.

The next attribute to consider then would be the AS_PATH length. However, the restriction says that we cannot MODIFY the AS_PATH length. However, if the bgp bestpath as-path ignore command is issued on the router, the AS_PATH attribute is not used in BGP best path selection. Also, when comparing this attribute, an AS_SET is counted once, regardless of the number of autonomous systems in the set. And, finally, the AS_CONFED_SEQUENCE is not included in the AS_PATH length.

 

Therefore, we can configure R1 to IGNORE the AS_PATH attribute in best path selection and look at the next attribute in the best path selection process, which is ORIGIN, we can influence the path selection by configuring R1 to ignore the AS_PATH attribute in the path selection process and advertising the prefix from R4 with a better ORIGIN code than that on R2.

 

R1

router bgp 1

 bgp bestpath as-path ignore

 

Complete your configuration on routers R2 and R4 as follows:

 

R2

route-map LOOPBACK permit 10

 match interface loopback 20

 

router bgp 2

redistribute connected route-map LOOPBACK

 

R4

router bgp 2

redistribute connected route-map LOOPBACK

 

route-map LOOPBACK permit 10

 match interface loopback 20

 set origin igp

 

router bgp 4

redistribute connected route-map LOOPBACK

 

Because the AS_PATH attribute is ignored in best path selection on R1, it is omitted in the path selection process and the next valid attribute, ORIGIN, is used instead. Given that an ORIGIN of IGP > EGP > Incomplete, the path from R4 wins and is used instead. The same logic is also applicable to R3, which prefers this same path because of the ORIGIN:

 

R1(config)#do show ip bgp 192.168.0.2 255.255.255.255

BGP routing table entry for 192.168.0.2/32, version 27

Paths: (2 available, best #1, table default)

  Advertised to update-groups:

     8

  Refresh Epoch 2

  3 4

    10.0.13.6 from 10.0.13.6 (3.3.3.3)

      Origin IGP, localpref 100, valid, external, best

      rx pathid: 0, tx pathid: 0x0

  Refresh Epoch 1

  2

    10.0.12.2 from 10.0.12.2 (2.2.2.2)

      Origin incomplete, metric 0, localpref 100, valid, external

      rx pathid: 0, tx pathid: 0

 

R3(config)#do show ip bgp 192.168.0.2 255.255.255.255

BGP routing table entry for 192.168.0.2/32, version 58

Paths: (2 available, best #1, table default)

  Advertised to update-groups:

     1

  Refresh Epoch 1

  4

    10.0.34.14 from 10.0.34.14 (4.4.4.4)

      Origin IGP, metric 0, localpref 100, valid, external, best

      rx pathid: 0, tx pathid: 0x0

  Refresh Epoch 1

  2

    10.0.23.9 from 10.0.23.9 (2.2.2.2)

      Origin incomplete, metric 0, localpref 100, valid, external

      rx pathid: 0, tx pathid: 0

 

R1(config)#do ping 192.168.0.2 source 172.16.1.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.0.2, timeout is 2 seconds:

Packet sent with a source address of 172.16.1.1

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 100/119/144 ms

 

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: