
Basic configuration of all routers:
R1:
interface Loopback0
ip address 1.1.1.1 255.255.255.0
!
interface Serial1/1
ip address 10.0.12.1 255.255.255.0
no shutdown
!
router isis
net 49.0001.1111.1111.1111.00
R2:
interface Loopback0
ip address 2.2.2.2 255.255.255.0
!
interface Serial1/1
ip address 10.0.12.1 255.255.255.0
no shutdown
!
interface Serial1/0
ip address 10.0.23.2 255.255.255.0
no shutdown
!
router isis
net 49.0001.2222.2222.2222.00
R3:
interface Loopback0
ip address 3.3.3.3 255.255.255.0
!
interface Serial1/1
ip address 10.0.23.3 255.255.255.0
no shutdown
!
router isis
net 49.0002.3333.3333.3333.00
Let's verify ISI adjacencies:
By default all routers operates as a L1-L2 router
By default two routers L1-L2 in the same area negociate adjacencies for both L1 and L2 as denoted by the adjacency between R1 and R2
Two routers in different area negociate adjacencies for only L2 as shown by the adjacency between R2 and R3. By default R3 is an L1-L2 router, it shows up as
type L2 because of the inter-area connection between R3 and R2.
Unlike with fastethernet link and because serial interfaces do not have a MAC address, the encapsulation type HDLC is displayed instead for the serial link in the SNPA column.
R2#show clns neighbors
System Id Interface SNPA State Holdtime Type Protocol
R1 Se1/1 *HDLC* Up 21 L1L2 IS-IS
R3 Se1/0 *HDLC* Up 29 L2 IS-IS
R2#
By default, R3 is an L1-L2 router, so it retains a separate link-state database for each level as shown by the Link State Database of R3:
R1 and R2 are not listed in the IS-IS Level 1 link-state database, because both are a L1-L2 router.
R3#show isis database
IS-IS Level-1 Link State Database:
LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
R3.00-00 * 0x00000007 0xE33A 455 1/0/0
IS-IS Level-2 Link State Database:
LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
R1.00-00 0x00000006 0xFDBB 443 0/0/0
R2.00-00 0x00000005 0x38BD 448 0/0/0
R3.00-00 * 0x00000007 0x447E 1199 0/0/0
R3#
The same conclusion is valid for R1 as well as with R3:
R1#show isis database
IS-IS Level-1 Link State Database:
LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
R1.00-00 * 0x00000006 0xDB40 435 1/0/0
R2.00-00 0x00000006 0x0D4E 528 1/0/0
IS-IS Level-2 Link State Database:
LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
R1.00-00 * 0x00000007 0xFBBC 517 0/0/0
R2.00-00 0x00000006 0x36BE 563 0/0/0
R3.00-00 0x00000008 0xF642 918 0/0/0
R1#
Let's verify the routing tables:
Remember R1 is a L1-L2 router therefore it is receiving both Level 1 and Level 2 routes as shown by the following output:
Since the subnet 2.2.2.0/24 and 10.0.23.0/24 are advertised by R2 in the same area 1,they are installed as a L1 routes which represent the intra-area routes.
But the subnet 3.3.3.0/24 is learned by R2 from another area 2 therefore it is installed as a L2 route which represent the inter-area route.
R1#show ip route isis | beg Gate
Gateway of last resort is not set
2.0.0.0/24 is subnetted, 1 subnets
i L1 2.2.2.0 [115/20] via 10.0.12.2, 00:24:39, Serial1/1
3.0.0.0/24 is subnetted, 1 subnets
i L2 3.3.3.0 [115/30] via 10.0.12.2, 00:01:05, Serial1/1
10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
i L1 10.0.23.0/24 [115/20] via 10.0.12.2, 00:22:04, Serial1/1
R1#
Let's check the routing table of R3:
all routes are learned from another area 1 therefore they are installed as a L2 routes.
R3#show ip route isis | beg Gate
Gateway of last resort is not set
1.0.0.0/24 is subnetted, 1 subnets
i L2 1.1.1.0 [115/30] via 10.0.23.2, 00:29:35, Serial1/1
2.0.0.0/24 is subnetted, 1 subnets
i L2 2.2.2.0 [115/20] via 10.0.23.2, 00:29:35, Serial1/1
10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
i L2 10.0.12.0/24 [115/20] via 10.0.23.2, 00:29:35, Serial1/1
R3#
Now let's configure R2 to be an L1-L2 router.
Recall that R2 is already an L1-L2 router by default, in the case where it has been configured as a L1 or L2 router and we want to reconfigure it as L1-L2 router we should enter the no is-type command and this will set the router to its default level (L1-L2) or is-type level-1-2 command
And let's configure R1 to be a Level 1 only router:
R1:
router isis
is-type level-1
Let's verify the adjacency between R1 and R2:
Although R2 is a L1-L2 router, the adjacency is a L1 connection, because R1 is a L1 router therefore R2 negociate a L1 adjacencies only with R1.
R1#show clns neighbors
System Id Interface SNPA State Holdtime Type Protocol
R2 Se1/1 *HDLC* Up 25 L1 IS-IS
R1#
The presence of L1 and L2 link-state databases tells us that R2 is now an L1-L2 router.
R2#show clns interface s1/1
Serial1/1 is up, line protocol is up
Checksums enabled, MTU 1500, Encapsulation HDLC
ERPDUs enabled, min. interval 10 msec.
CLNS fast switching enabled
CLNS SSE switching disabled
DEC compatibility mode OFF for this interface
Next ESH/ISH in 19 seconds
Routing Protocol: IS-IS
Circuit Type: level-1-2
Interface number 0x0, local circuit ID 0x100
Neighbor System-ID: R1
Level-1 Metric: 10, Priority: 64, Circuit ID: R2.00
Level-1 IPv6 Metric: 10
Number of active level-1 adjacencies: 1
Level-2 Metric: 10, Priority: 64, Circuit ID: R2.00
Level-2 IPv6 Metric: 10
Number of active level-2 adjacencies: 0
Next IS-IS Hello in 937 milliseconds
if state UP
R2#
Let's verify the Link State Database of R1:
Only an L1 link-state database is maintained, confirming that R1 is now an L1-
only router.
R1#show isis database
IS-IS Level-1 Link State Database:
LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
R1.00-00 * 0x00000008 0x4443 1188 0/0/0
R2.00-00 0x00000007 0x0B4F 710 1/0/0
R1#
Let's check the Link State Database of R3:
Since R3 is a L1-L2 router, it maintains information for both levels L1 and L2:
R3#show isis database
IS-IS Level-1 Link State Database:
LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
R3.00-00 * 0x0000000B 0xEBA5 394 1/0/0
IS-IS Level-2 Link State Database:
LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
R2.00-00 0x0000000B 0xF6F5 556 0/0/0
R3.00-00 * 0x0000000A 0xF244 551 0/0/0
R3#
The show clns interface serial 1/1 command confirms that link-state databases for both L1 and L2 are maintained:
R3#show clns interface serial 1/1
Serial1/1 is up, line protocol is up
Checksums enabled, MTU 1500, Encapsulation HDLC
ERPDUs enabled, min. interval 10 msec.
CLNS fast switching enabled
CLNS SSE switching disabled
DEC compatibility mode OFF for this interface
Next ESH/ISH in 17 seconds
Routing Protocol: IS-IS
Circuit Type: level-1-2
Interface number 0x2, local circuit ID 0x102
Neighbor System-ID: R2
Level-1 Metric: 10, Priority: 64, Circuit ID: R3.02
Level-1 IPv6 Metric: 10
Number of active level-1 adjacencies: 0
Level-2 Metric: 10, Priority: 64, Circuit ID: R3.02
Level-2 IPv6 Metric: 10
Number of active level-2 adjacencies: 1
Next IS-IS Hello in 558 milliseconds
if state UP
R3#
In some case it is not necessary to maintain the link-state databases for both L1 and L2 therefore we can configure R3 to be a L2-only router.
R3:
router isis
is-type level-2-only
Let's verify using the show isis database and the show clns interface serial 1/1 commands on R3:
Both outputs tell us that R3 has only L2 information, confirming R3 is now an L2-only router.
R3#show isis database
IS-IS Level-2 Link State Database:
LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
R2.00-00 0x00000003 0x07ED 985 0/0/0
R3.00-00 * 0x00000002 0x033C 982 0/0/0
R3#
R3#show clns interface serial 1/1
Serial1/1 is up, line protocol is up
Checksums enabled, MTU 1500, Encapsulation HDLC
ERPDUs enabled, min. interval 10 msec.
CLNS fast switching enabled
CLNS SSE switching disabled
DEC compatibility mode OFF for this interface
Next ESH/ISH in 21 seconds
Routing Protocol: IS-IS
Circuit Type: level-1-2
Interface number 0x2, local circuit ID 0x102
Neighbor System-ID: R2
Level-2 Metric: 10, Priority: 64, Circuit ID: R3.02
Level-2 IPv6 Metric: 10
Number of active level-2 adjacencies: 1
Next IS-IS Hello in 6 seconds
if state UP
R3#
Let's verify the routing table of all routers:
R2 is an L1-L2 router and connects two different areas, it is similar to the ABR on OSPF therefore it is originating both L1 routes (intra-area) and L2 routes (inter-area), in this case R2 is receiving an intra-area route Level 1 to 1.1.1.0/2 from R1 and an inter-area route Level 2 to 3.3.3.0/24 from R3:
R2#show ip route isis | beg Gate
Gateway of last resort is not set
1.0.0.0/24 is subnetted, 1 subnets
i L1 1.1.1.0 [115/20] via 10.0.12.1, 00:17:50, Serial1/1
3.0.0.0/24 is subnetted, 1 subnets
i L2 3.3.3.0 [115/20] via 10.0.23.3, 00:17:44, Serial1/0
R2#
R3 is receiving two inter-area route Level 2 from R2 because they are learned from another area:
R3#show ip route isis | beg Gate
Gateway of last resort is not set
1.0.0.0/24 is subnetted, 1 subnets
i L2 1.1.1.0 [115/30] via 10.0.23.2, 00:22:23, Serial1/1
2.0.0.0/24 is subnetted, 1 subnets
i L2 2.2.2.0 [115/20] via 10.0.23.2, 00:22:23, Serial1/1
10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
i L2 10.0.12.0/24 [115/20] via 10.0.23.2, 00:22:23, Serial1/1
R3#
Since R1 was configured as an L1-only router, it no longer has any L2 routes.Note that the gateway of last resort has been set in the R1's routing table. L1-only routers, in this case R1, always learn a default route from a neighboring L1-L2router (R2 in this case). This is a standard operating procedure for
Integrated IS-IS. R1 learns to exit area 49.0001 via R2 because the attached bit (ATT) is set in the L1 LSP sent by R2.
R1#show ip route isis | beg Gate
Gateway of last resort is 10.0.12.2 to network 0.0.0.0
i*L1 0.0.0.0/0 [115/10] via 10.0.12.2, 00:16:37, Serial1/1
2.0.0.0/24 is subnetted, 1 subnets
i L1 2.2.2.0 [115/20] via 10.0.12.2, 00:16:37, Serial1/1
10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
i L1 10.0.23.0/24 [115/20] via 10.0.12.2, 00:16:37, Serial1/1
R1#
The attached bit indicates that R2 is also an L2 router and can reach other areas. It is similar to the B-bit set by the ABR on OSPF:
Notice the attached bit (ATT) equal to 1 in the L1 LSP advertised by R2:
R1#show isis database
IS-IS Level-1 Link State Database:
LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
R1.00-00 * 0x00000010 0xBD5E 828 0/0/0
R2.00-00 0x00000011 0xF659 853 1/0/0
R1#
Let's verify the connectivity:
R1#ping 2.2.2.2 source 1.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
Packet sent with a source address of 1.1.1.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 60/86/128 ms
R1#
R1#ping 3.3.3.3 source 1.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
Packet sent with a source address of 1.1.1.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 108/120/132 ms
R1#
Now if we want to ignore the attached bit and R1 should not install a default route ,we use the Ignore Attach Bit command on R1 which is a L1 router.
Configuring this statement allows R1 to ignore the attached bit on incoming Level 1 LSPs advertised by R2. If the attached bit is ignored, no default route, which points to R2 which has set the attached bit.
Notice that this command is hidden in IOS cisco.
R1(config)#router isis
R1(config-router)#ignore-attached-bit
Let's verify the routing table of R1:
You can see that R1 does not install the default route because it ignore the attached bit ATT set by R2.
R1#show ip route isis | begin Gate
Gateway of last resort is not set
2.0.0.0/24 is subnetted, 1 subnets
i L1 2.2.2.0 [115/20] via 10.0.12.2, 00:30:20, Serial1/1
10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
i L1 10.0.23.0/24 [115/20] via 10.0.12.2, 00:30:20, Serial1/1
R1#
You must be a registered user to add a comment. If you've already registered, sign in. Otherwise, register and sign in.
Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: