Showing results for 
Search instead for 
Did you mean: 

ESC: Correct Info not retrieved using ETSI REST APIs


Hi ESC Team

I have a setup with NSO(NFVO Bundle) -> ESC-> Openstack VIM

I have deployed VNF on VIM using VNFD,VNF-Info  from NSO Prime UI.

Now trying to use ETSI REST Calls to retrieve the details. HTTP/HTTPS request is responded with 200OK but the response is not having correct/right information.

I have checked in /var/log/esc/etsi-vnfm.log file. It shows "0" VNFs found for required query. But actually VM is there when checked from ESC UI. Also for any other ETSI REST calls too (like :, it shows 200 OK response. but without required details.

Pls see below:

2018-11-23 08:59:53.608 [http-nio-] INFO etsi_rest_event - SessionID:'84EB50CF8A6E36BC43147558852774F0' LocalAddr:'' LocalPort:'8250' RemoteAddr:'' RemotePort:'63567' RemoteUser:'admin' UserPrincipal:'admin' Scheme:'http' Method:'GET' RequestURI:'/vnflcm/v1/vnf_instances' Parameters:'[]'
2018-11-23 08:59:53.626 [http-nio-] INFO etsi_rest_event - IN GET VNF Instances [requestParameters: {}]
2018-11-23 08:59:53.629 [http-nio-] DEBUG etsi_rest_detailed_event - IN GET REQUEST VNF Instances [requestParameters: {}]
2018-11-23 08:59:53.630 [http-nio-] INFO c.c.e.e.s.v.VnfInstancesServiceImpl - Query VNF instances - started
2018-11-23 08:59:53.686 [http-nio-] INFO c.c.e.e.s.v.VnfInstancesServiceImpl - Query VNF instances (found 0 matching VNF instances) - finished
2018-11-23 08:59:53.754 [http-nio-] DEBUG etsi_rest_detailed_event - IN GET RESPONSE VNF Instances [requestParameters: {}]
2018-11-23 08:59:53.804 [http-nio-] INFO etsi_rest_event - SessionID:'84EB50CF8A6E36BC43147558852774F0' Status: '200'

18 Replies 18


Any update on this?

Pls get my query resolved. As i am struck due to this.

Seems like a bug in ESC code. 





If your need is urgent, I suggest raising a case through TAC. I don't know if any ESC experts are regularly reading this forum.


Best Regards,


Thanks  Vleijon

But I do not have TAC access. As not having any service contract.


Cisco Employee
Cisco Employee

Hi Satish, can you please confirm the build of ESC that you are using?


Hi Rakothar

I am using ESC-4_3_0_128 along with NSO 4.7 loaded with ncs-4.7.1-tailf-etsi-rel2-nfvo-project-3.5.0 bundle to work as complete MANO.



Cisco Employee
Cisco Employee

> I have deployed VNF on VIM using VNFD,VNF-Info from NSO Prime UI


If the ETSI VNFM did not initially provision the VNF then it won't be aware of it. You need to use the SOL003 Or-vnfm REST interface. Is this the interface you are using?


> I have checked in /var/log/esc/etsi-vnfm.log file. It shows "0" VNFs found for required query. But actually VM is there when checked from ESC UI.


If NSO provisions the VNF then yes it's in ESC, but it cannot be queried through ETSI VNFM as did not instantiate the VNF. 

Hummm. Let me Create a VM using ETSI SOL3 REST APIs and try to query that.

Will come back soon. 




I tried to use SOL003 Or-vnfm REST interface of ESC to create VNF Instance ID using "/vnflcm/v1/vnf_instances" from ESC swagger. To fulfill this request ESC is sending "GET http://NSO_IP:8080/vnfpkgm/v1/vnf_packages" to NSO (with NFVO bundle). But NSO is not honoring the request and sending 404 Not found. 


When i am sending  GET http://NSO_IP:8080/api/running/nfvo/vnf-info . This request is responded back by NSO with 200OK and required details.


I think NSO is not supporting "vnfpkgm/v1" APIs on 8080 port. Even NFVO bundle is already in place. So how to support "vnfpkgm/v1" REST APIs in NSO(with NFVO bundle) ?

Pls find attached pcap on nso 8080 port.

There are currently two methods of creating and deploying VNFs in ESC. One is using ESC's own SOL003 REST API, the other is using NSO. Subsequent operations and queries must use the same system that created the VNF. Therefore a VNF created by one system will not be visible to the other.

When i am using "using ESC's own SOL003 REST API", ESC sends SOL005 ETSI complaint REST messages to NSO. I can not control. NSO need to support. As of not my NSO(with NFVO bundle) is not supporting SOL005 APIs. Please let me know how SOLOO5 can be supported by my NSO installation. 




Being involved at the ESC end, I'm unable to provide NSO help.


Will u be able to connect me to connect with some one from NSO side?

Thanks in advance.



I am also from the ESC team but I work on a project with the NSO NFVO function pack team where integration with ESC using the ETSI API is currently in development. NSO-ESC ETSI integration is not yet supported. Development for ETSI SOL003 on the NSO side involves work on the NFVO function pack, a new ETSI SOL003 NED and a new OpenStack NED. The versions of ESC and NFVO function pack that will support ETSI SOL003 have not been released yet. The version of ESC for this will be the 4.4 release coming in December. I don't know the corresponding release timelines for NFVO function pack/SOL003 NED/OpenStack NED where official ETSI SOL003 support will be available but expect it will be next year.

Thanks for the detailed explanation. I tried to use it because online available attached doc " Cisco Elastic Services Controller 4.0 User Guide" says that SOL 003 ETSI APIs are supported. 

So as per this doc, SOL 003 is already supported in ESC 4.0.

But you are right that NSO-NFVO does' t support SOL 005 and SOL 003.

Thanks again for clarifications. Need to wait for next release.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the NSO Developer community: