cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

898
Views
0
Helpful
1
Replies
raiuli
Beginner

Getting operation failed in netconf for cisco 1941

Dear all, 

 

I have configured net conf in my Cisco1941 series and geting operation failed for  all the request i am sending through ssh

Here is the configuration

Current configuration : 1580 bytes

!

! Last configuration change at 08:56:09 UTC Wed Mar 13 2019

!

version 15.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

!

!

aaa new-model

aaa session-id common

memory-size iomem 5

!

!

!

!

!

!

!

!

!

!

!

!

!

!

ip cef

no ipv6 cef

!

multilink bundle-name authenticated

!         

cts logging verbose

!

!

license udi pid CISCO1941/K9 sn FGL152923AY

!

!

username cisco password 0 passw0rd

!

redundancy

!

!

!

!

!

ip ssh rsa keypair-name sshkeys

ip ssh version 2

!

!

!

!

!

!

interface Embedded-Service-Engine0/0

no ip address

shutdown

!

interface GigabitEthernet0/0

no ip address

shutdown

duplex auto

speed auto

!

interface GigabitEthernet0/1

ip address 192.168.0.1 255.255.255.0

duplex auto

speed auto

!

interface Serial0/0/0

no ip address

shutdown

clock rate 2000000

!         

interface Serial0/0/1

no ip address

shutdown

clock rate 2000000

!

interface Serial0/1/0

no ip address

shutdown

clock rate 2000000

!

interface Serial0/1/1

no ip address

shutdown

clock rate 2000000

!

ip forward-protocol nd

!

no ip http server

no ip http secure-server

!

!

!

!         

!

!

!

control-plane

!

!

!

line con 0

line aux 0

line 2

no activation-character

no exec

transport preferred none

transport output pad telnet rlogin lapb-ta mop udptn v120 ssh

stopbits 1

line vty 0 4

transport input ssh

!

scheduler allocate 20000 1000

netconf max-sessions 5

netconf lock-time 60

netconf max-message 2345

!

end

 

Following is the output of ssh communication with the cisco router

ssh -s cisco@192.168.0.1 netconf

Password:

<?xml version="1.0" encoding="UTF-8"?><hello><capabilities><capability>urn:ietf:params:netconf:base:1.0</capability><capability>urn:ietf:params:netconf:capability:writeable-running:1.0</capability><capability>urn:ietf:params:netconf:capability:startup:1.0</capability><capability>urn:ietf:params:netconf:capability:url:1.0</capability><capability>urn:cisco:params:netconf:capability:pi-data-model:1.0</capability><capability>urn:cisco:params:netconf:capability:notification:1.0</capability></capabilities><session-id>734691320</session-id></hello>]]>]]>

<?xml version=”1.0" encoding=”UTF-8"?><hello><capabilities><capability>urn:ietf:params:netconf:base:1.0</capability></capabilities></hello>]]>]]>

<?xml version="1.0"?>

<rpc message-id="101"  xmlns="urn:ietf:params:xml:ns:netconf:base:1.0">

       <get-config>

         <source>

           <running/>

         </source>

         </get-config>

     </rpc>]]>]]>

<?xml version="1.0" encoding="UTF-8"?><rpc-reply message-id="101" xmlns="urn:ietf:params:netconf:base:1.0"><rpc-error><error-type>protocol</error-type><error-tag>operation-failed</error-tag><error-severity>error</error-severity></rpc-error></rpc-reply>]]>]]>

!

!

aaa authorization exec default local

!

!

1 REPLY 1
joepak
Cisco Employee


Hi, can you enable device trace in raw format and recreate the issue and see what the .trace file says? The info provided is not enough to understand why the operation is failing. Preferably you could tail -f /var/log/ncs and see what logs are affected when you recreate the issue and share the errors.