cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

220
Views
5
Helpful
3
Replies
LoicChabert27318
Beginner

NSO - IOS-XE AAA yang model compiling end with silent error

Hi !

 

I'm currently using Cisco NSO product to develop Ipsec tunnels gateway. I have compile all mantadory yang models, extracted from netconf-ned-builder tool.

Unfortunatly, when i add AAA yang models, NED build process end with an error, but without any details. How can i get more details about the error ?

 

Please find more details below:

NSO version: 5.7.1

Netconf target: CSR1000v 17.3.3

Build error:

make all
/home/noc/nso/5.7.1/bin/ncsc --ncs-compile-bundle yang                   \
    --ncs-device-dir ncsc-out                        \
                                  \
                            \
                                \
    --ncs-device-type netconf                        \
                                         \
    --ncs-ned-id cisco-iosxe-nc-1.2:cisco-iosxe-nc-1.2                                   \

internal error
make: *** [Makefile:51: ncsc-out/.done] Error 1

I have tried to add more debug on makefile, but only the yanger command is displayed, without more details:

make all
/home/noc/nso/5.7.1/bin/ncsc --ncs-compile-bundle yang                   \
    --ncs-device-dir ncsc-out                        \
                                  \
                            \
                                \
    -v --ncs-device-type netconf                        \
                                         \
    --ncs-ned-id cisco-iosxe-nc-1.2:cisco-iosxe-nc-1.2                                   \

Ignoring NCS-internal module "ietf-inet-types@2013-07-15.yang"
Ignoring NCS-internal module "ietf-yang-types@2013-07-15.yang"
yanger -p /home/noc/nso/5.7.1/src/ncs/builtin_yang:yang --ncs-builtin-yang-dir /home/noc/nso/5.7.1/src/ncs/builtin_yang --no-deviation-apply -t ncs -f yang yang/Cisco-IOS-XE-aaa.yang --ncs-device-type netconf  --ncs-mount-id cisco-iosxe-nc-1.2:cisco-iosxe-nc-1.2  -o augmented/Cisco-IOS-XE-aaa@2021-03-01.yang
internal error
make: *** [Makefile:51: ncsc-out/.done] Error 1

The following modules is present on yang directory:

ls yang/
cisco-ia@2020-03-01.yang                           Cisco-IOS-XE-ipv6-oper@2019-05-01.yang
Cisco-IOS-XE-aaa-oper.yang                         Cisco-IOS-XE-isis@2020-07-01.yang
Cisco-IOS-XE-aaa-rpc@2019-07-01.yang               Cisco-IOS-XE-l2vpn@2020-07-02.yang
Cisco-IOS-XE-aaa-types.yang                        Cisco-IOS-XE-license@2020-07-01.yang
Cisco-IOS-XE-aaa.yang                              Cisco-IOS-XE-line@2019-11-01.yang
Cisco-IOS-XE-acl@2020-07-01.yang                   Cisco-IOS-XE-logging@2020-07-01.yang
Cisco-IOS-XE-acl-oper@2020-03-01.yang              Cisco-IOS-XE-mpls@2020-07-01.yang
Cisco-IOS-XE-arp-rpc@2019-07-01.yang               Cisco-IOS-XE-multicast-rpc@2020-07-01.yang
Cisco-IOS-XE-atm@2020-07-01.yang                   Cisco-IOS-XE-native@2020-07-02.yang
Cisco-IOS-XE-bgp@2020-07-02.yang                   Cisco-IOS-XE-nd@2020-07-01.yang
Cisco-IOS-XE-bgp-common-oper@2019-05-01.yang       Cisco-IOS-XE-nd-deviation@.yang
Cisco-IOS-XE-bgp-oper@2019-11-01.yang              Cisco-IOS-XE-ntp@2020-07-01.yang
Cisco-IOS-XE-bgp-route-oper@2019-05-01.yang        Cisco-IOS-XE-ntp-oper@2019-05-01.yang
Cisco-IOS-XE-bgp-rpc@2019-07-01.yang               Cisco-IOS-XE-object-group@2020-07-01.yang
Cisco-IOS-XE-cdp@2020-07-01.yang                   Cisco-IOS-XE-ospf-rpc@2019-07-01.yang
Cisco-IOS-XE-cdp-deviation@2019-07-23.yang         Cisco-IOS-XE-ospfv3@2020-07-01.yang
Cisco-IOS-XE-crypto@2020-07-02.yang                Cisco-IOS-XE-parser@2019-07-01.yang
Cisco-IOS-XE-crypto-oper@2020-07-01.yang           Cisco-IOS-XE-platform-rpc@2020-07-01.yang
Cisco-IOS-XE-crypto-rpc@2020-03-01.yang            Cisco-IOS-XE-policy@2020-07-03.yang
Cisco-IOS-XE-device-hardware-oper@2020-07-01.yang  Cisco-IOS-XE-policy-deviation@2020-07-01.yang
Cisco-IOS-XE-dhcp-rpc@2019-07-01.yang              Cisco-IOS-XE-pppoe@2020-07-01.yang
Cisco-IOS-XE-dialer@2020-07-01.yang                Cisco-IOS-XE-route-map@2020-07-01.yang
Cisco-IOS-XE-dialer-deviation@2020-07-01.yang      Cisco-IOS-XE-rpc@2020-07-02.yang
Cisco-IOS-XE-ethernet@2020-07-02.yang              Cisco-IOS-XE-sanet@2020-07-01.yang
Cisco-IOS-XE-ethernet-cfm-efp@2020-07-01.yang      Cisco-IOS-XE-sanet-deviation@2020-07-01.yang
Cisco-IOS-XE-ethernet-oam@2019-11-01.yang          Cisco-IOS-XE-snmp@2020-07-02.yang
Cisco-IOS-XE-event-history-types@2019-05-01.yang   Cisco-IOS-XE-tunnel@2020-03-01.yang
Cisco-IOS-XE-features@2020-07-01.yang              Cisco-IOS-XE-tunnel-oper@2020-07-01.yang
Cisco-IOS-XE-interface-common@2020-07-01.yang      Cisco-IOS-XE-tunnel-types@2019-05-01.yang
Cisco-IOS-XE-interfaces@2020-07-02.yang            Cisco-IOS-XE-types@2019-11-01.yang
Cisco-IOS-XE-interfaces-oper@2020-07-01.yang       cisco-self-mgmt@2019-07-01.yang
Cisco-IOS-XE-ios-common-oper@2020-03-01.yang       cisco-semver@2019-03-20.yang
Cisco-IOS-XE-ip@2020-07-01.yang                    ietf-inet-types@2013-07-15.yang
Cisco-IOS-XE-ipv6@2020-07-01.yang                  ietf-yang-types@2013-07-15.yang

Only the AAA model end with this error.

 

Any hints concerning this issue ?

 

Regards.

1 ACCEPTED SOLUTION

Accepted Solutions

To be more specific, it's works too on NSO 5.7.4.

As mentionned on 5.7.4, a new yanger version is used, and solve yang compilations issues.

 

After opening a case on BST, they recommends to use as minimal version 5.7.4. I think NSO team will not backport changes on other versions.

View solution in original post

3 REPLIES 3
Nabsch
Beginner

Hello,

 

I tried on NSO 5.7.2.1 . I got the same error but it compile on NSO 5.8.

 

 Can you try on NSO 5.8 ? 

 

One of the solution will be to use NSO 5.8 ..

 

 

 

Hi,

 

Indeed, it's works with 5.8. Maybe a yang compilation bug on 5.7.x ... I will open a case on BST and ask for a backport of code.

 

Regards.

To be more specific, it's works too on NSO 5.7.4.

As mentionned on 5.7.4, a new yanger version is used, and solve yang compilations issues.

 

After opening a case on BST, they recommends to use as minimal version 5.7.4. I think NSO team will not backport changes on other versions.