cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
746
Views
0
Helpful
11
Replies
Highlighted
Beginner

LMR integration 4321 versus 2811 (NIM / VIC2 - E&M Cards)

Hi,

 

We use the ISRs to get radio traffic through E&M ports with LMR out to the network via multicast (exactly the same config you would use in an IPICS deployment).

 

We have always used 28/29xx series up until now and they are being swapped for 43xx series now.  These routers do not wirk with the exact same config on them though.  The IOS XE originally shipped did not even support multicast dial-peers out of the box and I have since upgraded to the latest (including the fuji and denali trains) with no success.  The config is simple ::

 

Current configuration : 5010 bytes
!
! Last configuration change at 03:00:49 UTC Sat Aug 25 2018
!
version 16.9
service timestamps debug datetime msec
service timestamps log datetime msec
platform qfp utilization monitor load 80
no platform punt-keepalive disable-kernel-core
!
hostname radio
!
boot-start-marker
boot system flash bootflash:isr4300-universalk9.16.09.01.SPA.bin
boot-end-marker
!
!
vrf definition Mgmt-intf
 !
 address-family ipv4
 exit-address-family
 !
 address-family ipv6
 exit-address-family
!
!
no aaa new-model
!
!
!
!
!
!
!
no ip domain lookup
ip admission watch-list expiry-time 0
ip multicast auto-enable
!
!
!
!
!
!
!
!
!
!
subscriber templating
!         
!         
! 
! 
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
crypto pki trustpoint TP-self-signed-4033084560
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-4033084560
 revocation-check none
 rsakeypair TP-self-signed-4033084560
!
!
crypto pki certificate chain TP-self-signed-4033084560
 certificate self-signed 01
  30820330 30820218 A0030201 02020101 300D0609 2A864886 F70D0101 05050030 
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274 
  69666963 6174652D 34303333 30383435 3630301E 170D3138 30383235 30323333 
  34355A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649 
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D34 30333330 
  38343536 30308201 22300D06 092A8648 86F70D01 01010500 0382010F 00308201 
  0A028201 0100C075 A6CE729F E3993F81 703BF865 D6038E25 4DCB9706 E543F4B8 
  4AFD8092 E0702495 4461D86B 351425AB FA9EEF1D 5ED32780 520D9A89 70474BE2 
  096CDE3A 76E630C3 72842AE5 7D76AB08 2C1D169E BEB9D75E 793AE7B9 AF3FB6AA 
  DD90DBF9 2B98B241 2E23FD36 37E49552 85CD9DDB AA1C95F0 F149B0C2 6DDE7687 
  D70EB173 BF5219A5 54C8FB0C 7D9FCA69 905AE137 CEE814B9 F229941C E87B4CA6 
  B39F1C81 9779440E 4C357FA4 CF23FBC4 9D3B50F7 DC25A048 EF414C5D 113BA120 
  84F438E2 58515028 194E5AED 84D6A9DF 15A0E34E 46ACC7DB A2084009 67E0C3F6 
  EF0EDEC0 BBE319CA 375887F7 1AAA8B77 756EABF7 BA0F4D75 CB55A59A 850B6898 
  6C4AD582 EAC10203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 
  301F0603 551D2304 18301680 14B35D13 C1D43C72 DB0D9754 9FD44A65 7B7CF1D1 
  F7301D06 03551D0E 04160414 B35D13C1 D43C72DB 0D97549F D44A657B 7CF1D1F7 
  300D0609 2A864886 F70D0101 05050003 82010100 79BF5EFD 4B3FC4F2 A560BBED 
  40908729 B9989714 BBCC807B AED37622 62B2E517 FD6A3A1B 115DAD91 7708957D 
  B9735D47 6CDBD01E 170B6017 E7008D62 45623357 1335856E FEEE7C98 F279D81D 
  E91F7711 C5FBF66B B62F2701 E5317351 352E4F47 E5B6F8F8 A8FFC898 F2CA579D 
  21DBE89C 13B685C7 60238B13 A2A29BD5 1B4319B4 DF044D69 8124309D B91E9960 
  12A7A317 B53F60ED CAB9AF47 CA0CBAAA 586C7231 1286623F 7DEE2CED 956A76A4 
  71CFD8AD D64B060E F0D47171 A69DF87D C3BB9C1C A9512E8E 8B48D781 B4F800AB 
  2D6DFBA5 749B833D 81C7D1E4 2E3C1E8B C109B889 AD561EED CAD6E6D3 85188E5A 
  595ACE8A A6CAABB4 FA3DC418 4B7C2B96 1EB77072
  	quit
!
!         
!
voice class permanent 1
 signal timing idle suppress-voice 1
 signal timing oos timeout disabled
 signal keepalive disabled
 signal sequence oos no-action
!
!
!
!
!
!
!
!
voice-card 0/1
 no watchdog
!
voice-card 0/4
 no watchdog
!
license udi pid ISR4321/K9 sn FDO22040HEE
license boot suite FoundationSuiteK9
license boot suite AdvUCSuiteK9
no license smart enable
diagnostic bootup level minimal
!
spanning-tree extend system-id
!
!
!
!
redundancy
 mode none
!
!
!
!
!
!
!
! 
!
!
!
!
!
!
!
!         
!
!
! 
! 
!
!
interface GigabitEthernet0/0/0
 no ip address
 negotiation auto
!
interface GigabitEthernet0/0/1
 ip address 192.168.100.254 255.255.255.0
 ip pim sparse-dense-mode
 negotiation auto
!
interface Service-Engine0/1/0
!
interface Service-Engine0/4/0
!
interface GigabitEthernet0
 vrf forwarding Mgmt-intf
 no ip address
 negotiation auto
!
interface Vif1
 ip address 192.168.99.254 255.255.255.0
 ip pim sparse-dense-mode
!
ip default-gateway 192.168.100.1
ip forward-protocol nd
ip http server
ip http authentication local
ip http secure-server
ip http client source-interface GigabitEthernet0/0/1
ip tftp source-interface GigabitEthernet0/0/1
ip route 0.0.0.0 0.0.0.0 192.168.100.1
!
!
!
!
!
!
control-plane
!
!
voice-port 0/1/0
 voice-class permanent 1
 auto-cut-through
 operation 4-wire
 type 3
 signal lmr
 lmr e-lead voice
 no vad
 no comfort-noise
 timeouts call-disconnect 3
 timing hookflash-in 30
 connection trunk 3000
 threshold noise -30
!
voice-port 0/1/1
!
voice-port 0/1/2
!
voice-port 0/1/3
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
!
!
!
dial-peer voice 3000 voip
 destination-pattern 3000
 session protocol multicast
 session target ipv4:239.10.10.241:27124
 codec g711ulaw
 no vad
!
!
!
line con 0
 transport input none
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 privilege level 15
 password cisco
 login
 transport input telnet
line vty 5 15
 privilege level 15
 password cisco
 login    
 transport input telnet
!
!
!
!
!
!
end
 

radio#

 

I usually debug with "vpm signal" on the older models, but the debugs do not even look the same to me on this new one and I am not getting the usual things I would see on a 2800 when e-lead traffic is generated from the handheld.

 

Is there something I am missing on these new XE routers?  A switch that needs to be flipped somewhere?  These NIM-4E&M modules are the only ones I have, so I am unsure if other voice cards have this same issue.

 

Thanks,

 

Greg

Everyone's tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions
Beginner

Re: LMR integration 4321 versus 2811 (NIM / VIC2 - E&M Cards)

Sorry, I know it has been a while, but I did want to finalize this one out for the records and future searches.

 

The issue was that the NIM Service-Engine configurations *also* need PIM defined on them.  TAC fixed it fairly quickly, but I wanted to share it here as well.

 

-Greg

11 REPLIES 11
Cisco Employee

Re: LMR integration 4321 versus 2811 (NIM / VIC2 - E&M Cards)

Add PIM under the service-engine and then test.

Nipun Singh Raghav
"We cannot solve our problems with the same thinking we used when we created them"
Beginner

Re: LMR integration 4321 versus 2811 (NIM / VIC2 - E&M Cards)

Hi Nipun,

 

Thanks for the reply - unfortunately, it is still not working.  This raises a couple of questions though -

 

1.  if the NIM is now housing the DSPs (I read that each voice NIM has it's own DSPs), is the vif still required?

2.  I assumed the service-engine that has the same numbering as the NIM is the one to add PIM to - in this case 0/1/0, so service-engine 0/1

 

Did I get that correct?  I tried adding an IP to the Service-Engine and it would not take it, so I assumed I

had it right when it referenced the DSP module.  Current version / config is ::

 

Cisco IOS XE Software, Version 16.09.01
Cisco IOS Software [Fuji], ISR Software (X86_64_LINUX_IOSD-UNIVERSALK9-M), Version 16.9.1, RELEASE SOFTWARE (fc2)

 

 

!
! Last configuration change at 15:48:43 UTC Tue Aug 28 2018
!
version 16.9
service timestamps debug datetime msec
service timestamps log datetime msec
platform qfp utilization monitor load 80
no platform punt-keepalive disable-kernel-core
!
hostname radio
!
boot-start-marker
boot system flash bootflash:isr4300-universalk9.16.09.01.SPA.bin
boot-end-marker
!
!
vrf definition Mgmt-intf
!
address-family ipv4
exit-address-family
!
address-family ipv6
exit-address-family
!
!
no aaa new-model
!
!
!
!
!
!
!
no ip domain lookup
ip admission watch-list expiry-time 0
ip multicast auto-enable
!
!
!
!
!
!
!
!
!
!
subscriber templating
!
!
!
!
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
crypto pki trustpoint TP-self-signed-4033084560
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-4033084560
revocation-check none
rsakeypair TP-self-signed-4033084560
!
!
crypto pki certificate chain TP-self-signed-4033084560
certificate self-signed 01 nvram:IOS-Self-Sig#2.cer
!
!
!
voice class permanent 1
signal timing idle suppress-voice 1
signal timing oos timeout disabled
signal keepalive disabled
signal sequence oos no-action
!
!
!
!
!
!
!
!
voice-card 0/1
no watchdog
!
voice-card 0/4
no watchdog
!
license udi pid ISR4321/K9 sn FDO22040HEE
license boot suite FoundationSuiteK9
license boot suite AdvUCSuiteK9
no license smart enable
diagnostic bootup level minimal
!
spanning-tree extend system-id
!
!
!
!
redundancy
mode none
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface GigabitEthernet0/0/0
no ip address
negotiation auto
!
interface GigabitEthernet0/0/1
ip address 192.168.100.254 255.255.255.0
ip pim sparse-dense-mode
negotiation auto
!
interface Service-Engine0/1/0
no ip address
ip pim sparse-dense-mode
!
interface Service-Engine0/4/0
ip pim sparse-dense-mode
!
interface GigabitEthernet0
vrf forwarding Mgmt-intf
no ip address
negotiation auto
!
interface Vif1
ip address 192.168.99.254 255.255.255.0
ip pim sparse-dense-mode
!
ip default-gateway 192.168.100.1
ip forward-protocol nd
ip http server
ip http authentication local
ip http secure-server
ip http client source-interface GigabitEthernet0/0/1
ip tftp source-interface GigabitEthernet0/0/1
ip route 0.0.0.0 0.0.0.0 192.168.100.1
!
!
!
!
!
!
control-plane
!
!
voice-port 0/1/0
voice-class permanent 1
auto-cut-through
operation 4-wire
type 3
signal lmr
lmr e-lead voice
no vad
no comfort-noise
timeouts call-disconnect 3
timing hookflash-in 30
connection trunk 3000
threshold noise -30
!
voice-port 0/1/1
!
voice-port 0/1/2
!
voice-port 0/1/3
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
!
!
!
dial-peer voice 3000 voip
destination-pattern 3000
session protocol multicast
session target ipv4:239.10.10.241:27124
codec g711ulaw
no vad
!
!
!
line con 0
transport input none
stopbits 1
line aux 0
stopbits 1
line vty 0 4
privilege level 15
password cisco
login
transport input telnet
line vty 5 15
privilege level 15
password cisco
login
transport input telnet
!
!
!
!
!
!
end

 

Cisco Employee

Re: LMR integration 4321 versus 2811 (NIM / VIC2 - E&M Cards)

Your config is good and VIF is required as well as enabled for PIM which you already have. Can you confirm the router model and also if this ISR-4k is also acting as the multicast hub ?

Nipun Singh Raghav
"We cannot solve our problems with the same thinking we used when we created them"
Beginner

Re: LMR integration 4321 versus 2811 (NIM / VIC2 - E&M Cards)

Sorry, I should have also given some more info on my network setup.

 

I am using the 4321 as you can see from the config.  I also have a workstation on the same subnet as a reporter (192.168.100.113).

 

radio#sh ip igmp mem
Flags: A  - aggregate, T - tracked
       L  - Local, S - static, V - virtual, R - Reported through v3
       I - v3lite, U - Urd, M - SSM (S,G) channel
       1,2,3 - The version of IGMP, the group is in
Channel/Group-Flags:
       / - Filtering entry (Exclude mode (S,G), Include mode (G))
Reporter:
       <mac-or-ip-address> - last reporter if group is not explicitly tracked
       <n>/<m>      - <n> reporter in include mode, <m> reporter in exclude

 Channel/Group                  Reporter        Uptime   Exp.  Flags  Interface
 *,239.255.255.250              192.168.100.181 00:00:00 02:59 2A     Gi0/0/1
 *,239.255.3.22                 192.168.100.181 00:00:04 02:55 2A     Gi0/0/1
 *,239.10.10.241                192.168.100.113 00:00:02 02:57 2A     Gi0/0/1
 *,239.10.10.241                192.168.99.254  00:00:07 02:52 2VA    Vi1
 *,224.0.1.40                   192.168.99.254  00:01:24 02:40 2LA    Vi1

 

When we use the 2{8/9}00s, there is also the Cisco Hoot-N-Holler message broadcast on mcast port+1, so in this case port 27125 that broadcasts constantly.  Am I still missing something?

 

 

 

Beginner

Re: LMR integration 4321 versus 2811 (NIM / VIC2 - E&M Cards)

Oh, sorry - to answer your model question:

 

Cisco IOS XE Software, Version 16.03.07
Cisco IOS Software [Denali], ISR Software (X86_64_LINUX_IOSD-UNIVERSALK9-M), Version 16.3.7, RELEASE SOFTWARE (fc4)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2018 by Cisco Systems, Inc.
Compiled Sat 04-Aug-18 00:44 by mcpre


Cisco IOS-XE software, Copyright (c) 2005-2018 by cisco Systems, Inc.
All rights reserved.  Certain components of Cisco IOS-XE software are
licensed under the GNU General Public License ("GPL") Version 2.0.  The
software code licensed under GPL Version 2.0 is free software that comes
with ABSOLUTELY NO WARRANTY.  You can redistribute and/or modify such
GPL code under the terms of GPL Version 2.0.  For more details, see the
documentation or "License Notice" file accompanying the IOS-XE software,
or the applicable URL provided on the flyer accompanying the IOS-XE
software.


ROM: IOS-XE ROMMON

radio uptime is 7 minutes
Uptime for this control processor is 9 minutes
System returned to ROM by Reload Command
System image file is "bootflash:isr4300-universalk9.16.03.07.SPA.bin"
Last reload reason: Reload Command



This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to
export@cisco.com.



Suite License Information for Module:'esg'

--------------------------------------------------------------------------------
Suite                 Suite Current         Type           Suite Next reboot     
--------------------------------------------------------------------------------
FoundationSuiteK9     FoundationSuiteK9     Permanent      FoundationSuiteK9     
securityk9
appxk9

AdvUCSuiteK9          AdvUCSuiteK9          Permanent      AdvUCSuiteK9          
uck9
cme-srst
cube


Technology Package License Information:

-----------------------------------------------------------------
Technology    Technology-package           Technology-package
              Current       Type           Next reboot  
------------------------------------------------------------------
appxk9           None             None             appxk9
uck9             None             None             uck9
securityk9       None             None             securityk9
ipbase           ipbasek9         Permanent        ipbasek9

cisco ISR4321/K9 (1RU) processor with 3698780K/6147K bytes of memory.
Processor board ID FLM2211Y11B
2 Gigabit Ethernet interfaces
4 Voice E & M interfaces
32768K bytes of non-volatile configuration memory.
8388608K bytes of physical memory.
6598655K bytes of flash memory at bootflash:.
0K bytes of  at webui:.

Configuration register is 0x2102

Beginner

Re: LMR integration 4321 versus 2811 (NIM / VIC2 - E&M Cards)

Also - if it helps:

 

radio#sh inventory

+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
INFO: Please use "show license UDI" to get serial number for licensing.
+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

NAME: "Chassis", DESCR: "Cisco ISR4321 Chassis"
PID: ISR4321/K9        , VID: V04  , SN: FLM2211Y11B

NAME: "Power Supply Module 0", DESCR: "110W AC Power Supply for Cisco ISR 4320"
PID: PWR-4320-AC       , VID:      , SN:            

NAME: "Fan Tray", DESCR: "Cisco ISR4320 Fan Assembly"
PID: ACS-4320-FANASSY  , VID:      , SN:            

NAME: "module 0", DESCR: "Cisco ISR4321 Built-In NIM controller"
PID: ISR4321/K9        , VID:      , SN:            

NAME: "NIM subslot 0/1", DESCR: "NIM-4E/M Voice Analog Module"
PID: NIM-4E/M          , VID: V03  , SN: FOC2146408T

NAME: "PVDM subslot 0/4", DESCR: "PVDM4-32 Voice DSP Module"
PID: PVDM4-32          , VID: V02  , SN: FOC2206433B

NAME: "NIM subslot 0/0", DESCR: "Front Panel 2 ports Gigabitethernet Module"
PID: ISR4321-2x1GE     , VID: V01  , SN:            

NAME: "module R0", DESCR: "Cisco ISR4321 Route Processor"
PID: ISR4321/K9        , VID: V04  , SN: FDO22040HEE

NAME: "module F0", DESCR: "Cisco ISR4321 Forwarding Processor"
PID: ISR4321/K9        , VID:      , SN:            

Cisco Employee

Re: LMR integration 4321 versus 2811 (NIM / VIC2 - E&M Cards)

Can you do a code upgrade since I remember a defect on 16.3 release. Upgrade it to the latest and then test. Also ensure that this ISR is not a multicast hub. E&M and multicast hub are not supported if co-located.

Nipun Singh Raghav
"We cannot solve our problems with the same thinking we used when we created them"
Beginner

Re: LMR integration 4321 versus 2811 (NIM / VIC2 - E&M Cards)

radio# sh  ver

 

Cisco IOS XE Software, Version 16.09.01
Cisco IOS Software [Fuji], ISR Software (X86_64_LINUX_IOSD-UNIVERSALK9-M), Version 16.9.1, RELEASE SOFTWARE (fc2)

 

I have "debug ip multicast" enabled - you can see all of the regular mcast traffic on the network:

 

*Aug 31 16:08:11.316: IGMP(0): Received v2 Report on GigabitEthernet0/0/1 from 192.168.100.181 for 239.255.3.22
*Aug 31 16:08:11.316: IGMP(0): Received Group record for group 239.255.3.22, mode 2 from 192.168.100.181 for 0 sources
*Aug 31 16:08:11.316: IGMP(0): Updating EXCLUDE group timer for 239.255.3.22
*Aug 31 16:08:11.896: IGMP(0): Received v2 Report on GigabitEthernet0/0/1 from 192.168.100.181 for 239.255.255.250
*Aug 31 16:08:11.896: IGMP(0): Received Group record for group 239.255.255.250, mode 2 from 192.168.100.181 for 0 sources
*Aug 31 16:08:11.896: IGMP(0): Updating EXCLUDE group timer for 239.255.255.250
*Aug 31 16:08:13.056: IGMP(0): Received v2 Report on GigabitEthernet0/0/1 from 192.168.100.181 for 224.0.0.251
*Aug 31 16:08:13.056: IGMP(0): Report has illegal group address 224.0.0.251
*Aug 31 16:08:15.628: IGMP(0): Received v2 Report on GigabitEthernet0/0/1 from 192.168.100.162 for 224.0.0.1
*Aug 31 16:08:15.628: IGMP(0): Report has illegal group address 224.0.0.1
*Aug 31 16:08:54.737: IGMP(0): Send v2 general Query on Vif1
*Aug 31 16:08:54.737: IGMP(0): Set report delay time to 2.8 seconds for 224.0.1.40 on Vif1
*Aug 31 16:08:57.550: IGMP(0): Send v2 Report for 224.0.1.40 on Vif1
*Aug 31 16:08:57.550: IGMP(0): Received v2 Report on Vif1 from 192.168.99.254 for 224.0.1.40
*Aug 31 16:08:57.550: IGMP(0): Received Group record for group 224.0.1.40, mode 2 from 192.168.99.254 for 0 sources
*Aug 31 16:08:57.550: IGMP(0): Updating EXCLUDE group timer for 224.0.1.40
*Aug 31 16:09:08.462: IGMP(0): Send v2 general Query on GigabitEthernet0/0/1
*Aug 31 16:09:09.192: IGMP(0): Received v2 Report on GigabitEthernet0/0/1 from 192.168.100.1 for 224.0.0.251
*Aug 31 16:09:09.192: IGMP(0): Report has illegal group address 224.0.0.251
*Aug 31 16:09:12.572: IGMP(0): Received v2 Report on GigabitEthernet0/0/1 from 192.168.100.181 for 239.255.255.250
*Aug 31 16:09:12.572: IGMP(0): Received Group record for group 239.255.255.250, mode 2 from 192.168.100.181 for 0 sources
*Aug 31 16:09:12.572: IGMP(0): Updating EXCLUDE group timer for 239.255.255.250
*Aug 31 16:09:12.732: IGMP(0): Received v2 Report on GigabitEthernet0/0/1 from 192.168.100.162 for 224.0.0.1
*Aug 31 16:09:12.732: IGMP(0): Report has illegal group address 224.0.0.1
*Aug 31 16:09:15.752: IGMP(0): Received v2 Report on GigabitEthernet0/0/1 from 192.168.100.181 for 239.255.3.22
*Aug 31 16:09:15.752: IGMP(0): Received Group record for group 239.255.3.22, mode 2 from 192.168.100.181 for 0 sources
*Aug 31 16:09:15.752: IGMP(0): Updating EXCLUDE group timer for 239.255.3.22
*Aug 31 16:09:27.633: IGMP(0): Received Leave from 192.168.100.203 (GigabitEthernet0/0/1) for 224.0.0.251
*Aug 31 16:09:27.633: IGMP(0): Received v2 Report on GigabitEthernet0/0/1 from 192.168.100.203 for 224.0.0.251

 

but no traffic from the vif for the E&M ports.  I raeally am stuck.  We opened a TAC case for it -684918674

 

The customer thought it was PIM, but I believe it is card related or something...  Not sure where to go from here..?  We are only a development partner with Cisco, so I cannot open TAC cases.

 

-Greg

Beginner

Re: LMR integration 4321 versus 2811 (NIM / VIC2 - E&M Cards)

Sorry, I know it has been a while, but I did want to finalize this one out for the records and future searches.

 

The issue was that the NIM Service-Engine configurations *also* need PIM defined on them.  TAC fixed it fairly quickly, but I wanted to share it here as well.

 

-Greg

Beginner

Re: LMR integration 4321 versus 2811 (NIM / VIC2 - E&M Cards)

Hi,

 

Could you please confirm what additional configuration was required?

I can see from the config output on your 08-28-18 post that pim sparse-dense was added to interface Service-Engine0/1/0 and interface Service-Engine0/4/0, but the final post suggests something further was adde.

 

where else did you need to enable pim?

Any chance you could post the final working config?

 

Thanks,

Rhys

Beginner

Re: LMR integration 4321 versus 2811 (NIM / VIC2 - E&M Cards)

I no longer have access to that router, but here is the TAC recap.  The only thing that needed to be added was PIM on the Service-Engine port of the NIM..

 

On Wed, 2018-09-12 at 16:46 +0000, Kyzer Davis (kydavis) wrote:

Hello Greg,

 

Thanks for hopping on our call.

Find the detailed overview of the WebEx below in addition to every item we discussed on the call about the LMR hootie feature on IOS-XE.

As agreed let me know when you have finished testing!

 

Thanks,

 

### Problem Description

Customer is configuring LMR/Hootie Feature for ISR4000 for the first time to certify this deployment to sell to customers

 

### Platform Info

4321 - 16.9.1

 

### Call Flow

Radio > E&M (voice-port 0/1/0) > 4321 > Gig0/0/1 (192.168.100.254) > Multicast (239.10.10.24)

xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx> No audio

 

### Action Taken

Upgraded from 16.3.6 to 16.9.1 as 16.3 was the introduction of the Hootie feature on IOS-XE and 16.7+ have alot of fixes.

Added PIM to the service-engine interface which is the L3 internal interface for the DSP/PVDMs on the NIM Card.

Checked a PCM and can hear SIN traffic with audio so radio and cabling is good for voice port.

Checked the hootie feature with 'show platform hardware qfp active feature sbc hootie group' and I don't see any problems with replication or drops performed by the DSP as there are no drops observed.

Checked 'sh ip igmp member' commands and we see the local endpoint joined to the multicast network properly.

Checking the global drop counters of 'show platform hardware qfp active statistics drop' while I don't see the DSP incrementing failures but I do see the drops for Ipv4mcNoRoute (No IPv4 Multicast Route)

Noticed the VIF was .254 making the internal VIF+1 .255 which is broadcast. So we shut it down and changed to .253 so VIF+1 is .254 then shut/no shut the voice-port to restart the call. Drops still occurred.

'show ip mroute' shows no output so we enabled 'ip multicast-routing distributed' and now we see valid ViF and routes.

At this point testing worked as expected and the Ipv4mcNoRoute drops are gone after clearing 'show platform hardware qfp active statistics drop clear' and doing further testing.

I also used the test command 'test voice port 0/1/0 inject-tone network 1000' sent audio from the DSP towards the IP LAN / Multicast.

 

### IOS-XE Packet Drops

radio# sh platform hardware qfp active statistics drop

-------------------------------------------------------------------------

Global Drop Stats                         Packets                  Octets

-------------------------------------------------------------------------

FIAError                                      724                  144800

Ipv4mcNoRoute                                 728                  145272

UnconfiguredIpv6Fia                             1                     108

 

### Winning Hootie Config

!

ip multicast-routing distributed

ip multicast auto-enable

!

interface GigabitEthernet0/0/1

ip address 192.168.100.254 255.255.255.0

ip pim sparse-dense-mode

negotiation auto

!

interface Service-Engine0/1/0

ip pim sparse-dense-mode

!

interface Service-Engine0/4/0

ip pim sparse-dense-mode

!

interface Vif1

ip address 192.168.99.253 255.255.255.0

ip pim sparse-dense-mode

!

voice-port 0/1/0

voice-class permanent 1

auto-cut-through

operation 4-wire

type 2

timeouts call-disconnect 3

connection trunk 1000

description Police Radio 1

!

dial-peer voice 3000 voip

destination-pattern 3000

session protocol multicast

session target ipv4:239.10.10.241:27124

codec g711ulaw

no vad

!

 

### Verification

radio# sh ip int br | e una

Interface              IP-Address      OK? Method Status                Protocol

GigabitEthernet0/0/1   192.168.100.254 YES NVRAM  up                    up

Vif1                   192.168.99.253  YES manual up                    up

 

radio# sh call active voice com

<callID>  A/O FAX T<sec> Codec       type        Peer Address       IP R<ip>:<udp>        VRF

Total call-legs: 2

1 ANS     T659228 g711ulaw    TELE        P

2 ORG     T0      g711ulaw    VOIP        P3000    239.10.10.241:27124

     

radio# sh platform hardware qfp active feature sbc hootie group

SBC Hootie structure :

---------------------------------------

 

  VRF                                   = 0

  IP                                    = 239.10.10.241

  Port                                  = 27124

  Protocol                              = 1

  Calls in group                        = 1

 

SBC Hootie group Statistics

---------------------------------------

 

  Total RTP packets received                  = 409

  Total RTP octects received                  = 79592

  Total RTP packets replicated                = 409

  Total RTP octects replicated                = 79592

  Total RTP packets dropped                   = 0

  Total RTP octects dropped                   = 0

 

radio# sh ip mroute

IP Multicast Routing Table

Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,

       L - Local, P - Pruned, R - RP-bit set, F - Register flag,

       T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,

       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,

       U - URD, I - Received Source Specific Host Report,

       Z - Multicast Tunnel, z - MDT-data group sender,

       Y - Joined MDT-data group, y - Sending to MDT-data group,

       G - Received BGP C-Mroute, g - Sent BGP C-Mroute,

       N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed,

       Q - Received BGP S-A Route, q - Sent BGP S-A Route,

       V - RD & Vector, v - Vector, p - PIM Joins on route,

       x - VxLAN group, c - PFP-SA cache created entry

Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join

Timers: Uptime/Expires

Interface state: Interface, Next-Hop or VCD, State/Mode

 

(*, 239.255.255.250), 00:09:26/stopped, RP 0.0.0.0, flags: DC

  Incoming interface: Null, RPF nbr 0.0.0.0

  Outgoing interface list:

    GigabitEthernet0/0/1, Forward/Sparse-Dense, 00:09:26/stopped

 

(192.168.100.181, 239.255.255.250), 00:08:59/00:01:14, flags: PT

  Incoming interface: GigabitEthernet0/0/1, RPF nbr 0.0.0.0

  Outgoing interface list: Null

 

(*, 239.255.3.22), 00:09:27/00:02:35, RP 0.0.0.0, flags: DC

  Incoming interface: Null, RPF nbr 0.0.0.0

  Outgoing interface list:

    GigabitEthernet0/0/1, Forward/Sparse-Dense, 00:09:27/stopped

 

(*, 239.10.10.241), 00:10:13/stopped, RP 0.0.0.0, flags: DC

  Incoming interface: Null, RPF nbr 0.0.0.0

  Outgoing interface list:

   Vif1, Forward/Sparse-Dense, 00:01:44/stopped

    GigabitEthernet0/0/1, Forward/Sparse-Dense, 00:10:13/stopped

 

(192.168.99.1, 239.10.10.241), 00:10:13/00:00:41, flags: T

  Incoming interface: Vif1, RPF nbr 0.0.0.0

  Outgoing interface list:

    GigabitEthernet0/0/1, Forward/Sparse-Dense, 00:10:13/stopped

 

(*, 224.0.1.40), 00:10:13/00:02:36, RP 0.0.0.0, flags: DCL

  Incoming interface: Null, RPF nbr 0.0.0.0

  Outgoing interface list:

    GigabitEthernet0/0/1, Forward/Sparse-Dense, 00:10:13/stopped

 

radio# sh ip igmp member

Flags: A  - aggregate, T - tracked

       L  - Local, S - static, V - virtual, R - Reported through v3

       I - v3lite, U - Urd, M - SSM (S,G) channel

       1,2,3 - The version of IGMP, the group is in

Channel/Group-Flags:

       / - Filtering entry (Exclude mode (S,G), Include mode (G))

Reporter:

       <mac-or-ip-address> - last reporter if group is not explicitly tracked

       <n>/<m>      - <n> reporter in include mode, <m> reporter in exclude

 

Channel/Group                  Reporter        Uptime   Exp.  Flags  Interface

*,239.255.255.250              192.168.100.181 00:18:40 02:21 2A     Gi0/0/1

*,239.255.3.22                 192.168.100.181 00:18:41 02:25 2A     Gi0/0/1

*,239.10.10.241                192.168.99.253  00:02:58 00:01 2VA    Vi1

*,239.10.10.241                192.168.100.113 00:18:40 02:25 2A     Gi0/0/1

*,224.0.1.40                   192.168.100.254 00:13:00 02:18 2LA    Gi0/0/1

radio#

 

 

### Test Commands

! Inject 1000hz tone towards IP/Network Leg. Sent from DSP to Multicast

test voice port 0/1/0 inject-tone network 1000

test voice port 0/1/0 inject-tone network disable

 

! Inject 1000hz tone towards Voice-port sourced from DSP

test voice port 0/1/0 inject-tone local 1000

test voice port 0/1/0 inject-tone local disable

 

### PCAP for egress Multicast on IOS-XE

monitor capture TAC int gig0/0/1 both

monitor capture TAC match any

!

monitor capture TAC start

! send audio

monitor capture TAC stop

monitor capture TAC export [flash:/filename.pcap |ftp://user:pass@ip.address/filename.pcap | tftp://a.b.c.d/filename]

 

### PCM Capture for the voice-port

conf t

voice pcm capture buffer 200000

voice pcm capture destination bootflash:

exit

!

test voice port 0/1/0 pcm-dump caplog ffffff duration 255

! send audio

test voice port 0/1/0 pcm-dump disable

!

copy flash:/<filename>.dat [ftp://user:pass@ip.address/filename.pcap | tftp://a.b.c.d/filename]

! TAC is required to decode the binary .dat file into SIN/SOUT/RIN streams

 

### Other Info for Notes

! Hootie Licenses Required on IOS-XE to configure the voice features and ViF

!

license boot level appxk9

license boot level uck9

! or

license boot suite FoundationSuiteK9

license boot suite AdvUCSuiteK9

!

 

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards