cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1431
Views
0
Helpful
5
Replies

PVDM2-12DM compatibility with HWIC-1CE1T1-PRI

kenny.mclean
Beginner
Beginner

                  Hi there,

I'm hoping someone can assist.  The setup i am trying to get working is the following

User dials in over POTS to an ISDN30 Line.  The ISDN30 line (3rd Party Supplier) is connected to our 2911 via a HWIC-1CE1T1-PRI module.  We have inserted a PVDM2-12DM into the router to handle the POTS call.

Problem we have is that we cannot seem to get a modem tone when the user dials in.  The ISDN line connects and the debug modem command shows the modem SETUP & INIT phase - see below

Aug 13 12:58:52.341: CSM: MODEM_REPORT from 0/0/0:0, call_id=0x61, event=0x1, cause=0x0, dchan_idb=0x2B2C837C

Aug 13 12:58:52.341: CSM: called_number 'number removed' modem_pool 2AA6CE14 deny_call FALSE

Aug 13 12:58:52.341: CSM: Next free modem = 0/202; statbits = 10020

Aug 13 12:58:52.341: Modem 0/202 CSM: modem is allocated, modems free=-1

Aug 13 12:58:52.341: Modem 0/202 CSM: Incoming call from Unknown to 'number removed', id 0x61

Aug 13 12:58:52.341: Modem 0/202 CSM: (CSM_PROC_IDLE)<--ISDN_CALL

Aug 13 12:58:52.453: CSM: MODEM_REPORT from 0/0/0:0, call_id=0x61, event=0x4, cause=0x0, dchan_idb=0x2B2C837C

Aug 13 12:58:52.453: Modem 0/202 CSM: MODEM_REPORT rcvd DEV_CONNECTED for call_id 0x61

Aug 13 12:58:52.453: Modem 0/202 CSM: (CSM_PROC_MODEM_RESERVED)<--ISDN_CONNECTED

Aug 13 12:58:52.453: Modem 0/202 CSMV12: SETUP(Answer) ISDN 0/0:0

Aug 13 12:58:52.453: Modem 0/202 CSMV12: configured for Answer(A-law) mode, with Null signaling, 0x0 tone detection

Aug 13 12:58:52.453: Modem 0/202 CSMV12: INIT(Answer) ISDN 0/0:0

Aug 13 12:58:52.453: %ISDN-6-CONNECT: Interface Serial0/0/0:0 is now connected to N/A N/A

Aug 13 12:58:52.485: CSM: csm_modem_event called

Aug 13 12:58:52.485: Modem 0/202 CSM: (CSM_PROC_WAIT_FOR_CARRIER)<--CSM_EVENT_MODEM_SETUP Aug 13 12:58:52.341: CSM:

but there is no modem tone or any more output from the debug commands.

The ISDN line is working fine as a normal ISDN dial in is successful.

Has any one tried this before or is there a known issue with this solution?

1 Accepted Solution

Accepted Solutions

Configure network-clock-select 1 for the interface.

View solution in original post

5 Replies 5

paolo bevilacqua
Hall of Fame
Hall of Fame

Can you update IOS first.

If still trouble, search for similar threads in 'infrastructure - remote access' forum.

Updated the IOS but made no difference.  Turns out i was missing the line 'network-clock-participate wic 0'  Added this to the config and managed to get incoming POTS calls.  Only problem now is that the PITS call won't stay up for more than 5 seconds.  Looking at the Modem AT registry settings.

Configure network-clock-select 1 for the interface.

Hi Paolo,

Many thanks for this, all sorted.  Made a dial in call and managed a continuous ping for 7 minutes before i tore the call down.

You've been a great help,

Cheers

Kenny

Thank you for the nice rating and good luck!

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: