cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
360
Views
0
Helpful
3
Replies

q931 debug

subbarao.s
Beginner
Beginner

I am getting the below message with debug q931 on MGCP gateway confiugred for E1 PRI QSIG at IPC Dealer board side and T1 PRI to PSTN with CCM 4.0(2).

Incoming calls are perfectly routed to turrets but outgoing calls from the turrets not getting routed. I have checked partions/CCS/Route-patterns and translation patterns all are perfect.

Below is the debug

*Mar 13 05:26:36.147: ISDN Se1/0:15 Q931: RX <- SETUP pd = 8 callref = 0x0008

Sending Complete

Bearer Capability i = 0x8090A2

Standard = CCITT

Transer Capability = Speech

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0xA9838A

Exclusive, Channel 10

Facility i = 0x9FAA06800100820100A112020107020100800A4A6F686E20536D697468

Calling Party Number i = 0x0083, '6934'

Plan:Unknown, Type:Unknown

Called Party Number i = 0x80, '9117'

Plan:Unknown, Type:Unknown

*Mar 13 05:26:36.151: ISDN Se1/0:15 Q931: TX -> RELEASE_COMP pd = 8 callref = 0x8008

Cause i = 0x8081 - Unallocated/unassigned number

This is message on E1 QSIG trunk, I dont see any message on T1 PRI. Here I mean calls received from the E QSIG trunk are not getting routed to PSTN though there is a valid route pattern exists.

Calls from Cisco IP phones (which is in the same partition and CSS of Turrets( is perfectly getting routed to PSTN.

Any help is appreciated.

Thanks!

3 Replies 3

carijit
Beginner
Beginner

Hi Subba,

Under your Serial Interface for the E1 add this command

"isdn overlap-receiving T302 2000".

Hope this helps.

If this solution dont work please post your MGCP config.

Arijit

Hi Arijit,

Actually I tested overlap mode initially later I changed to End block mode for testing.

I guess the problem is with the route patter I have configured (I yet to verify this though). When I dial any number from turret, I dont see # prefix to the number though I press it. I think dealer board is dropping this.

Tomorrow I am planning to have two route patters 9.!# and 9.! as well, so that it should match one of them.

Thanks anyway for your help.

Subba

Hi Subba,

9T will be a better option on your dial peers.

# is more for the international route pattern option.

Lemme know how it goes.

Arijit

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: