Showing results for 
Search instead for 
Did you mean: 

vrf aware dns for sip calls



on our SBC, I want to have a sip trunk to our partner. I had configured this over ipv4 and this worked perfect.

Now our partner wants us to do send the calls to the DNS name of their SBC's so they can add and remove SBC's if needed, without having to contact us.

We also have VRF's configured on this SBC so I think there is something misconfigured.

When I do ping vrf vrfname domain-name , the domain-name is resolved.
In the dial-peer, I have configured session target dns:domain-name:5060. In the debug output, I can see that the correct dial-peer is selected, but the call fails. I see no outgoing call legs.

Does anybody now where I have made a mistake?

12 Replies 12

configuration seems ok if I compare it to this guide

VRF with ip is working fine, only when I use DNS, the calls fail.

I also checked this guide:

If you could share your running configuration, without any sensitive information, we could easier help you with verifying the correctness of it.

Response Signature

see attachment, only relevant config included and ip addresses removed

I think that you should try with a IOS version that is much newer than 16.4 as that is about ancient. As the 1000V is limited to a maximum version it would be advisable to upgrade to an 8000V instead. You can do that by simply upgrading the IOS on the virtual router to an IOS version for a 8000V. That will automatically change the hardware from a 1000V to a 8000V. Version 17.6.4 would be my go to choice as that is proven to be a stable release.

Response Signature

Have you check if the host name gets resolved to an IP with the vrf?

As this works with the IP, I assume it’s not resolving to IP address of the destination.

Response Signature


yes, when I do ping vrf vrfname domain-name I see the correct ip address



I have read that SRV is not used when you configure the port number like this:

session target dns:domain-name:5060



when I add the domain server globally, it works, but I would like to be able to give different DNS servers to different vrf's


Do you need source interface 

ip domain lookup vrf ShurgardNixxisSbcVRF source-interface GigabitEthernet2.3691

on ip domain lookup command ?

Response Signature

I have tried with and without source-interface... same result

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: