cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
589
Views
0
Helpful
1
Replies

ip pim neighbor-policy not working on Nexus 7K

s-durando
Level 1
Level 1

Hi all,

 

I have the following configuration on a couple of Nexus 7K:

N7K-1

interface Vlan3
  vrf member TEST
  ip address 10.139.7.252/22
  ip pim sparse-mode
  ip pim dr-priority 100
  ip pim hello-interval 5000
  no shutdown

 

N7K-2

interface Vlan3
  vrf member TEST
  ip address 10.139.7.253/22
  ip pim sparse-mode
  ip pim hello-interval 5000
  ip pim neighbor-policy FILTER-PIM-MAP
  no shutdown

ip access-list FILTER-PIM
  5 deny pim 10.139.7.252/32 any 
  6 deny pim 10.139.7.252/32 224.0.0.13/32 
  10 deny pim 10.139.7.252/32 any 
  20 permit ip any any 

route-map FILTER-PIM-MAP permit 10
  match ip address FILTER-PIM

 

 

Neighbor-policy is not working. PIM neighborship on SVI 3 is still up between Nexus 1 and 2.

Does anybody know what is wrong on the route-map and ACL?

 

Regards

Stefano

 

1 Reply 1

rigoh
Level 1
Level 1

try this

ip prefix-list mynewnb seq 15 permit 10.1.1.0/24 eq 32

route-map PIMNBRM permit 10
match ip address prefix-list mynewnb

interface Ethernet3/1
delay 100
bandwidth 1000
no ip redirects
ip address 20.1.0.1/16
ip pim sparse-mode
ip pim neighbor-policy PIMNBRM
no shutdown