04-23-2003 01:33 PM - edited 03-02-2019 06:51 AM
I'm working on a 2509 running IOS 11.2. I was connected via telnet and was configuring a banner message. I started getting the "Password Required but none set" message, which I usually get when I haven't configured the passwords on line vty0. No matter what I did (hit enter, ctrl-z, etc.) I got this message. I closed Hyperterminal and tried to re-establish the connection, but now I get an Unable to Connect to the router Port 23 message.
I physically went to the router and am able to console directly in to the router. I re-booted, had to manually copy the startup config to the running config (this is a problem I've had for some time), but I'm still unable to connect to the router via a telnet session. Still getting the unable to connect message.
Has anyone experienced anything similar and how did you overcome? Thanks!
04-24-2003 07:30 AM
a couple of things:
regarding you having to copy the startup to running, you might be able to resolve that by just changing the register value to 0x2102 :
config terminal
config-register 0x2102
end
write mem
Regarding the connection issue to the line vty, it would be helpful if you can paste your sho run. meanwhile, make sure you don't have access lists and that you are actually telneting to the right IP address. i know it sounds ridiculous, but just checking. also, maybe you don't have enough line vty sessions configrued?
E.
04-24-2003 08:09 AM
Thanks for the input on the Register value. I will definitely check it out.
Here is my Sho Run:
Current configuration:
!
version 11.2
no service password-encryption
no service udp-small-servers
no service tcp-small-servers
!
hostname SA_Plant_Phone_Rm_10.4.0.2
!
enable password 1sland
!
!
interface Loopback0
ip address 10.1.1.1 255.255.0.0
no ip directed-broadcast
!
interface Ethernet0
ip address 10.4.0.2 255.255.0.0
no ip directed-broadcast
!
interface Serial0
ip address 10.3.0.1 255.255.0.0
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.3.0.2
ip route 10.2.0.0 255.255.0.0 10.3.0.2
ip route 10.3.0.0 255.255.0.0 10.3.0.2
ip route 10.5.0.0 255.255.0.0 10.3.0.2
ip route 10.6.0.0 255.255.0.0 10.3.0.2
ip route 10.7.0.0 255.255.0.0 10.3.0.2
ip route 10.8.0.0 255.255.0.0 10.3.0.2
ip route 10.9.0.0 255.255.0.0 10.3.0.2
ip route 10.10.0.0 255.255.0.0 10.3.0.2
ip route 128.241.0.0 255.255.0.0 10.3.0.2
ip route 128.242.0.0 255.255.0.0 10.3.0.2
!
line con 0
line 1 8
line aux 0
line vty 0
password hawa11
login
line vty 1 4
login
!
end
~~~~~~~~~~~~~~~~~~~
My major concern with the Telnet issue is that I was connected to the router, the connection spontaneously dropped, and I can't telnet back in.
I don't ever expect that there would be more than one telnet session active at one time. Would I need more than the one session configured?
Thanks!
04-24-2003 08:27 AM
The symptoms are that it dropped you for whatever reason and left the vty0 session locked up. When you telnet now you are going into vty1. but I would think the boot would clear that up. Someone else might be in the vty0 session now. Connect via console and enter sho user and sho line. one or both will sho that your old session is still active or someone else is there. Put the password on all vtys.
04-24-2003 08:33 AM
Since the reboot didn't kill the open session, how do I force it down?
Thx.
04-24-2003 09:46 AM
to force the line vty to close:
sho users (to determine the line number you want to close)
clear line vty 0 (to close the session on the first line)
==
i am not so sure why you want to have so seperate line vty blocks (maybe for security reasons), but for troubleshooting purpose why don't you group them into one block first:
confi t
line vty 0 4
login
password XXXX
end
and try telneting into it again. i don't know what the default time-out is for a telnet session, but you can also control that using the line vty command "exec-timeout
E
04-24-2003 10:37 AM
The vty's separate automatically when they are configured different. In this case they should all be configured the same
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide