05-28-2003 06:02 PM - edited 03-02-2019 07:42 AM
Hello,
I started a post earlier but after working on the problem some more, I realized that I was barking up the wrong tree.
I figured out how to add DGW and DNS addresses to my config but, telling my router where the DNS servers are does me no good if I can not even ping them.
Here is my config...
"Current configuration : 1440 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 1605r
!
enable secret
!
ip subnet-zero
no ip source-route
ip name-server 64.81.45.2
ip name-server 216.231.41.2
!
no ip bootp server
!
!
!
!
interface Ethernet0
ip address 64.xxx.xxx.xxx 255.255.255.0
no ip proxy-arp
ip nat outside
no cdp enable
!
interface Ethernet1
ip address 192.168.1.1 255.255.255.0
no ip proxy-arp
ip nat inside
no cdp enable
!
ip default-gateway 64.xxx.xxx.xxx
ip nat inside source list 1 interface Ethernet0 overload
no ip classless
ip route 0.0.0.0 0.0.0.0 Ethernet0
no ip http server
!
access-list 1 permit 192.168.1.0 0.0.0.255
no cdp run
banner login ^C
WARNING!!!
This system is soley for the use of authorized users for official purposes.
You have no expectation of privacy in its use and to ensure that the system
is functioning properly, individuals using this computer system are subject
to having all of their activities monitored and recorded by system
personnel. Use of this system evidences an express consent to such
monitoring and agreement that if such monitoring reveals evidence of
possible abuse or criminal activity, system personnel may provide the
results of such monitoring to appropriate officials.
^C
!
line con 0
password
login
line vty 0 4
exec-timeout 0 1
no login
no exec
transport input none
!
end"
Now, this config worked perfectly on my cable modem where my isp assigned my ip address for int e0 dynamically. Now I have a new isp that has static addressing and I can't get it to work?!?!?
I entered the ip address and netmask on e0 and I can ping my DGW but I can not ping my dns servers. If i hook up a pc to my dsl modem instead of my router, I can surf fine.
Anyone know what I am missing?
Thanks, Chris
05-28-2003 06:04 PM
Chris,
Try enabling "ip classless"
05-29-2003 12:39 PM
you may also try "ip route 0.0.0.0 0.0.0.0 Ethernet0 64.x.x.x (next hop address)
instead of just ip route 0.0.0.0 0.0.0.0 Ethernet0
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide