02-18-2005 05:53 PM - edited 03-02-2019 09:45 PM
I setup one pool for dynamic DHCP bindings and one for manual bindings(mac-to-ip static mapping).But I always get the address of dynamic pool.Any suggest?
02-18-2005 07:51 PM
Configure the static binding pool such that its network is a sub of the main dynamic pool's network. For example:
ip dhcp pool main
network 10.129.5.0 255.255.255.0
domain-name xxx.yyy
dns-server 10.10.10.10
netbios-name-server 10.5.2.5
ip dhcp pool static_sub
host 10.129.5.254
hardware-address XXXX.XXXX.XXXX ieee802
client-name Orion (this is optional)
where the host Orion will always get the assigned ip address 10.129.5.254 from the static pool, and also inherit the domain name and dns server configs from the main dynamic pool.
The idea here is that the static pool network (10.129.5.254 255.255.255.255 - host) is a sub-network of the main pool (10.129.5.0 255.255.255.0); hence the static pool inherits the main pool's dns and domain name server in addition to assigning its own ip address.
Check this document:
Regards,
Mustafa
02-18-2005 09:30 PM
does the client-name Orion should be match netbios name or tcpip domain name?I was setup random name(not match any Netbios/domain name of PC)
I was setup same config as your but it is still got the dynamic addr. instead of static as your Ipaddr 10.129.5.254.
02-18-2005 11:20 PM
Client-name is optional, it does not have to match the netbios, and it should not contain domain suffix.
Try this on the static pool:
change the host command from
host 10.129.5.254
to
host 10.129.5.254 255.255.255.0
that is, the subnet mask has to be the same as the main dynamic pool (the reason is that the router will default to classful when checking the dhcpreq if no mask is specified)
Also, if possible - careful though, clear arp cache on the interface and see if that works.
02-19-2005 12:15 AM
I follow your instruction but it is still fail.This is my conf.
ip dhcp pool pool1
network 192.168.200.0 255.255.248.0
domain-name vghtpe.gov.tw
netbios-node-type h-node
default-router 192.168.207.254
dns-server 10.99.10.1 10.99.10.2
lease 5
!
ip dhcp pool pool2
network 192.168.212.0 255.255.252.0
default-router 192.168.215.254
domain-name vghtpe.gov.tw
netbios-node-type h-node
dns-server 168.95.1.1 168.95.192.1
lease 5
!
ip dhcp pool test_static
host 192.168.206.100 255.255.248.0
hardware-address 000c.f105.6098 ieee802
lease 5
The client is still get the dynamic addr.I did cleared the arp cache and clear ip dhcp bind.
I do not know is it related to two dynamic pools?
And I have another 2 questions about this.
1.The hardware address on "sh ip dhcp bind" is added another prefix 01.And the static and dynamic address is different.
2.How I set the expire time on static?
vghtpe-gateway#sh ip dhcp bind
IP address Hardware address Lease expiration Type
192.168.204.1 0100.0e35.1049.5e Feb 21 2005 07:43 AM Automatic
192.168.204.4 0100.0423.700b.1b Feb 24 2005 11:01 AM Automatic
192.168.204.11 0100.0cf1.052b.19 Feb 24 2005 04:03 PM Automatic
192.168.204.12 0100.0cf1.2f12.73 Feb 22 2005 12:11 AM Automatic
192.168.204.13 0100.0cf1.0567.c6 Feb 24 2005 04:01 PM Automatic
192.168.204.21 0100.0cf1.056b.15 Feb 24 2005 09:51 AM Automatic
192.168.204.33 0100.0cf1.0563.af Feb 24 2005 04:02 PM Automatic
192.168.204.34 0100.0cf1.0566.de Feb 24 2005 02:55 PM Automatic
192.168.204.37 0100.0cf1.052a.e7 Feb 24 2005 04:02 PM Automatic
192.168.204.38 0100.0cf1.0558.c9 Feb 24 2005 04:01 PM Automatic
192.168.204.218 0100.0cf1.0524.52 Feb 24 2005 02:47 PM Automatic
192.168.204.252 0100.0cf1.053d.70 Feb 24 2005 03:04 PM Automatic
192.168.205.12 0100.0cf1.0531.df Feb 24 2005 04:02 PM Automatic
192.168.205.14 0100.0423.7708.26 Feb 24 2005 10:12 AM Automatic
192.168.205.42 0100.0cf1.0560.a7 Feb 23 2005 03:56 PM Automatic
192.168.206.100 000c.f105.6098 Infinite Manual
192.168.206.226 0100.0b6b.4a96.b1 Feb 23 2005 01:45 PM Automatic
02-19-2005 01:50 AM
The MAC address with the correct ip address showed up:
IP address Hardware address Lease expiration Type
192.168.206.100 000c.f105.6098 Infinite Manual
so the client should have obtained that ip address. May be the client's NIC need to be reset after clearing the dhcp binding on the router. You can also experiment with changing the hardware-address type from ieee802 to:
hardware-address XXXX.XXXX.XXXX ethernet (default setting)
Not sure why the MAC addresses show up with 64 bits, or how to expire a static binding.
02-19-2005 06:59 AM
Insteed of doing this:
ip dhcp pool test_static
host 192.168.206.100 255.255.248.0
hardware-address 000c.f105.6098 ieee802
Try this:
ip dhcp pool test_static
host 192.168.206.100 255.255.248.0
client-identifier 0100.0cf1.0560.98
This would make it work.
02-19-2005 07:23 PM
Yes,it is works.Thanks
12-30-2020 05:34 AM
Hi,
In generel, you can bind it dynamicaly, just to see the machine id whether it is :
1: Client-ID || 2: Hardware address || 3: User name.
Then, you configure the static pool with the appropriate #ID!
Best Regards!
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide