07-12-2012 02:39 AM - edited 03-03-2019 06:40 AM
Hey everyone!
I have a big problem with my Cisco 1841 and the WIC-1AM-V2 in Slot 0.
I got the task, to test if it is possible, to build up a connection (Dial on Demand Routing) to a remote modem, which is connected to a console port of another Cisco 1841, with the integrated modem card over POTS from the CLI of the router. My router will only dial out to the remote modems and only if its needed.
I am connected to the router with the integrated modem card over a console cable on the console port. The remote modem is also connected to the console port of the remote Cisco 1841.
I found out, with my Dialer Profile configuration, it is possible to build up a connection. I configured a dialer list, that specifies that all ip traffic is permitted an interesting for my dialer interface. So a telnet or ping brings up my dialer, which brings up my Async interface. With the "show line" command, I can see that the TTY line, connected with the Async0/0/0 Interface is in use for 5 minutes, because of the "exec-timeout 5 0", which is configured on the remote router.
Now the problem is, in this 5 minutes, I can not use a remote telnet on this line with my loopback interface, because the line is already in use and I get a "connection refused". The first telnet I use runs in a timeout, because the remote host is not responding. When I dial out directly from the modem card and not from the CLI with the AT-commands, I get also the connection and with a return i get the login prompt.
I will post my actual config, so that you can see maybe a mistake I did or which command I must use, to get a working connection.
Current configuration : 3181 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service linenumber
!
hostname oob-test
!
boot-start-marker
boot-end-marker
!
logging buffered 8182 debugging
enable secret 5 $1$C61o$uwI8KVOlYVtAhVpc7Sj3U0
!
no aaa new-model
ip cef
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
ip host gelnlxxx 10.200.45.27
ip host gelitxxx 10.200.45.17
ip host geldexxx 10.200.45.69
!
chat-script gelitxxx ABORT ERROR "" "ATX3" OK "ATDT000xxxxxxx" TIMEOUT 120 CONNECT \r
chat-script gelnlxxx ABORT ERROR "" "ATX3" OK "ATDT000xxxxxxx" TIMEOUT 120 CONNECT \r
chat-script geldexxx ABORT ERROR "" "ATX3" OK "ATDT00xxxxxxx" TIMEOUT 120 CONNECT \r
!
!
!
!
ip telnet timeout retransmit 120
!
!
!
!
!
interface Loopback99
ip address 10.200.45.245 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.0.1 255.255.255.0
shutdown
duplex auto
speed auto
!
interface Async0/0/0
ip unnumbered Loopback99
encapsulation slip
dialer in-band
dialer pool-member 1
async mode interactive
no peer default ip address
routing dynamic
!
interface Dialer1
ip address 7.7.7.7 255.255.255.0
dialer pool 1
dialer remote-name gelnlxxx
dialer idle-timeout 300
dialer string 000xxxxxxx modem-script gelnlxxx
dialer-group 11
!
interface Dialer2
ip unnumbered Loopback99
dialer pool 1
dialer remote-name gelitxxx
dialer idle-timeout 300
dialer string 000xxxxxxxx modem-script gelitxxx
dialer-group 11
!
interface Dialer3
ip unnumbered Loopback99
dialer pool 1
dialer remote-name geldexxx
dialer idle-timeout 300
dialer string 00xxxxx modem-script geldexxx
dialer-group 11
!
ip forward-protocol nd
ip route 10.200.45.17 255.255.255.255 Dialer2
ip route 10.200.45.27 255.255.255.255 Dialer1
ip route 10.200.45.69 255.255.255.255 Dialer3
!
ip http server
no ip http secure-server
!
dialer-list 11 protocol ip permit
!
!
control-plane
!
alias exec gelnlxxx telnet 10.200.45.27 2002
alias exec gelitxxx telnet 10.200.45.17 2002 /source-interface Dialer2
alias exec geldexxx telnet 10.200.45.69 /source-interface Dialer3
!
line con 0
exec-timeout 5 0
transport output all
line aux 0
line 0/0/0
exec-timeout 30 0
session-limit 3
modem InOut
modem autoconfigure discovery
transport input all
transport output all
stopbits 1
speed 115200
flowcontrol hardware
line vty 0 4
exec-timeout 30 0
logging synchronous
login local
history size 256
transport input all
transport output all
!
scheduler allocate 20000 1000
end
I hope you can give me a hint. If you have any questions, don´t hesitate to ask.
07-12-2012 04:50 AM
Start checking that you can ping before telnet.
07-12-2012 07:24 AM
Dear Paolo,
I tried to ping the ip address of the remote router, but I got only ............... Maybe I am pinging the wrong ip address. When I build up a connection to the remote router via POTS and modem card from the CLI of my router, which IP of the remote router should I ping? The ip address which I used was the Loopback IP of the remote router. For example, the Loopback Ip of the remote router is 10.200.45.27 255.255.255.255. Must the Dialer or Async interface be in the same subnet to get a working ping?
07-12-2012 09:46 AM
255.255.255.255. Must the Dialer or Async interface be in the same subnet to get a working ping?
Yes, otherwise you have to setup some static routes etc.
Note however that IP over dial-up modem is too slow for almost any practical purpose, generally modems are used only for out of band management.
07-13-2012 01:50 AM
Dear Paolo,
you are right with the out of band management. This is the aim of my project. Maybe I was thinking in the wrong direction (using DDR). I am not trying to route anything, I am just trying to manage remote routers via POTS connection. Please have a look at the attachment (topology-setup). There you can see my described setup, which we have in the moment.
The aim is to get the CLI of the Branch-router to my HQ-router. When I start my chat-scripts, the dial connection works fine for 5 minutes, but I don´t get the CLI of the Branch-router to my HQ-router. But when I do a reverse Telnet (Loopback99 IP + Port of Async line) I get on the modem card (WIC-1AM-V2) and there I get the CLI of the Branch-router using the needed AT-Commands (atx3 and atdtxxx).
Now I am looking for a possibility, to get the CLI of the Branch-router to my HQ-router, from the CLI of my HQ-router.
07-13-2012 04:23 AM
You can then remove all the async and dialer commands.
If you can configure a chat script that dials automatically that's good otherwise just do manually.
There are also virtual com drivers to use the modem in HQ with a terminal program like Putty or Kitty
Please remember to rate useful posts clicking on the stars below.
07-13-2012 05:11 AM
Thank you for the advice, I will try it out! I also rated your answer is you wished.
If you can configure a chat script that dials automatically that's good otherwise just do manually.
I have configured a chat script, which calls the remote site:
chat-script gelitxxx ABORT ERROR "" "ATX3" OK "ATDT000xxxxxxx" TIMEOUT 120 CONNECT \r
But once the call is active, how do I get the incoming characters from the remote router to my command line?
There are also virtual com drivers to use the modem in HQ with a terminal program like Putty or Kitt
Can you give me a link or another hint, what you mean exactly with this virtual com drivers?
The HQ-router shall be used as a "management-server" for multiple engineers.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide