cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
639
Views
0
Helpful
9
Replies

loadbalancing two PTP line

statebar
Level 1
Level 1

Here is the setup:

I have two sites: LAN1 is connected to LAN2 by 2611XM on each side and both router connected to each other with two WIC Point to Point T1.

I like to know what is the best way to load balance trafic between two sites.

- Jayesh

9 Replies 9

marvin
Level 1
Level 1

IP CEF will do what you are looking for. What sort of traffic are you sending? You can do per-packet load balancing, but that is not recommended if you are sending delay sensitive traffic, such as voice.

Reference - Cisco - Configuring CEF -

http://www.cisco.com/en/US/products/sw/iosswrel/ps1828/products_configuration_guide_chapter09186a00800ca62c.html#3589

dbellazetin
Level 4
Level 4

Jayesh -

You don't need to use CEF if you don't want to. You can still do per packet or per destination load balancing without CEF too using 3 different methods.

Since these connections are back to back a Dynamic protocol probably isn't needed. You could just configure two static routes to the same destination on both routers and just point each route out a different PTP T1 interface.

For per packet load balancing which means the router will do a route table lookup (more CPU intensive and more delay) on your Ethernet LAN interface and T1 interfaces put in the command "no ip route-cache" to disable fast switching.

For per destination load balancing which means when the router receives a packet it examines the destination and looks up a fast-switch cache, if the router does not have an entry for the destination the L3 routing engine does a regular routing lookup and makes a forwarding decision. After this lookup is done the cache entry is created so subsequent packets to the same destination will just use the cached entry by passing the routing table lookup process.

Use PPP multilink which will bond the t1's together and automatically do fragmentation/load balancing on the PTP t1's.

Sample PPP Multilink config -

Site A

interface multilink 1

ip address 10.10.10.1 255.255.255.252

ppp multilink

multilink-group 1

!

interface serial 0

no ip address

encapsulation ppp

ppp multilink

multilink-group 1

!

interface serial 1

no ip address

encapsulation ppp

ppp multilink

multilink-group 1

Site B

interface multilink 1

ip address 10.10.10.2 255.255.255.252

ppp multilink

multilink-group 1

!

interface serial 0

no ip address

encapsulation ppp

ppp multilink

multilink-group 1

!

interface serial 1

no ip address

encapsulation ppp

ppp multilink

multilink-group 1

Verify PPP multilink using "show ppp multilink".

This link will show you how to do PPP Multilink with a Virtual Template interface which accomplishes the same as above. I have used both methods and haven't had any preference on either one because they both work just fine.

http://www.cisco.com/en/US/customer/tech/tk713/tk507/technologies_configuration_example09186a00800a3e98.shtml

Daniel

Daniel,

Thanks for the information,

Does multilink provide redundancy also? If one line fails does trafic still forwarded on other line?

Jayesh

It sure does.

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

Jayesh,

Yes I'm sorry I didn't add that into my remark. The way multilink works is it creates a master interface that is responsible for the links (t1 interfaces) which in multilink is called a bundle.

If you have multilink enabled and a particular link fails, traffic will simply stop flowing across that pipe and multilink will remove it from the bundle.

Once it comes back up again multilink will add it to the bundle and begin to use the pipe again.

So it provides load balancing, redundancy and fault tolerance.

Daniel

Do I need to add static route for destination LAN?

LAN1 and LAN2 are connected with routers on both side. I am using EIGRP and IP CEF is enabled.

Thanks

Jayesh

If you are using EIGRP you don't need to input any static routes.

Daniel

Daniel,

I have configured router as follow. Let me know if it should work or any change need to be made.

Router A:

!

ip cef

!

interface FastEthernet0/0

description "Interface to LA LAN"

ip address 172.15.3.1 255.255.0.0

speed 100

full-duplex

!

interface Serial0/0

ip address 10.10.1.1 255.255.255.252

ip load-sharing per-packet

shutdown

fair-queue

service-module t1 clock source internal

service-module t1 timeslots 1-24

!

interface Serial0/1

ip address 10.10.1.5 255.255.255.252

ip load-sharing per-packet

shutdown

fair-queue

service-module t1 clock source internal

service-module t1 timeslots 1-24

!

router eigrp 1

redistribute static

network 10.0.0.0

network 172.15.0.0

no auto-summary

no eigrp log-neighbor-changes

!

ip classless

ip route 0.0.0.0 0.0.0.0 172.15.1.1

Router B:

!

ip cef

!

interface FastEthernet0/0

description "Interface to SF LAN"

ip address 172.16.3.54 255.255.0.0

speed 100

full-duplex

!

interface Serial0/0

ip address 10.10.1.2 255.255.255.252

ip load-sharing per-packet

shutdown

fair-queue

service-module t1 timeslots 1-24

!

interface Serial0/1

ip address 10.10.1.6 255.255.255.252

ip load-sharing per-packet

shutdown

fair-queue

service-module t1 timeslots 1-24

!

router eigrp 1

redistribute static

network 10.0.0.0

network 172.16.0.0

no auto-summary

no eigrp log-neighbor-changes

!

no ip http server

ip classless

ip route 0.0.0.0 0.0.0.0 172.16.1.1

It looks like it should work. Just remember to turn on the serial interfaces.

Once you have the routers in place make sure a "show ip route" shows two routes to the same destination using two different next hop IP addresses.

"Show ip eigrp topology" should also show two successor routes to the same destination.

Daniel