05-26-2014 12:57 AM - edited 03-03-2019 07:25 AM
I am trying to create an etherchannel between two switches 2970G and a 3750G
The configuration of the interfaces is as follows :
interface Port-channel3
switchport mode access
macro description 3750G-16TD
!
interface GigabitEthernet2/0/1
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
channel-group 3 mode active
!
interface GigabitEthernet2/0/2
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
channel-group 3 mode active
!
interface GigabitEthernet2/0/3
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
channel-group 3 mode active
!
interface GigabitEthernet2/0/4
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
channel-group 3 mode active
When I connect the switches i get this message :
%EC-5-CANNOT_BUNDLE2: Gi2/0/4 is not compatible with Po3 and will be suspended (dtp mode of Gi2/0/4 is on, Po3 is off)
%EC-5-CANNOT_BUNDLE2: Gi2/0/3 is not compatible with Po3 and will be suspended (dtp mode of Gi2/0/3 is on, Po3 is off)
any idea how to fix the etherchannel ?
05-26-2014 02:59 AM
Issue seems with interface attribute, please check duplex and speed of both interfaces.
Error Message EC-5-CANNOT_BUNDLE2: [chars] is not compatible with [chars] and will
be suspended ([chars]).
Explanation This message means that the interface has different interface attributes than other ports in the EtherChannel. For the interface to join the bundle (EtherChannel), change the interface attributes to match the EtherChannel attributes. The first [chars] is the interface to be bundled, the second [chars] is the physical interface that is already in the bundle, and the third [chars] is the reason for the incompatibility.
Recommended Action Change the interface attributes to match the EtherChannel attributes.
05-26-2014 03:59 AM
05-26-2014 04:28 AM
I am talking about Gi2/0/4 and Gi2/0/3, check duplex and speed of both interfaces same as GigabitEthernet 2/0/2 setting.
Sajid Ali Pathan
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide