Redundancy & load balance by using static route
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
10-05-2004 07:23 PM - edited 03-02-2019 07:00 PM
I have build a lab at home and try to test Redundancy and load balance by using static route.
I am trying to ping some internet IP from PC1, I find that it can perform Redundancy when I shutdown one of series ports of 2620 but load balance fail.
It is possible to do it ?
The Physical connection is as Below. 2620 two serial ports are connect to two 1720 series port
LanA(PC1 192.168.0.1) -> 2620->1720A & 1720B -> Hub(LanB) ->NAT Router(192.168.169.254) -> Internet
2620#sh ru
!
version 12.1
service timestamps debug uptime
!
memory-size iomem 10
ip subnet-zero
no ip finger
!
!
interface Ethernet0/0
ip address 192.168.0.254 255.255.255.0
!
interface Serial0/0
ip address 172.0.0.1 255.255.255.252
no fair-queue
clockrate 128000
!
interface Ethernet0/1
no ip address
shutdown
!
interface Serial0/1
ip address 172.0.0.6 255.255.255.252
clockrate 128000
!
ip classless
ip route 0.0.0.0 0.0.0.0 Serial0/1
ip route 0.0.0.0 0.0.0.0 Serial0/0
!
line con 0
1720B#sh ru
!
version 12.2
!
hostname RouterB
!
memory-size iomem 20
ip subnet-zero
!
interface FastEthernet0
ip address 192.168.169.51 255.255.255.0
ip nat outside
speed auto
!
interface Serial0
ip address 172.0.0.2 255.255.255.252
ip nat inside
no fair-queue
!
ip nat inside source list 1 interface FastEthernet0 overload
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.169.254
ip route 192.168.0.0 255.255.255.0 192.168.169.50
ip route 192.168.0.0 255.255.255.0 172.0.0.1
no ip http server
!
access-list 1 permit 192.168.0.0 0.0.0.255
!
line con 0
1720A#sh ru
!
memory-size iomem 25
ip subnet-zero
!
!
interface FastEthernet0
ip address 192.168.169.50 255.255.255.0
ip nat outside
speed auto
!
interface Serial0
no ip address
shutdown
!
interface Serial1
ip address 172.0.0.5 255.255.255.252
ip nat inside
!
ip nat inside source list 1 interface FastEthernet0 overload
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.169.254
ip route 192.168.0.0 255.255.255.0 172.0.0.6
ip route 192.168.0.0 255.255.255.0 192.168.169.51
no ip http server
!
access-list 1 permit 192.168.0.0 0.0.0.255
!
line con 0
- Labels:
-
Other Networking
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
10-05-2004 08:20 PM
By default your interfaces on the 2620 serial interface will be doing per-destination load balancing. For every destination address one of the serial links will be used. Try pinging a different address in the internet and see if LB works.
UC Solutions Architect
Pacific Northwest | CDW
CCIE Collaboration #17135 Emeritus
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
10-05-2004 11:16 PM
This is normally doing per-session balancing rather than per-packet load balancing. I think you can provoke per-packet load balancing, at a price, by disabling CEF and ip route cache.
Kevin Dorrell
Luxembourg
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
10-06-2004 03:00 AM
Yes, I try to use two ping, it can perform LB,
so is it possible to perform per-packet LB ?
I haven't enable CEF and ip route cache
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
10-06-2004 03:25 AM
ip route cache is enabled by default. You have to do no ip route cache on the relevant interfaces to disable it.
Kevin Dorrell
Luxembourg
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
10-06-2004 04:16 AM
Thx ! kevin,
This time, I have disable ip route cache in the 2620Router and use one ping to obtain the result.
It seems not work because I expect there will be input and output traiffc on both two serial interface,but now the result seems no output rate on two serial interfaces.
Does my concept is right ? traffic which leave from router to interface can be seen as output rate ?
2620#sh int | i bits/sec
5 minute input rate 11000 bits/sec, 1 packets/sec
5 minute output rate 11000 bits/sec, 1 packets/sec
5 minute input rate 6000 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
5 minute input rate 5000 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
10-06-2004 04:27 AM
The concept is right. I don't know why it does not seem to be working ... I'll have to do some reading. I don't know how it arbitrates between the two routes when route cache is disabled. I'll post back to you if I find anything.
Kevin Dorrell
Luxembourg
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
10-06-2004 04:31 AM
Thank you very much !
kevin.
