01-23-2021 10:36 PM - edited 01-24-2021 11:44 AM
I am wondering how to create an ACL for this scenario:
LAN-A connected to Router-1 on fa0/0 and subnet is 1.1.1.0/24
LAN-B connected to Router-1 on fa0/1 and subnet is 2.2.2.0/24
ACL requirement:
Solved! Go to Solution.
01-24-2021 12:01 PM - edited 01-24-2021 12:30 PM
I was able to solve this as well:
interface FastEthernet0/0 ##LAN-A
ip address 1.1.1.1 255.255.255.0
!
interface FastEthernet0/1 ##LAN-B
ip address 2.2.2.1 255.255.255.0
ip access-group inbound in
ip access-group outbound out
!
interface FastEthernet1/0 ##internet
ip address dhcp
!
ip access-list extended outbound-LAN-B
permit ip 1.1.1.0 0.0.0.255 any reflect Mirror timeout 30 ##permits and watches LAN-A's connection to LAN-B
permit ip any any ##permits LAN-B to go to internet/other subnets
!
ip access-list extended inbound-LAN-B
evaluate Mirror ##permits or denies based on self created Mirror ACL
deny ip 2.2.2.0 0.0.0.255 1.1.1.0 0.0.0.255 ##denies LAN-Bs initial connection going out to LAN-A
permit ip any any ##permits internet/other subnet traffic going to LAN-B
01-24-2021 03:19 AM
Not sure what is the device hee and version of code running, you can look examples (reflex ACL)
You want to only TCP session look at below : (Allow Only Internal Networks to Initiate a TCP Session)
https://www.cisco.com/c/en/us/support/docs/ip/access-lists/26448-ACLsamples.html
01-24-2021 10:47 AM
ip access-list extended INBOUND evaluate MIRROR ! ip access-list extended OUTBOUND permit tcp any any reflect MIRROR permit udp any any reflect MIRROR permit icmp any any reflect MIRROR ! interface FastEthernet0/0 ip address 1.1.1.1 255.255.255.0 ! interface FastEthernet0/1 ip address 2.2.2.1 255.255.255.0 ip access-group INBOUND in ip access-group OUTBOUND out
Tested and verified in GNS3 using c2691 running version 12.4(25d)
01-24-2021 12:01 PM - edited 01-24-2021 12:30 PM
I was able to solve this as well:
interface FastEthernet0/0 ##LAN-A
ip address 1.1.1.1 255.255.255.0
!
interface FastEthernet0/1 ##LAN-B
ip address 2.2.2.1 255.255.255.0
ip access-group inbound in
ip access-group outbound out
!
interface FastEthernet1/0 ##internet
ip address dhcp
!
ip access-list extended outbound-LAN-B
permit ip 1.1.1.0 0.0.0.255 any reflect Mirror timeout 30 ##permits and watches LAN-A's connection to LAN-B
permit ip any any ##permits LAN-B to go to internet/other subnets
!
ip access-list extended inbound-LAN-B
evaluate Mirror ##permits or denies based on self created Mirror ACL
deny ip 2.2.2.0 0.0.0.255 1.1.1.0 0.0.0.255 ##denies LAN-Bs initial connection going out to LAN-A
permit ip any any ##permits internet/other subnet traffic going to LAN-B
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide