cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1501
Views
15
Helpful
24
Replies
Mohideen Pitchai
Beginner

SR TE Policy in IOS XE

Hi , I am trying to bring up SR TE Policy on VIRL to create a tunnel between PEs.

Need support to clarify the following. Kindly assist.

 

1. My PCC to PCE connection doesnt show "Instantiation". Is there anything i am missing here as this is required for SR-PCE initiate LSP if i am not wrong.

 

R5#show pce client peer
PCC's peer database:
--------------------

Peer address: 12.12.12.12, Precedence: 100
Client POLICY_MGR
State up
Capabilities: Stateful, Update, Segment-Routing

 

2. My Policy is not coming up which is created locally on the PCC R5.

 


segment-routing mpls
!
connected-prefix-sid-map
address-family ipv4
5.5.5.5/32 index 5 range 1
exit-address-family
!
segment-routing traffic-eng
policy SR_TE_1
color 10 end-point 3.3.3.3
candidate-paths
preference 100
dynamic
metric
type igp
!

 

Output shows as follows:

 


R5#sh segment-routing traffic-eng policy all

Name: SR_TE_1 (Color: 10 End-point: 3.3.3.3)
Owners : CLI
Status:
Admin: up, Operational: down for 00:43:04 (since 06-21 09:20:51.275)
Candidate-paths:
Preference 100 (CLI):
Dynamic (inactive)
Inactive Reason: Source address is not specified
Metric Type: IGP
Attributes:

 

Note : I am running IOS XE 17.3.1a on VIRL 

 

Thanks
Mohideen.

 

3 ACCEPTED SOLUTIONS

Accepted Solutions

The issue seems to be due to the fact that your OSPF network type is not point-to-point.

 

This causes weird information in the segment routing topology database as can be seen here:

 

Node 1:
TE router ID: 5.5.5.5
OSPF router ID: 5.5.5.5 area ID: 0 domain ID: 115 ASN: 0
Prefix SID:
Prefix 5.5.5.5, label 16005 (regular), domain ID 115, flags: N
Link[0]: local address 10.1.5.5, remote address 10.1.5.1
Local node:
OSPF router ID: 5.5.5.5 area ID: 0 domain ID: 115 ASN: 0
Remote node:
TE router ID: 1.1.1.1
OSPF router ID: 1.1.1.1 area ID: 0 domain ID: 115 ASN: 0
Metric: IGP 0, TE 0, Delay 0
Bandwidth: Total 0, Reservable 0
Admin-groups: 0x00000000
Link[1]: local address 10.1.5.5, remote address 10.1.5.5
Local node:
OSPF router ID: 5.5.5.5 area ID: 0 domain ID: 115 ASN: 0
Remote node:
TE router ID: 5.5.5.5
OSPF router ID: 5.5.5.5 area ID: 0 domain ID: 115 ASN: 0
Metric: IGP 1, TE 1, Delay 1
Bandwidth: Total 125000000, Reservable 0
Admin-groups: 0x00000000
Adj SID: 18 (unprotected)

 

Although you only have one link between Node 1 and Node 2, the topology database sees 2. 

 

Can you please set all the transit interface as point-to-point ("ip ospf network point-to-point").

 

Regards,

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

View solution in original post

Hi Mohideen,

 

The issue is due to the fact that you are missing the following configuration under the ospf process on the PCE.

 

router ospf SR

 distribute link-state

 

This is why the PCE is not listening on TCP port 4189

 

Regards,

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

View solution in original post

Hi Harold,

 

Its working now. Thanks for your support to reach towards conclusion.. Much appreciated.

 

Thanks

Mohideen.

View solution in original post

24 REPLIES 24
Harold Ritter
Cisco Employee

Hi @Mohideen Pitchai ,

 

If I understand you well, you want the PCE to evaluate the policy. You need to change your policy as follow.

 

policy SR_TE_1
color 10 end-point 3.3.3.3
candidate-paths
preference 100
constraints
segments
dataplane mpls
!
!
dynamic
pcep
metric
type igp
!
!
!
!

 

Regards,

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

Hi Harold,

 

Thanks for your prompt support.. Initially i am trying local path calculation by PCC itself and then to move with PCE initiated LSP.

 

However with the below suggested configuration i am still unable to make it up.

 


Name: SR_TE (Color: 5 End-point: 1.1.1.1)
Owners : CLI
Status:
Admin: up, Operational: down for 00:49:18 (since 06-22 16:13:17.685)
Candidate-paths:
Preference 5 (CLI):
Dynamic (inactive)
Inactive Reason: Failed to find SID's for the path
Metric Type: IGP
Attributes:
Binding SID: 19
Allocation mode: dynamic
State: Programmed

---------------------------------------------------------------------

config

---------------------------------------------------------------------

segment-routing traffic-eng
policy SR_TE
color 5 end-point 1.1.1.1
candidate-paths
preference 5
constraints
segments
dataplane mpls
!
!
dynamic
metric
type igp

 

Hi Harold, 

 

In addition to this i am having issue in bringing up PCEP connection on IOSXE PCC using segment-routing pcc config.

 

However the PCEP connection is coming up through mpls traffic-engineering based pcc configuration. Still the SR-PCE initiated LSP is failing.

 

Status:

 

R5#sh pce client peer
PCC's peer database:
--------------------

Peer address: 12.12.12.12, Precedence: 10
Client POLICY_MGR
State keep wait
Capabilities: Stateful, Update, Segment-Routing

R5#sh pce client peer
PCC's peer database:
--------------------

Peer address: 12.12.12.12, Precedence: 10
Client POLICY_MGR
State idle
Capabilities: Stateful, Update, Segment-Routing

 

CONFIG:

 


segment-routing traffic-eng
pcc
pce address 12.12.12.12 source-address 5.5.5.5 preference 10
report-all

 

Kindly assist.

 

Did you configure the following on the PCE?

 

pce
address ipv4 12.12.12.12
!

 

Can you do a "show tcp brief" on the PCE?

 

Regards,

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

Hi Harold,

 

Please find the below info to support further.

 

RP/0/0/CPU0:XR2#show tcp brief | i 4189
Tue Jun 22 21:10:36.613 UTC
0x1213ac08 0x60000000 0 0 0.0.0.0:4189 0.0.0.0:0 LISTEN
RP/0/0/CPU0:XR2#show tcp brief | i 4189
Tue Jun 22 21:10:37.993 UTC
0x1215de70 0x60000000 220 0 12.12.12.12:4189 5.5.5.5:42883 CLOSEWAIT
0x1213ac08 0x60000000 0 0 0.0.0.0:4189 0.0.0.0:0 LISTEN
RP/0/0/CPU0:XR2#show tcp brief | i 4189
Tue Jun 22 21:10:39.903 UTC
0x1213ac08 0x60000000 0 0 0.0.0.0:4189 0.0.0.0:0 LISTEN

 


RP/0/0/CPU0:XR2#sh run pce
Tue Jun 22 21:08:14.803 UTC
pce
address ipv4 12.12.12.12
logging
no-path
fallback

 

Thanks

Mohideen.

Hi @Mohideen Pitchai ,

 

It looks like the configuration is fine and that the PCC is trying to connect. I would suggest using "deb pce pcep" on the PCE to get more information about the session not coming up.

 

Regards,

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

Hi @Harold Ritter 

 

Greetings. i got the traces and attaching it for your kind reference. once i shutdown my local SR-TE Policy under segment-routing the PCEP connection becomes stable.

Thanks

Mohideen.

Hi @Mohideen Pitchai ,

 

The issue is due to the PCC reporting the local policy to the PCE and the PCE not recognizing some specific TLV and therefore closing the session. The issue is known (CSCvk44812) and resides on the PCE. What version of XR do you run on the PCE?

 

Here are the specific log entries from the "deb pce pcep":

RP/0/0/CPU0:Jun 22 22:44:31.497 : pce_server[1117]: DBG-PCEP:pce_parse_tlvs:3364 3. Parsing TLV Unknown (type 65505, size 6)
RP/0/0/CPU0:Jun 22 22:44:31.497 : pce_server[1117]: DBG-PCEP:pce_tx_msg:842 Sending Close to 5.5.5.5.

 

Here's the link to the CCO bug toolkit:

https://bst.cloudapps.cisco.com/bugsearch/bug/CSCvk44812

 

You have at least two options:

- Upgrading the PCE to a level of code fixing CSCvk44812

- Removing the "report-all" from the segment-routing pcc section

 

Regards,

 

 

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

Hi Harold,

 

I am running 6.3.1 on CML2 .. Let me see how this can be upgraded to newer version.

 

Best Regards

Mohideen.

Hi @Mohideen Pitchai ,

 

You are probably using XRv then for PCE. 6.3.1 is the latest you can go with XRv. The alternative would be to use XRv9000 in place of XRv for the PCE. This will allow you to use much more recent code, which will include the fix for CSCvk44812.

 

Regards,

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

Hi ,

I tried this XRv 9000 running 7.x code. However enabling PCE configuration doesnt make the PCE to listen on the req port. The output is empty.
Is it due to not all software pack to be added

Did you give it a couple of minutes. It sometimes takes a bit of time for the process to start listening on port 4189.

 

Regards,

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

Hi Harold,

The PCE Is up for 20 minutes; however looks like it missing some packages to be added.. kindly let  me know if we have any option to move forward.

 


RP/0/RP0/CPU0:PCE#show version
Thu Jun 24 15:32:55.220 UTC
Cisco IOS XR Software, Version 7.2.1
Copyright (c) 2013-2020 by Cisco Systems, Inc.

Build Information:
Built By : gopalk2
Built On : Wed Aug 12 06:38:51 PDT 2020
Built Host : iox-ucs-012
Workspace : /auto/srcarchive13/prod/7.2.1/xrv9k/ws
Version : 7.2.1
Location : /opt/cisco/XR/packages/
Label : 7.2.1-0

cisco IOS-XRv 9000 () processor
System uptime is 22 minutes

RP/0/RP0/CPU0:PCE#
RP/0/RP0/CPU0:PCE#
RP/0/RP0/CPU0:PCE#
RP/0/RP0/CPU0:PCE#sh run pce
Thu Jun 24 15:33:06.213 UTC
pce
address ipv4 15.15.15.15
!

RP/0/RP0/CPU0:PCE#sh tcp br
Thu Jun 24 15:33:12.030 UTC
RP/0/RP0/CPU0:PCE#

Hi @Mohideen Pitchai ,

 

Can you please provide the output of the following command: "show install committed". Can you also provide the file name for the XRv9000 that you installed.

 

Regards,

 

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México