cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
3158
Views
5
Helpful
9
Replies
Highlighted
Beginner

CPAM Client problems

Hi

We are runnning a physical CPAM server version 1.3.0.0341 and are having some issues withc the CPAM Client in a Terminal Server environment.

When installing, everything looks fine, JRE and the client finishes installing and the Client starts up whith no problem.

But when a user connect, the se the attached error BEFORE the login windows appears.

CPAM.JPG

We have another Terminal server, excactly the same (Windows 2008 Std. SP2 x64) which works fine......

The firewall rules are also the same. If i connect through the Console it works, both as administrator and regular user, but not in a RDP session....

Any clues?

9 REPLIES 9
Highlighted
Enthusiast

Hello Joergen,

The only two supported operating systems for the CPAM Desktop Client are as follows:

  • Windows XP or Vista and Internet Explorer 6.0 or higher
  • Windows 7 (64-bit only) and Internet Explorer 8.0 (32-bit only)

I've never seen it installed in a CPAM environment, so I can't comment on that.  I would recommend loading the CPAM client on a supported OS and see if that resolves your issue.

Thank you,

Sean

Highlighted

We are having the same error pop up on certain machines. We are not running any terminal servers, no firewall or anything like that. Just a standard install. Some of these errors are happening on XP machines, and some on Win7. We have uninstalled the cleint and reinstalled it. It seemed to fix the issue on a few machines, but not on all of them

Highlighted

Hi Jason,

The next time you see this error, can you open the task manager, at the Processes tab, highlight "javaw.exe", and press "End Process" button.  Please follow up and let me know if this allows you to proceed as expected, or if this does not help.

Thanks,

Sean

Highlighted
Beginner

We are having this problem also. I'm not sure if it's A/D related or not. It appears to have something to do with permissions. I found nothing on Cisco.com or from the endless Google searches I have done.

Ending javaw.exe only clears the error message. It doesn't enable the user to log in the next time your start the PAM client.

Highlighted

This problem was AD related for us, GPO related actually.  I run the client on a 2k8 R2 server and unless you have local admin privileges, this is the error you will receive.  Our users didn't have local admin based on their individual GPOs.  The same goes for their local workstations, which they don't have local admin privileges to either.

If you have a way of escalating their priveleges for the single process this should work.  It was the solution for us.

The same thing goes for installing a client update.

The client.jnlp file will crash before it downloads the jar file, which is the actual installation file.  We had to escalate a CLI session to local admin privileges on the workstation and run the following command "javaws client.jnlp" to get the client update to install.  You may have to locate the javaws executable.  It should be in Program Files\Java\jre-xxxxx\bin\.

This is kind of a pain, but it should be workable in your GPO heirarchy.

Hopefully this works for you.  It did for us.

Highlighted

I second Jonathan's fix. We had the same issue here for a client who was receiving the same error. We gave the user account admin rights on that computer and it corrected the error.

Highlighted

Well, we will NOT give any user admin rights, especially in a Citrix Farm environment .

But until further i could deploy an extra Citrix server just for this and make user loacl admins.

Highlighted
Beginner

It is not an operating system problem. I am already running the CPAM client on 2008 R2 servers, så it is just related to Terminal services.

I know from my knowledge on Citrix, that some applications must have an unique IP adress per user (which can be easily solved with Citrix), but in this case, i am the only user logged on to the server.

We have several users on the CPAM klient, and not all is located at the company adress (etc at home), so it would really help us to be able to.

We are in the progress of upgrading to CPAM version 1.4.1 (0.3.13), i will update this post as soon as we are up and running.

Highlighted

Please let us know the outcome of the upgrade once you are done.

Content for Community-Ad