cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
2007
Views
10
Helpful
10
Replies
Arie --
Beginner

Warning on Media Server "Media Server Database is Inconsistent"

Hello,

 

Does anyone have any documentation about this warning that occur on VSMS (Media Server)?

Description: Media Server Database is Inconsistent

Detail: Could not update SMD file record with recording repository id. Check recording location in Media Server Database.

 

I have searched on google but still can't find relevant documentation about this Warning.

 

The VSMS and VSOM are not co-located and the version is 7.6.0. The OS platform is RedHat Enterprise Linux Server release 6.4 (Santiago).

 

Thank you in advance.

1 ACCEPTED SOLUTION

Accepted Solutions

It not associated to the VSM 7.6 Hotfix1 and there is not Bug id created to this issue.

Just an internal created script from BU, which has synchronized with VSOM the server's status can be reset to clear the database inconsistent errors.

 

Solution:

To verify the problem check the recording_location table in the VSMS database to verify all of the video repositories are listed correctly by running the following database query:

# sudo /usr/BWhttpd/mysql/bin/mysql --defaults-file=/usr/BWhttpd/mysql/ums/ums.cnf UMS -e "select l.name,t.name as 'Type',s.name as 'state' from recording_location l, recording_location_type t, admin_states s where l.type = t.enum_value and l.admin_state = s.enum_value order by l.name,t.name;"

+----------+---------------+---------+
| name     | type          | state   |
+----------+---------------+---------+
| /media2  | media         | enabled |
| failover | remote_server | enabled |
+----------+---------------+---------+

 

++ To add the missing partitions, download the dbinconsistent.zip file attached below and upload the file to the VSM server.  Unzip the file and run the script on the server's VSMS database:

# unzip dbinconsistent.zip

# sudo /usr/BWhttpd/mysql/bin/mysql --defaults-file=/usr/BWhttpd/mysql/ums/ums.cnf UMS -e "delete from recording_location where name = 'failover';"
# sudo /usr/BWhttpd/mysql/bin/mysql --defaults-file=/usr/BWhttpd/mysql/ums/ums.cnf UMS < dbinconsistent.sql

 

Then restart the VSM software on the server.  When the server comes up and has synchronized with VSOM the server's status can be reset to clear the database inconsistent errors.

Hope this explanation helps you.


Thanks,

Jayesh

 

View solution in original post

10 REPLIES 10
Scott Olsen
Frequent Contributor

I personally haven't seen this one.  My advice would be to open a Cisco TAC case and ask for a root cause or bugID.

Cheers!

Scott Olsen Solutions Specialist Bulletproof Solutions Inc. Web: www.bulletproofsi.com

Hello Arie,

Yes this is a know issue in the VSM 7.6 version, I can help you with that if you can open a TAC case with us.


The main reason behind this was:

"Each of the video repository partitions where video is being recorded must be listed here as type "media" and state "enabled", and each will probably be listed as type "clip" as well (the "failover" should always be present, it is a default entry).  If any of the repository partitions are missing, a SQL script needs to be run to update the table to add the missing entries.  If any of the partitions are listed and disabled, the disable partitions may be re-enabled through the server's Media Server settings in VSOM."

To add the missing partitions on the server, there is a patch which need to run on the VSOM to make the DB consistent.

Let me know you contact information, so I can help you over phone to fixed this issue.

 

Regards,

Jayesh

 

Scott Olsen
Frequent Contributor

Is this addressed by the 7.6 Hotfix package, Jsah?

Scott Olsen Solutions Specialist Bulletproof Solutions Inc. Web: www.bulletproofsi.com

No, there is another "dbinconsistent" patch is there to run in the server comes up and synchronized with VSOM to clear the database inconsistent errors and make the server stable then.

 

Scott Olsen
Frequent Contributor

I'm sorry... I don't quite follow your statement above.  Can you confirm this is a known issue that *does* currently impact VSM 7.6 Hotfix 1?  If so, is there a BugID for this problem?

Thanks.

Scott Olsen Solutions Specialist Bulletproof Solutions Inc. Web: www.bulletproofsi.com

It not associated to the VSM 7.6 Hotfix1 and there is not Bug id created to this issue.

Just an internal created script from BU, which has synchronized with VSOM the server's status can be reset to clear the database inconsistent errors.

 

Solution:

To verify the problem check the recording_location table in the VSMS database to verify all of the video repositories are listed correctly by running the following database query:

# sudo /usr/BWhttpd/mysql/bin/mysql --defaults-file=/usr/BWhttpd/mysql/ums/ums.cnf UMS -e "select l.name,t.name as 'Type',s.name as 'state' from recording_location l, recording_location_type t, admin_states s where l.type = t.enum_value and l.admin_state = s.enum_value order by l.name,t.name;"

+----------+---------------+---------+
| name     | type          | state   |
+----------+---------------+---------+
| /media2  | media         | enabled |
| failover | remote_server | enabled |
+----------+---------------+---------+

 

++ To add the missing partitions, download the dbinconsistent.zip file attached below and upload the file to the VSM server.  Unzip the file and run the script on the server's VSMS database:

# unzip dbinconsistent.zip

# sudo /usr/BWhttpd/mysql/bin/mysql --defaults-file=/usr/BWhttpd/mysql/ums/ums.cnf UMS -e "delete from recording_location where name = 'failover';"
# sudo /usr/BWhttpd/mysql/bin/mysql --defaults-file=/usr/BWhttpd/mysql/ums/ums.cnf UMS < dbinconsistent.sql

 

Then restart the VSM software on the server.  When the server comes up and has synchronized with VSOM the server's status can be reset to clear the database inconsistent errors.

Hope this explanation helps you.


Thanks,

Jayesh

 

View solution in original post

I'm using WinSCP to transfer the zip file, but I don't see where you copied it to. Wherever I try I get "Access Denied"

You likely SFTP'd the file using the 'localadmin' account, which would place it in that accounts home dir..

[localadmin@VSM76COLO-1 ~]$ whoami
localadmin
[localadmin@VSM76COLO-1 ~]$ cd ~
[localadmin@VSM76COLO-1 ~]$ pwd

/var/lib/localadmin
[localadmin@VSM76COLO-1 ~]$

 

You'll want to sudo to root, then go retrieve the file and place it somewhere else like...

[localadmin@VSM76COLO-1 ~]$ ls -la
total 28

drwx------.  2 localadmin localadmin 4096 Jul 10 09:57 .
drwxr-xr-x. 33 root       root       4096 Jul  3 14:55 ..
-rw-------   1 localadmin localadmin  202 Jul  8 17:07 .bash_history
-rw-r--r--.  1 localadmin localadmin   18 Sep 25  2014 .bash_logout
-rw-r--r--.  1 localadmin localadmin  176 Sep 25  2014 .bash_profile
-rw-r--r--.  1 localadmin localadmin  124 Sep 25  2014 .bashrc
-rw-rw-r--   1 localadmin localadmin   69 Jul 10 09:57 dbinconsistent.zip
[localadmin@VSM76COLO-1 ~]$
sudo su -
[root@VSM76COLO-1 ~]# cd /var/lib/localadmin/
[root@VSM76COLO-1 localadmin]# mkdir /Patches.From.Cisco.For.Bugs.That.Arent.Bugs
[root@VSM76COLO-1 localadmin]# cp dbinconsistent.zip /Patches.From.Cisco.For.Bugs.That.Arent.Bugs/
[root@VSM76COLO-1 localadmin]# cd /Patches.From.Cisco.For.Bugs.That.Arent.Bugs/
[root@VSM76COLO-1 Patches.From.Cisco.For.Bugs.That.Arent.Bugs]# ls -la
total 16
drwxr-xr-x   2 root   root   4096 Jul 10 09:59 .
drwxr-xr-x. 25 nobody nobody 4096 Jul 10 09:58 ..
-rw-r--r--   1 root   root     69 Jul 10 09:59 dbinconsistent.zip
[root@VSM76COLO-1 Patches.From.Cisco.For.Bugs.That.Arent.Bugs]#

... then proceed with the typical instructions:

# unzip dbinconsistent.zip

# /usr/BWhttpd/mysql/bin/mysql --defaults-file=/usr/BWhttpd/mysql/ums/ums.cnf UMS -e "delete from recording_location where name = 'failover';"
# /usr/BWhttpd/mysql/bin/mysql --defaults-file=/usr/BWhttpd/mysql/ums/ums.cnf UMS < dbinconsistent.sql

 

 

 

Scott Olsen Solutions Specialist Bulletproof Solutions Inc. Web: www.bulletproofsi.com

Thanks Scott. That worked like a champ. I had to re-image a CIVS-MSP-2RU with 7.0.1, then upgrade to 7.5 and then to 7.6. I got the errors at 7.6. Cisco said that the CIVS servers aren't supported in 7.6, but they may work. So now I go from no archives working to archives working again. Great job.

LOL

Content for Community-Ad

This widget could not be displayed.