Showing results for 
Search instead for 
Did you mean: 

Error i18nHTMLMissing on RV220W


I just received and installed my RV220W today.  Everything was working fine.  I was down to configuring SSL VPN as my last step.  I was reading through the documentation and than went back to the management console to make a change.  The session timed out.  When it prompted me to login again I keep getting a message on the screen "i18nHTMLMissing", nothing else. (Ruby on Rails Error?)  I can't seem to login anymore.  All logins result in this message.  I have tried from multiple devices with the same result.

Any ideas would be greatly appreciated.  It took me awhile to get this router setup, I would hate to have to do a hard reset and start over.


Steven Perry

11 Replies 11

Servaas te Brake

Return the router if you still can.

It's no longer supported (at least that's what it looks like regarding Cisco's attitude towards it's customers


Have you tried a different browser? I seem to remember that this type of error has been experienced before.

Returning the router sounds extreme. Cisco DO support this router.


No new firmware in allmost a year for a router with known bugs in the current firmware is what I call "no longer supported"...

I wonder about support as well.  I do a search under the support site for RV220W and it finds nothing!  How is that possible if it is a supported device?  Also, why has noone from Cisco responded to this thread?  Do they not monitor the discussions?

I ended up doing a full reset of the router.  I have started reconfiguring all over again.  I finished everything except the VPN configuration.  I exported my config, just in case.

I have found the VPN configuration to be VERY confusing.  Am trying to work through it now, and pointers would be appreciated.

Dear Steven,

I apologize for the delay on our answer to your post and thank you for your time and patience.

Please find below a link for the RV220W admin guide where starting on page 104 you can check on VPN and Security configuration instructions;

Please do not hesitate to reach me back if anything comes up and/or if there is any further assistance I may help you with.

Kind regards,

Jeffrey Rodriguez S. .:|:.:|:.
Cisco Customer Support Engineer

*Please rate the Post so other will know when an answer has been found.

Jeffrey Rodriguez S. .:|:.:|:. Cisco Customer Support Engineer *Please rate the Post so other will know when an answer has been found.

Dear Jeffrey,


I have searched through the forums and found no answer to resolve such a critical issue (can't login with error "i18nHTMLMissing") 

May I know if you have any method to solve this? (I have tried different machines and browsers already) It seems the a/c is locked out and can't login with any password (correct or incorrect). 

Your answer and reply is much appreciated. 



PS: I have upgraded to the latest firmware already and I can still connect it via PPTP but can't login into the router web admin console. 




Please discontinue these RV routers. I feel kind of angry that I was able to buy one new with the misconception that it would be a quality, supported product.

If I wanted to waste my days doing hard-resets just because I'm using a part of a web UI that is apparently totally untested, I'd have stuck with the embarrasingly weak router I just replaced. I am now leaving work late, with the router in a state where it can't be accessed. Successful credentials with any of the administrator users results in redirect back to the login page but with the dreaded "i18nHTMLMissing" error.


This is insane. Back to a PC router box and OpenSWAN for us, I think.



Can you try an alternate browser? I was seeing this error with IE so I switched to Chrome and I have not seen it in almost a year. I know that doesn't resolve the underlying problem but it has made managing the router a whole lot easier for me.

- Marty

Hello Marty,

Thanks for your suggestion. I did try Google Chrome 32.0.1700.107 but the router is still inaccessible this morning.

Do you mean that avoiding Firefox/using Chrome is a work-around for you, or that it seems to prevent putting the router into this inaccessible state in the first place?

I'll have to stay back late again today to do the hard-reset out of office hours. One upside is that I'm still getting debug-level log events, if any of these are interesting to Cisco engineers I'd be happy to share them.

- Paul


I wish I could tell you more about the error. All I know is that when I stopped using IE and switched to Chrome it seemed to go away. I have also experienced the issue in our lab when I was testing different RV220Ws. In those cases I always just closed the browser and opened the GUI in a different one. One one or two occasions I had to reboot the router to get back in. It seems like I can recall having the issue more when I was in a rush and I clicked a new button before the page fully loaded. I have learned to be patient with the interface as it is very slow to load pages.

Is there anything about your configuration that you would consider unusual? I wonder if certain settings can cause the problem.

- Marty

Jiri Brejcha
Cisco Employee
Cisco Employee

This worked for me. I used Firefox 103.0.1 on macOS Monterey 12.5. To load the web UI, I needed to drop security requirements of the browser. Please make sure you change these to their original values after you are done.

1. E
nter about:config into the Firefox Address Bar
2. Search for security.ssl.errorReporting.automatic, select Boolean and False.
3. Search for security.tls.version.min and set it to 1.
4. Don't restart the browser. Enter the IP address of your router. The web UI now loads, and allows you to log in.
5. After you are done with web UI, please change both security settings from steps 2 and 3 to their original values.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: