Showing results for 
Search instead for 
Did you mean: 

WRVS4400N is interfering with Windows7 HomeGroup (NetBIOS?) on wireless links(?)


I have been using Windows7 (64bit) on all my network computers for some years now. One main computer is connected directly to the LAN port, and 4 via WLAN. Three more LAN ports are used for some VoIP equipment (non-Microsoft). All the Windows7 computers were connected via HomeGroup and were working impeccably. This was true as long as I used my old Linksys WRT150N Wireless-N router.
I recently decided to upgrade it to WRVS4400N so I would be able to use VPN for remote access. For the simplicity of the migration, I configured the WRVS4400N to have the same SSID and the same IP ports assigned exactly as it was on the WRT150N. I set only the default VLAN (I plan to add a second VLAN for guests that will be allowed to access the internet only), and I enabled WMM on the wireless, as I also have wireless VoIP handsets.

The swap was easy, and except for an issue I had with the “SIP Application Layer Gateway” that caused the WRVS4400N to hang, I had no issues. (I disabled the ALG as it was not really required).

After some time I noticed that I do not see all the HomeGroup computers, and I fail to communicate with them even when I enter \\hostname in the explorer address box. It worked well for a short period after I restarted both computers, but after a while I started having problems again. I thought that it would be wise to re-establish the HomeGroup, as there must be something different on the new network after all, and the old HomeGroup is not handling it well. So I had all my computers leave the HomeGroup, and I setup a new HomeGroup on the main computer. Now none of the other computers could join the new HomeGroup.
I contacted Cisco support, and the support person had me ping the ports, and claimed that if I can ping the ports, I could pass any other type of messages. This caused me to come to the conclusion that I must have somehow corrupted the Windows HomeGroup by resetting it. Especially since the Windows error message said “Windows cannot set a HomeGroup on this computer”. I spent two days on the Windows forums and tried all the tricks they suggested to recover the HomeGroup, but all failed. The other computers would not connect to the new HomeGroup, and in some cases they did not even recognize that there is a HomeGroup already set on the other computer.
Finally it crossed my mind to try to connect the Windows computers back to the old WRT150N. Once the computers were connected back to the WRT150N it took me just seconds to have all the computers join the HomeGroup with no issue whatsoever.
So now I am back to square one. The computers are connected to the WRVS4400N and have trouble connecting with sometime after they are booted. And I also learned a few things:

  1. The Windows7 HomeGroup has no bugs I could blame.
  2. The WRVS4400N interfered with the messages that had to take place between the computers, and thus prevented them from joining the HomeGroup. The WRT150N handled these messages correctly.
  3. The WRVS4400N’s interference with these type of messages (NetBIOS?) is causing the computers to be unreachable after a while.
  4. I have not tried to connect more than one computer to the LAN port, so I don’t know that for sure, but from looking at many other discussions, this may be a problem that is unique to the wireless link of the router. I also learned from these forum messages, that my problem might be a common problem to more models, and even more makes of wireless routers.

So here is the question: what functionality is missing or got corrupted on the new models (such as my WRVS4400N) that the old models (such as the WRT150N) could handle correctly, and is there a setup configuration or parameter that need to be set, that could solve this issue. Your input and support would be appreciated.

21 Replies 21

Frequent Contributor
Frequent Contributor


I wanted to ask what have you tried changing on the router? anything?

Disable IPS and test? repost results.

Also test with two clients on the LAN ports this way we can verify it's wireless problem or both.

Next you can change Netbios broadcast over TCP and test.

Only make one change at a time and then test, this way we know what fixed the issue if it changing a setting did resolve it.



Thank you for your support.

I have tested the LAN, and I can now say that this is NOT a wireless issue. I got the same problem on wired LAN (could not join the HomeGroup over the LAN as well).

As you reque