07-01-2017 08:02 AM - edited 03-05-2019 08:47 AM
Hello all,
I am having some trouble configuring an ADSL connection on a Cisco 1921. The DSL line is coming into a modem and I had setup the in bridge mode, and connected it to Ge0/1 on the 1921 configured a dialer interface with the ADSL details, default route to dialer interface, added the dialer group to ge0/1.
Not sure what step I'm missing. when I enabled various debugging for pppoe and ppp I don't even get any events showing it attempting to dial. I know my ADSL credentials and service are correct because I can set it up fine in the bridge modem.
Here is the config and version below.
Current configuration : 6633 bytes
!
! Last configuration change at 17:59:18 AEST Fri Jun 30 2017 by ittelligent
version 15.2
service timestamps debug datetime msec
service timestamps log datetime localtime show-timezone
no service password-encryption
!
!
boot-start-marker
boot-end-marker
!
!
no logging console
!
no aaa new-model
clock timezone AEST 10 0
clock summer-time AEDT recurring 1 Sun Oct 2:00 1 Sun Apr 3:00
!
ip cef
!
!
!
ip dhcp excluded-address 192.168.99.1 192.168.99.10
ip dhcp excluded-address 192.168.99.150 192.168.99.220
ip dhcp excluded-address 10.10.30.1 10.10.30.20
ip dhcp excluded-address 172.16.0.1 172.16.0.10
ip dhcp excluded-address 10.10.30.200 10.10.30.254
!
ip dhcp pool Data.Pool
network 10.10.30.0 255.255.255.0
default-router 10.10.30.1
dns-server 10.10.30.20 8.8.8.8
domain-name local.ducere.co
option 150 ip 192.168.99.180
lease 8
!
ip dhcp pool Voice.Pool
network 192.168.99.0 255.255.255.0
dns-server 192.168.99.1
default-router 192.168.99.1
domain-name Voice.Pool
option 150 ip 192.168.99.180
lease 8
!
ip dhcp pool unifytest
network 172.16.0.0 255.255.255.0
default-router 172.16.0.1
dns-server 172.16.0.1
!
!
!
ip domain name local.ducere.co
ip host DUC-VME-ESXi-02 10.10.30.10
ip host DUC-VME-ESXi-01 10.10.30.11
ip host DUC-VME-SVR-01 10.10.30.20
ip name-server 10.10.30.20
ip name-server 8.8.8.8
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
license udi pid CISCO1921/K9 sn FGL1825205L
!
!
redundancy
!
!
!
!
!
ip ssh version 2
!
class-map match-all SWC-MAC_MINI
match access-group name SWA-MAC_MINI
!
policy-map SWP-SHAPE
class SWC-MAC_MINI
priority 100000
class class-default
fair-queue
policy-map WAN_SHAPE
class class-default
police 20000000
!
!
!
!
!
!
bridge irb
!
!
!
!
interface Tunnel0
description OpusV
ip address 10.0.255.26 255.255.255.252
shutdown
tunnel source 103.232.216.1
tunnel destination 220.244.63.158
!
interface Tunnel1
description Ducere-161Collins
ip address 172.30.0.1 255.255.255.252
ip mtu 1400
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 7
tunnel source 103.232.216.1
tunnel destination 203.191.199.250
!
interface Tunnel2
description MatJacobson-Home
ip address 172.30.0.5 255.255.255.252
ip mtu 1400
tunnel source 103.232.216.1
tunnel destination 120.148.224.55
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
description DUC-2960-001_Gi1/0/46
no ip address
ip tcp adjust-mss 1360
duplex auto
speed auto
!
interface GigabitEthernet0/0.1
description subIF_UniFiAPMgt
encapsulation dot1Q 1 native
ip address 172.16.0.2 255.255.255.0
ip nat inside
ip virtual-reassembly in
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 7
vrrp 1 ip 172.16.0.1
vrrp 1 timers advertise 3
vrrp 1 authentication md5 key-string
!
interface GigabitEthernet0/0.30
description subIF_OfficeData
encapsulation dot1Q 30
ip address 10.10.30.2 255.255.255.0
ip helper-address 192.168.99.180
ip accounting output-packets
ip nat inside
ip virtual-reassembly in
ip ospf authentication message-digest
vrrp 2 ip 10.10.30.1
vrrp 2 timers advertise 3
vrrp 2 authentication md5 key-string
!
interface GigabitEthernet0/0.99
description subIF_CiscoVoice
encapsulation dot1Q 99
ip address 192.168.99.1 255.255.255.0
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
pppoe enable group global
pppoe-client dial-pool-number 1
no cdp enable
!
interface Dialer0
description OUTSIDE_INTERFACE
mtu 1492
ip address negotiated
ip nat outside
ip virtual-reassembly in
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication pap chap callin
ppp pap sent-username user@domain password 0 ADSLPASSWORD
ppp ipcp route default
no cdp enable
!
interface Dialer1
no ip address
!
interface BVI1
no ip address
!
router ospf 1
area 0 authentication message-digest
passive-interface default
no passive-interface Tunnel1
network 10.10.30.1 0.0.0.0 area 0
network 172.16.0.1 0.0.0.0 area 0
network 172.30.0.1 0.0.0.0 area 0
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip dns server
ip nat inside source list 30 interface GigabitEthernet0/1 overload
ip nat inside source static tcp 10.10.30.9 21 103.232.216.1 21 extendable
ip nat inside source static tcp 10.10.30.9 80 103.232.216.1 80 extendable
ip nat inside source static udp 172.30.0.6 161 103.232.216.1 164 extendable
ip nat inside source static tcp 10.10.30.9 443 103.232.216.1 443 extendable
ip nat inside source static udp 10.10.30.3 161 103.232.216.1 1610 extendable
ip nat inside source static tcp 10.10.30.20 1723 103.232.216.1 1723 extendable
ip nat inside source static tcp 10.10.30.9 22 103.232.216.1 2222 extendable
ip nat inside source static tcp 10.10.30.20 3389 103.232.216.1 3389 extendable
ip nat inside source static tcp 10.10.30.13 3389 103.232.216.1 3390 extendable
ip nat inside source static tcp 10.10.30.3 5060 103.232.216.1 5060 extendable
ip nat inside source static udp 10.10.30.3 5060 103.232.216.1 5060 extendable
ip nat inside source static tcp 10.10.30.13 6556 103.232.216.1 6556 extendable
ip nat inside source static tcp 10.10.30.20 6556 103.232.216.1 6600 extendable
ip route 0.0.0.0 0.0.0.0 Dialer0
ip route 10.10.24.0 255.255.255.0 Tunnel2
ip route 192.168.1.0 255.255.255.0 GigabitEthernet0/1
!
ip access-list extended SWA-MAC_MINI
permit ip any host 10.10.30.9
permit ip host 10.10.30.9 any
!
logging host 103.20.20.27
access-list 14 permit 103.20.20.27
access-list 30 permit 172.30.0.6
access-list 30 permit 10.10.30.0 0.0.0.255
access-list 30 permit 172.16.0.0 0.0.0.255
access-list 30 permit 10.10.24.0 0.0.0.255
access-list 30 permit 192.168.1.0 0.0.0.255
access-list 50 permit 103.20.20.27
!
!
snmp-server location Russell St Melbourne Victoria Australia
snmp-server contact MikeIT +613-90290431
snmp-server chassis-id DUC-VME-RTR-02
snmp-server enable traps entity-sensor threshold
!
control-plane
!
bridge 1 protocol ieee
bridge 1 route ip
!
!
line con 0
exec-timeout 90 0
logging synchronous
login local
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
exec-timeout 90 0
logging synchronous
login local
transport input ssh
!
scheduler allocate 20000 1000
ntp master 5
ntp server 10.10.30.20
ntp server au.pool.ntp.org source GigabitEthernet0/0.30
!
End
Cisco 1921 Show Version
Cisco IOS Software, C1900 Software (C1900-UNIVERSALK9-M), Version 15.2(4)M6, RELEASE SOFTWARE (fc2)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2014 by Cisco Systems, Inc.
Compiled Wed 19-Mar-14 11:56 by prod_rel_team
ROM: System Bootstrap, Version 15.0(1r)M16, RELEASE SOFTWARE (fc1)
uptime is 7 hours, 31 minutes
System returned to ROM by power-on
System restarted at 14:18:01 AEST Fri Jun 30 2017
System image file is "usbflash0:c1900-universalk9-mz.SPA.152-4.M6.bin"
Last reload type: Normal Reload
Last reload reason: power-on
This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.
A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html
If you require further assistance please contact us by sending email to
Cisco CISCO1921/K9 (revision 1.0) with 491520K/32768K bytes of memory.
Processor board ID FGL1825205L
2 Gigabit Ethernet interfaces
1 terminal line
1 Virtual Private Network (VPN) Module
DRAM configuration is 64 bits wide with parity disabled.
255K bytes of non-volatile configuration memory.
249840K bytes of USB Flash usbflash0 (Read/Write)
License Info:
License UDI:
-------------------------------------------------
Device# PID SN
-------------------------------------------------
*0 CISCO1921/K9
Technology Package License Information for Module:'c1900'
-----------------------------------------------------------------
Technology Technology-package Technology-package
Current Type Next reboot
------------------------------------------------------------------
ipbase ipbasek9 Permanent ipbasek9
security securityk9 Permanent securityk9
data None None None
Configuration register is 0x2102
07-01-2017 11:28 AM
Hi,
Can you setup on your Dialer interface chap authentication with these commands:
ppp chap hostname user@domain
ppp chap password 0 ADSLPASSWORD
If this still doesn't work please run the following debugs and paste the result into a text file:
debug ppp authentication
debug ppp negotiation
debug ppp packet
debug ppp error
Not every debug might be needed but to avoid doing back and forth it will be better to get all information in 1 shot .
Thanks
PS: Please don't forget to rate and mark as correct answer if this answered your question
07-01-2017 01:54 PM
Hello,
you don't need any bridge commands, since none of your interfaces is in a bridge group. If you put your modem in bridge mode, your router effectively becomes the Internet edge device.
I have made some changes (marked in bold), implement those and see if you get your connection to work:
Current configuration : 6633 bytes
!
! Last configuration change at 17:59:18 AEST Fri Jun 30 2017 by ittelligent
version 15.2
service timestamps debug datetime msec
service timestamps log datetime localtime show-timezone
no service password-encryption
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
clock timezone AEST 10 0
clock summer-time AEDT recurring 1 Sun Oct 2:00 1 Sun Apr 3:00
!
ip cef
!
ip dhcp excluded-address 192.168.99.1 192.168.99.10
ip dhcp excluded-address 192.168.99.150 192.168.99.220
ip dhcp excluded-address 10.10.30.1 10.10.30.20
ip dhcp excluded-address 172.16.0.1 172.16.0.10
ip dhcp excluded-address 10.10.30.200 10.10.30.254
!
ip dhcp pool Data.Pool
network 10.10.30.0 255.255.255.0
default-router 10.10.30.1
dns-server 10.10.30.20 8.8.8.8
domain-name local.ducere.co
option 150 ip 192.168.99.180
lease 8
!
ip dhcp pool Voice.Pool
network 192.168.99.0 255.255.255.0
dns-server 192.168.99.1
default-router 192.168.99.1
domain-name Voice.Pool
option 150 ip 192.168.99.180
lease 8
!
ip dhcp pool unifytest
network 172.16.0.0 255.255.255.0
default-router 172.16.0.1
dns-server 172.16.0.1
!
ip domain name local.ducere.co
ip host DUC-VME-ESXi-02 10.10.30.10
ip host DUC-VME-ESXi-01 10.10.30.11
ip host DUC-VME-SVR-01 10.10.30.20
ip name-server 10.10.30.20
ip name-server 8.8.8.8
no ipv6 cef
!
multilink bundle-name authenticated
!
license udi pid CISCO1921/K9 sn FGL1825205L
!
redundancy
!
ip ssh version 2
!
class-map match-all SWC-MAC_MINI
match access-group name SWA-MAC_MINI
!
policy-map SWP-SHAPE
class SWC-MAC_MINI
priority 100000
class class-default
fair-queue
policy-map WAN_SHAPE
class class-default
police 20000000
!
no bridge irb
!
interface Tunnel0
description OpusV
ip address 10.0.255.26 255.255.255.252
shutdown
tunnel source 103.232.216.1
tunnel destination 220.244.63.158
!
interface Tunnel1
description Ducere-161Collins
ip address 172.30.0.1 255.255.255.252
ip mtu 1400
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 7
tunnel source 103.232.216.1
tunnel destination 203.191.199.250
!
interface Tunnel2
description MatJacobson-Home
ip address 172.30.0.5 255.255.255.252
ip mtu 1400
tunnel source 103.232.216.1
tunnel destination 120.148.224.55
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
description DUC-2960-001_Gi1/0/46
no ip address
ip tcp adjust-mss 1360
duplex auto
speed auto
!
interface GigabitEthernet0/0.1
description subIF_UniFiAPMgt
encapsulation dot1Q 1 native
ip address 172.16.0.2 255.255.255.0
ip nat inside
ip virtual-reassembly in
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 7
vrrp 1 ip 172.16.0.1
vrrp 1 timers advertise 3
vrrp 1 authentication md5 key-string
!
interface GigabitEthernet0/0.30
description subIF_OfficeData
encapsulation dot1Q 30
ip address 10.10.30.2 255.255.255.0
ip helper-address 192.168.99.180
ip accounting output-packets
ip nat inside
ip virtual-reassembly in
ip ospf authentication message-digest
vrrp 2 ip 10.10.30.1
vrrp 2 timers advertise 3
vrrp 2 authentication md5 key-string
!
interface GigabitEthernet0/0.99
description subIF_CiscoVoice
encapsulation dot1Q 99
ip address 192.168.99.1 255.255.255.0
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
pppoe enable group global
pppoe-client dial-pool-number 1
no cdp enable
!
interface Dialer0
description OUTSIDE_INTERFACE
mtu 1492
ip address negotiated
ip nat outside
ip virtual-reassembly in
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication pap chap callin
ppp pap sent-username user@domain password 0 ADSLPASSWORD
ppp ipcp route default
no cdp enable
!
interface Dialer1
no ip address
!
interface BVI1
no ip address
!
router ospf 1
area 0 authentication message-digest
passive-interface default
no passive-interface Tunnel1
network 10.10.30.1 0.0.0.0 area 0
network 172.16.0.1 0.0.0.0 area 0
network 172.30.0.1 0.0.0.0 area 0
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip dns server
ip nat inside source list 30 interface Dialer0 overload
ip nat inside source static tcp 10.10.30.9 21 103.232.216.1 21 extendable
ip nat inside source static tcp 10.10.30.9 80 103.232.216.1 80 extendable
ip nat inside source static udp 172.30.0.6 161 103.232.216.1 164 extendable
ip nat inside source static tcp 10.10.30.9 443 103.232.216.1 443 extendable
ip nat inside source static udp 10.10.30.3 161 103.232.216.1 1610 extendable
ip nat inside source static tcp 10.10.30.20 1723 103.232.216.1 1723 extendable
ip nat inside source static tcp 10.10.30.9 22 103.232.216.1 2222 extendable
ip nat inside source static tcp 10.10.30.20 3389 103.232.216.1 3389 extendable
ip nat inside source static tcp 10.10.30.13 3389 103.232.216.1 3390 extendable
ip nat inside source static tcp 10.10.30.3 5060 103.232.216.1 5060 extendable
ip nat inside source static udp 10.10.30.3 5060 103.232.216.1 5060 extendable
ip nat inside source static tcp 10.10.30.13 6556 103.232.216.1 6556 extendable
ip nat inside source static tcp 10.10.30.20 6556 103.232.216.1 6600 extendable
ip route 0.0.0.0 0.0.0.0 Dialer0
ip route 10.10.24.0 255.255.255.0 Tunnel2
ip route 192.168.1.0 255.255.255.0 GigabitEthernet0/1
!
ip access-list extended SWA-MAC_MINI
permit ip any host 10.10.30.9
permit ip host 10.10.30.9 any
!
logging host 103.20.20.27
access-list 14 permit 103.20.20.27
access-list 30 permit 172.30.0.6
access-list 30 permit 10.10.30.0 0.0.0.255
access-list 30 permit 172.16.0.0 0.0.0.255
access-list 30 permit 10.10.24.0 0.0.0.255
access-list 30 permit 192.168.1.0 0.0.0.255
access-list 50 permit 103.20.20.27
!
snmp-server location Russell St Melbourne Victoria Australia
snmp-server contact MikeIT +613-90290431
snmp-server chassis-id DUC-VME-RTR-02
snmp-server enable traps entity-sensor threshold
!
control-plane
!
no bridge 1 protocol ieee
no bridge 1 route ip
!
line con 0
exec-timeout 90 0
logging synchronous
login local
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
exec-timeout 90 0
logging synchronous
login local
transport input ssh
!
scheduler allocate 20000 1000
ntp master 5
ntp server 10.10.30.20
ntp server au.pool.ntp.org source GigabitEthernet0/0.30
!
End
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide