cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
4134
Views
0
Helpful
23
Replies
Highlighted
Beginner

876W Router: internet wired but no wireless internet, need help configuring

For a long time now I try to get my 876 Wireless Router configured but I do not succeed. (I'm just a cisco loving amateur so please respect my poor knowledge)

Problem is that I got the router setup for internet connection but only wired. Now I have a configuration in which I also succeed to make a wireless connection. Only the problem is that the wireless connection does not get to the internet.

Next to some other minor looking problems that will be the main thing!

I tried several helpfull tools as CCP and some sites which gave a Form-template on the internet or a Excel-sheet to fill in. All those did not function for me.

Now I hope there will be someone out there who is willing to have a look at my running-config and give me a helping hand.

Thanks in advance,

Emil

Building configuration...

Current configuration : 6294 bytes

!

! Last configuration change at 03:55:22 UTC Thu Apr 29 2010 by Router876W

!

version 15.0

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname yourname

!

boot-start-marker

boot-end-marker

!

logging buffered 51200 warnings

!

no aaa new-model

!

!

!

crypto pki trustpoint TP-self-signed-1959697149

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-1959697149

revocation-check none

rsakeypair TP-self-signed-1959697149

!

!

crypto pki certificate chain TP-self-signed-1959697149

certificate self-signed 01

<KEY-FOLLOWS-HERE>


   quit

dot11 syslog

!

dot11 ssid 876W

vlan 1

authentication open

authentication key-management wpa

wpa-psk ascii 0 <MYKEY>

!

ip source-route

!

!

ip dhcp excluded-address 10.10.10.1

!

ip dhcp pool ccp-pool

   import all

   network 10.10.10.0 255.255.255.248

   default-router 10.10.10.1

   lease 0 2

!

!

ip cef

no ip domain lookup

ip domain name yourdomain.com

no ipv6 cef

!

multilink bundle-name authenticated

!

!

!

username Router876W privilege 15 secret 5 <MYSECRET>

!

!

!

interface BRI0

no ip address

encapsulation hdlc

shutdown

!

!

interface ATM0

no ip address

no atm ilmi-keepalive

!

!

interface ATM0.1 point-to-point

pvc 8/48

  encapsulation aal5mux ppp dialer

  dialer pool-member 1

!

!

interface FastEthernet0

!

!

interface FastEthernet1

!

!

interface FastEthernet2

!

!

interface FastEthernet3

!

!

interface Dot11Radio0

no ip address

!

encryption vlan 1 mode ciphers aes-ccm tkip

!

broadcast-key vlan 1 change 30

!

!

ssid 876W

!

mbssid

speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0

station-role root

!

!

interface Dot11Radio0.1

encapsulation dot1Q 1 native

no cdp enable

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 spanning-disabled

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

!

interface Vlan1

description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$

ip address 10.10.10.1 255.255.255.0

ip nat inside

ip virtual-reassembly

ip tcp adjust-mss 1452

!

!

interface Dialer0

ip address <MY-ISPGIVEN-FIX-IPADDRESS> 255.255.255.0

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 1

dialer-group 1

ppp authentication pap callin

ppp pap sent-username <MYUSERNAME> password 0 <MYPASS>

no cdp enable

!

!

ip forward-protocol nd

ip http server

ip http access-class 23

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!

!

ip nat inside source list 1 interface Dialer0 overload

ip route 0.0.0.0 0.0.0.0 Dialer0

!

access-list 1 remark INSIDE_IF=Vlan1

access-list 1 remark CCP_ACL Category=2

access-list 1 permit 10.10.10.0 0.0.0.7

access-list 23 permit 10.10.10.0 0.0.0.7

dialer-list 1 protocol ip permit

no cdp run

!

control-plane

!

line con 0

login local

no modem enable

line aux 0

line vty 0 4

access-class 23 in

privilege level 15

login local

transport input telnet ssh

!

scheduler max-task-time 5000

end

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Glad to hear it   Sometimes a reboot is all that's needed, especially when nothing else makes sense! LOL! If you would, please rate this post so others can find it if needed.....

Thanks!

John

HTH, John *** Please rate all useful posts ***

View solution in original post

23 REPLIES 23
Highlighted
Engager

Hi

Once you are connected using the wireless connection are you able to resolve any of the website hostaddress (ex.www.cisco.com), when you try to ping any of the outside world host are you able to see the resolution happening (from the web address to ip address).

You can try pushing the dns server details as part of the dhcp config so that the client pcs can use that dns for resolution.

Your SP might have given the DNS addresses which you can make use of here to get configured under the ip dhcp pool ccp-pool group.

regds

Highlighted

Thank you very much for your support.

Sorry it took some time to answer: there are some weard things happening as I can ping in a dos command but not with terraterm over my usb/serial connection with the router. That also makes that I see differences in my running config which I tried to upload to my computer.

Never mind; although I have internet connection without the DNS in my config, as I see now in my config as you found out, I added ip domain-lookup and ip name servers from my ISP.

Everything stays the same. I can still ping into the world wihtin my DOS prompt but not with my console connection.

And for the Wireless problem: nothing has changed. Still I can connect wireless but I have no internet connection with wireless.

Any other suggestions/ ideas?

Highlighted

can you post the output of ipconfig /all when connected to the ethernet and onto the wireless?

are you manually assigning ip address & dns when connecting through the ethernet port ?

regds

Highlighted

Starting with your last question: Yes I assing them manually.

Sorry that I don't know if I have to give my answers in the attachments or just paste them here, but here they are pasted anyhow. The ipconfig is from my Laptop but I also cannot connect with my Iphone which I also give a manual IP / Mask configuration and DNS addresses.

>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>


Windows IP-configuratie

   Hostnaam  . . . . . . . . . . . . : Vostro1700
   Primair DNS-achtervoegsel . . . . :
   Knooppunttype . . . . . . . . . . : hybride
   IP-routering ingeschakeld . . . . : nee
   WINS-proxy ingeschakeld . . . . . : nee

Draadloos LAN-adapter voor Wireless Network Connection:

   Mediumstatus. . . . . . . . . . . : medium ontkoppeld
   Verbindingsspec. DNS-achtervoegsel:
   Beschrijving. . . . . . . . . . . : Intel(R) Wireless WiFi Link 4965AGN
   Fysiek adres. . . . . . . . . . . : 00-1F-3B-12-D0-C5
   DHCP ingeschakeld . . . . . . . . : nee
   Autom. configuratie ingeschakeld  : ja

Ethernet-adapter voor Local Area Connection:

   Verbindingsspec. DNS-achtervoegsel:
   Beschrijving. . . . . . . . . . . : Broadcom 440x 10/100 Integrated Controlle
r
   Fysiek adres. . . . . . . . . . . : 00-1D-09-C4-C1-11
   DHCP ingeschakeld . . . . . . . . : nee
   Autom. configuratie ingeschakeld  : ja
   Link-local IPv6-adres . . . . . . : fe80::a0f6:181e:5de0:93d6%11(voorkeur)
   IPv4-adres. . . . . . . . . . . . : 10.10.10.4(voorkeur)
   Subnetmasker. . . . . . . . . . . : 255.255.255.0
   Standaardgateway. . . . . . . . . : 10.10.10.1
   DHCPv6 IAID . . . . . . . . . . . : 234888457
   DHCPv6-client DUID. . . . . . . . : 00-01-00-01-13-47-2B-61-00-1D-09-C4-C1-11

   DNS-servers . . . . . . . . . . . : 195.121.1.34
                                       195.121.1.66
   NetBIOS via TCPIP . . . . . . . . : ingeschakeld

Tunnel-adapter voor isatap.{4437E7D3-F10B-40A0-A997-8AD3F7C0CD54}:

   Mediumstatus. . . . . . . . . . . : medium ontkoppeld
   Verbindingsspec. DNS-achtervoegsel:
   Beschrijving. . . . . . . . . . . : Microsoft ISATAP Adapter
   Fysiek adres. . . . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP ingeschakeld . . . . . . . . : nee
   Autom. configuratie ingeschakeld  : ja

Tunnel-adapter voor isatap.{5F991D0E-5E7D-47A5-8C14-ECD88711BD5D}:

   Mediumstatus. . . . . . . . . . . : medium ontkoppeld
   Verbindingsspec. DNS-achtervoegsel:
   Beschrijving. . . . . . . . . . . : Microsoft ISATAP Adapter #2
   Fysiek adres. . . . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP ingeschakeld . . . . . . . . : nee
   Autom. configuratie ingeschakeld  : ja

Tunnel-adapter voor Teredo Tunneling Pseudo-Interface:

   Verbindingsspec. DNS-achtervoegsel:
   Beschrijving. . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
   Fysiek adres. . . . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP ingeschakeld . . . . . . . . : nee
   Autom. configuratie ingeschakeld  : ja
   IPv6-adres. . . . . . . . . . . . : 2001:0:5ef5:73bc:2408:184e:2af5:78bf(voor
keur)
   Link-local IPv6-adres . . . . . . : fe80::2408:184e:2af5:78bf%14(voorkeur)
   Standaardgateway. . . . . . . . . : ::
   NetBIOS via TCPIP . . . . . . . . : uitgeschakeld

Tunnel-adapter voor Reusable ISATAP Interface {4AD2C90B-FD2C-41C7-98E6-6E1DE4977
EE7}:

   Mediumstatus. . . . . . . . . . . : medium ontkoppeld
   Verbindingsspec. DNS-achtervoegsel:
   Beschrijving. . . . . . . . . . . : Microsoft ISATAP Adapter #4
   Fysiek adres. . . . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP ingeschakeld . . . . . . . . : nee
   Autom. configuratie ingeschakeld  : ja


>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>


Windows IP-configuratie

   Hostnaam  . . . . . . . . . . . . : Vostro1700
   Primair DNS-achtervoegsel . . . . :
   Knooppunttype . . . . . . . . . . : hybride
   IP-routering ingeschakeld . . . . : nee
   WINS-proxy ingeschakeld . . . . . : nee

Draadloos LAN-adapter voor Wireless Network Connection:

   Verbindingsspec. DNS-achtervoegsel:
   Beschrijving. . . . . . . . . . . : Intel(R) Wireless WiFi Link 4965AGN
   Fysiek adres. . . . . . . . . . . : 00-1F-3B-12-D0-C5
   DHCP ingeschakeld . . . . . . . . : nee
   Autom. configuratie ingeschakeld  : ja
   Link-local IPv6-adres . . . . . . : fe80::b02d:6dcb:23cc:7d9e%12(voorkeur)
   IPv4-adres. . . . . . . . . . . . : 10.10.10.3(voorkeur)
   Subnetmasker. . . . . . . . . . . : 255.255.255.0
   Standaardgateway. . . . . . . . . : 10.10.10.1
   DHCPv6 IAID . . . . . . . . . . . : 218111803
   DHCPv6-client DUID. . . . . . . . : 00-01-00-01-13-47-2B-61-00-1D-09-C4-C1-11

   DNS-servers . . . . . . . . . . . : 195.121.1.34
                                       195.121.1.66
   NetBIOS via TCPIP . . . . . . . . : ingeschakeld

Ethernet-adapter voor Local Area Connection:

   Mediumstatus. . . . . . . . . . . : medium ontkoppeld
   Verbindingsspec. DNS-achtervoegsel:
   Beschrijving. . . . . . . . . . . : Broadcom 440x 10/100 Integrated Controlle
r
   Fysiek adres. . . . . . . . . . . : 00-1D-09-C4-C1-11
   DHCP ingeschakeld . . . . . . . . : nee
   Autom. configuratie ingeschakeld  : ja

Tunnel-adapter voor isatap.{4437E7D3-F10B-40A0-A997-8AD3F7C0CD54}:

   Mediumstatus. . . . . . . . . . . : medium ontkoppeld
   Verbindingsspec. DNS-achtervoegsel:
   Beschrijving. . . . . . . . . . . : Microsoft ISATAP Adapter
   Fysiek adres. . . . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP ingeschakeld . . . . . . . . : nee
   Autom. configuratie ingeschakeld  : ja

Tunnel-adapter voor isatap.{5F991D0E-5E7D-47A5-8C14-ECD88711BD5D}:

   Mediumstatus. . . . . . . . . . . : medium ontkoppeld
   Verbindingsspec. DNS-achtervoegsel:
   Beschrijving. . . . . . . . . . . : Microsoft ISATAP Adapter #2
   Fysiek adres. . . . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP ingeschakeld . . . . . . . . : nee
   Autom. configuratie ingeschakeld  : ja

Tunnel-adapter voor Teredo Tunneling Pseudo-Interface:

   Mediumstatus. . . . . . . . . . . : medium ontkoppeld
   Verbindingsspec. DNS-achtervoegsel:
   Beschrijving. . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
   Fysiek adres. . . . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP ingeschakeld . . . . . . . . : nee
   Autom. configuratie ingeschakeld  : ja

Tunnel-adapter voor Reusable ISATAP Interface {4AD2C90B-FD2C-41C7-98E6-6E1DE4977
EE7}:

   Mediumstatus. . . . . . . . . . . : medium ontkoppeld
   Verbindingsspec. DNS-achtervoegsel:
   Beschrijving. . . . . . . . . . . : Microsoft ISATAP Adapter #4
   Fysiek adres. . . . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP ingeschakeld . . . . . . . . : nee
   Autom. configuratie ingeschakeld  : ja

Message was edited by: Emil Heilbron Sorry messed it up in copying. Now it is right.

Highlighted
Advisor

Try this:

bridge irb

You'll want to remove the address from vlan 1 and add the internal address that's assigned to the vlan to the bvi:

int bvi1

ip address  10.10.10.1 255.255.255.0

ip nat inside

ip virtual-reassembly

ip  tcp adjust-mss 1452

Then add:

int vlan 1

bridge-group 1

HTH,

John

HTH, John *** Please rate all useful posts ***
Highlighted

ip  tcp adjust-mss 1452

That is not neded, because OP has PPP, not PPPoE.

Highlighted

Sorry, need to reply to John

Message was edited by: Emil Heilbron

Highlighted
Advisor

You'll need to enable bridging first:

bridge irb

That should create your bvi interface.....

John

HTH, John *** Please rate all useful posts ***
Highlighted

Thanks,

So I leaf the thing whit ip tcp adjust-mss out as Bevilacqua suggested.

And I made the bridge with your bridge irb command which gives me a next error:

yourname(config-if)#ip address  10.10.10.1 255.255.255.0 % 10.10.10.0 overlaps with Vlan1

How to get rid of that please ..

Highlighted
Advisor

You need to remove the ip address from the vlan interface first:

int vlan 1

no ip address

bridge-group 1

int bvi1

HTH, John *** Please rate all useful posts ***
Highlighted

Oops. I did as you guys suggested. But now it is not possible anymore to ping from Laptop to router, nor is it possible from console to ping to internet. So all connections are gone. Good luck I have a funtioning not wireless 876 to still connect.

Any suggestions what went wrong? And even how to solve this even bigger problem

So what I did is the combination of your advices. Toke away the Vlan 1 and added the bridge with the same 10.10.10.10/ 24

Highlighted

Post your config....

And you said that you "added the same 10.10.10.10/24."

The original address in the config is 10.10.10.1 255.255.255.0. Is that a typo?

HTH, John *** Please rate all useful posts ***
Highlighted

Sorry, yes a typo. I added the same (10.10.10.1/ 24)

Here comes the running-config:

yourname#sh run
Building configuration...

Current configuration : 6480 bytes
!
! Last configuration change at 08:43:42 UTC Thu Apr 29 2010 by Router876W
!
version 15.0
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname yourname
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
!
aaa new-model
!
!
aaa authentication login default local
!

!
aaa session-id common
!

!
crypto pki trustpoint TP-self-signed-1959697149
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-1959697149
revocation-check none
rsakeypair TP-self-signed-1959697149
!
!
crypto pki certificate chain TP-self-signed-1959697149
certificate self-signed 01
  3082024F 308201B8 A0030201 02020101 300D0609 2A864886 F70D0101 04050030

        quit
dot11 syslog
!
dot11 ssid 876W
vlan 1
authentication open
authentication key-management wpa
wpa-psk ascii 0
!
ip source-route
!
!
ip dhcp excluded-address 10.10.10.1
!
ip dhcp pool ccp-pool
   import all
   network 10.10.10.0 255.255.255.248
   default-router 10.10.10.1
   lease 0 2
!
!
ip cef
ip domain name yourdomain.com
ip name-server 195.121.1.66
ip name-server 195.121.1.34
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
username Router876W privilege 15 secret 5
!
!
!
bridge irb
!
!
!
interface BRI0
no ip address
encapsulation hdlc
shutdown
!
!
interface ATM0
no ip address
no atm ilmi-keepalive
!
!
interface ATM0.1 point-to-point
pvc 8/48
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
!
!
interface FastEthernet0
!
!
interface FastEthernet1
!
!
interface FastEthernet2
!
!
interface FastEthernet3
!
!
interface Dot11Radio0
no ip address
!
encryption vlan 1 mode ciphers aes-ccm tkip
!
broadcast-key vlan 1 change 30
!
!
ssid 876W
!
mbssid
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
station-role root
!
!
interface Dot11Radio0.1
encapsulation dot1Q 1 native
no cdp enable
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 spanning-disabled
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
!
interface Vlan1
description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$
no ip address
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1452
bridge-group 1
!
!
interface Dialer0
ip address 255.255.255.0
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication pap callin
ppp pap sent-username password 0
no cdp enable
!
!
interface BVI1
ip address 10.10.10.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
!
ip forward-protocol nd
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
!
ip nat inside source list 1 interface Dialer0 overload
ip route 0.0.0.0 0.0.0.0 Dialer0
!
access-list 1 remark INSIDE_IF=Vlan1
access-list 1 remark CCP_ACL Category=2
access-list 1 permit 10.10.10.0 0.0.0.7
access-list 23 permit 10.10.10.0 0.0.0.7
dialer-list 1 protocol ip permit
no cdp run

!
!
control-plane
!
!
!
line con 0
no modem enable
line aux 0
line vty 0 4
access-class 23 in
privilege level 15
transport input telnet ssh
!
scheduler max-task-time 5000
end

Highlighted

Try putting:

bridge 1 route ip

Also, can you get an association with the AP and get an address? Can you ping the 10.10.10.1 address after you associate? And remove the "ip tcp adjust-mss 1452" from vlan 1.....

HTH, John *** Please rate all useful posts ***